Bug 490922 - Partition 1 does not end on cylinder boundary
Partition 1 does not end on cylinder boundary
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 491748 497668 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-18 11:23 EDT by Ronald Warsow
Modified: 2012-09-13 10:23 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-19 21:53:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot: Partition 1 does not end on cylinder boundary (120.12 KB, image/png)
2009-03-18 11:23 EDT, Ronald Warsow
no flags Details

  None (edit)
Description Ronald Warsow 2009-03-18 11:23:56 EDT
Created attachment 335715 [details]
screenshot: Partition 1 does not end on cylinder boundary

Description of problem:
problem with partition layout (screenshot attached) 


Version-Release number of selected component (if applicable):
boot.iso from 17.03.2009
anaconda-11.5.0.31-1.i586.rpm

How reproducible:


Steps to Reproduce:
1. install in a VM via boot.iso
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 David Lehman 2009-03-19 21:02:41 EDT
We are aware of the fact that we are not creating partitions on cylinder boundaries at this time. We are interested in determining if it is actually necessary or if it is just something that people do out of some vague fear. If you are seeing any negative consequences, or know of any, please let us know.
Comment 2 Ronald Warsow 2009-03-19 21:44:40 EDT
Head Scratch

up to now my "vague fear" only is that we/you will start to see this or similar bug reports from people are able to do "fdisk" on c-l-i...

close this one !
Comment 3 David Lehman 2009-03-19 21:53:42 EDT
As you wish.
Comment 4 Chris Lumens 2009-03-23 16:20:21 EDT
*** Bug 491748 has been marked as a duplicate of this bug. ***
Comment 5 Chris Lumens 2009-04-27 10:20:53 EDT
*** Bug 497668 has been marked as a duplicate of this bug. ***
Comment 6 Suresh Kolsur 2012-02-01 03:58:42 EST
Hi, I have encountered the same problem with RHEL6.2 virtual machine.

[root@vmrlnx179-74 ~]# fdisk -l

Disk /dev/sda: 17.2 GB, 17179869184 bytes
64 heads, 32 sectors/track, 16384 cylinders
Units = cylinders of 2048 * 512 = 1048576 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0005b2b5

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           2         201      204800   83  Linux
Partition 1 does not end on cylinder boundary.
/dev/sda2             202        2249     2097152   82  Linux swap / Solaris
Partition 2 does not end on cylinder boundary.
/dev/sda3            2250       16384    14474240   83  Linux
Partition 3 does not end on cylinder boundary.

Disk /dev/sdb: 10.7 GB, 10737418240 bytes
64 heads, 32 sectors/track, 10240 cylinders
Units = cylinders of 2048 * 512 = 1048576 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xc0ddf28b

   Device Boot      Start         End      Blocks   Id  System
Comment 7 David Lehman 2012-02-01 09:42:20 EST
(In reply to comment #6)
> Hi, I have encountered the same problem with RHEL6.2 virtual machine.
> 

Please see comment 1.
Comment 8 bart.leyers 2012-09-13 04:38:12 EDT
(In reply to comment #1)
> We are aware of the fact that we are not creating partitions on cylinder
> boundaries at this time. We are interested in determining if it is actually
> necessary or if it is just something that people do out of some vague fear.
> If you are seeing any negative consequences, or know of any, please let us
> know.

Hi,

If you are not using cylinder boundaries, what do you
use to create partitions ?
Comment 9 David Lehman 2012-09-13 10:23:40 EDT
(In reply to comment #8)
> (In reply to comment #1)
> > We are aware of the fact that we are not creating partitions on cylinder
> > boundaries at this time. We are interested in determining if it is actually
> > necessary or if it is just something that people do out of some vague fear.
> > If you are seeing any negative consequences, or know of any, please let us
> > know.
> 
> Hi,
> 
> If you are not using cylinder boundaries, what do you
> use to create partitions ?

We use sectors. We align them according to the alignment data provided by the kernel for each block device.

Note You need to log in before you can comment on or make changes to this bug.