Bug 497835 - Key repeating doesn't work
Key repeating doesn't work
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: tigervnc (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On: 496786
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-27 10:01 EDT by Adam Tkac
Modified: 2013-04-30 19:42 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 496786
Environment:
Last Closed: 2009-05-21 08:42:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Adam Tkac 2009-04-27 10:01:57 EDT
+++ This bug was initially created as a clone of Bug #496786 +++

Description of problem:
tigervnc server is very buggy.

Version-Release number of selected component (if applicable):
0.0.90-0.5.20090403svn3751.fc11

How reproducible:
Reproduces every time for me.

Steps to Reproduce:
1. Start up the tigervnc-server in fedora 11 / ppc
2. Use ultravnc client (Windows v. 1.0.5) to connect to the server
3. Notice that client starts up briefly then shuts down saying connection was terminated.
4. Use TightVNC client for Windows (1.3.1.0) to connect to the server.
5. Notice that the client starts up, paints the screen, but then goes blank.  After that, you must find an move objects on the desktop for it to repaint the screen.
6. With TightVNC, the server is usable, but still bug-ridden.  Besides the initial blank screen, another problem is that it frequently drops special characters when I type them, such as hyphen, colon, and also seems to drop the fact that the shift key is pressed.  Still another problem is that auto-repeat on keys does not function at all.

I use both the TightVNC and UltraVNC clients for vnc servers on other Linux machines (RHEL 5.3, for example) with no problems at all, so I don't think it's the client.

Further, I should note that I recently updated the tigervnc-server because I had been having other problems with it: in the previous version, there were frequent 13-second delays from getting screen updates after a change occurred.  Taking the tigervnc-server update cleared up that problem, but introduced these other bugs.
Comment 1 Ken Roser 2009-05-06 01:27:30 EDT
I'm using F11 preview and also have the loss of keyboard repeat when using vncserver(tigervnc-server-0.0.90-0.6.20090427svn3789.fc11.i586).  Perhaps the following excerpt from the vnc log would be useful.


Window manager warning: Log level 32: could not find XKB extension.

** (gnome-settings-daemon:17408): WARNING **: XKB extension not available

** (gnome-settings-daemon:17408): WARNING **: Neither XKeyboard not Xfree86's keyboard extensions are available,
no way to support keyboard autorepeat rate settings
Comment 2 Adam Tkac 2009-05-20 04:32:03 EDT
Could you check if packages from http://kojiweb.fedoraproject.org/koji/taskinfo?taskID=1365483 solve your problem, please?
Comment 3 Ken Roser 2009-05-20 10:33:37 EDT
I installed tigervnc-server-0.0.90-0.9.1.fc11.i586.rpm from http://kojiweb.fedoraproject.org/koji/taskinfo?taskID=1365483 and this does appear to have fixed the key repeat problem.
Comment 4 Adam Tkac 2009-05-21 08:42:24 EDT
Fixed in tigervnc-0.0.90-0.10.fc11.

Note You need to log in before you can comment on or make changes to this bug.