Bug 496786 - Most recent tigervnc-server is very buggy.
Most recent tigervnc-server is very buggy.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: tigervnc (Show other bugs)
rawhide
powerpc Linux
low Severity medium
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 497835
  Show dependency treegraph
 
Reported: 2009-04-21 03:01 EDT by Corey Ashford
Modified: 2013-04-30 19:42 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 497835 (view as bug list)
Environment:
Last Closed: 2009-04-27 10:04:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Corey Ashford 2009-04-21 03:01:36 EDT
Description of problem:
tigervnc server is very buggy.

Version-Release number of selected component (if applicable):
0.0.90-0.5.20090403svn3751.fc11

How reproducible:
Reproduces every time for me.

Steps to Reproduce:
1. Start up the tigervnc-server in fedora 11 / ppc
2. Use ultravnc client (Windows v. 1.0.5) to connect to the server
3. Notice that client starts up briefly then shuts down saying connection was terminated.
4. Use TightVNC client for Windows (1.3.1.0) to connect to the server.
5. Notice that the client starts up, paints the screen, but then goes blank.  After that, you must find an move objects on the desktop for it to repaint the screen.
6. With TightVNC, the server is usable, but still bug-ridden.  Besides the initial blank screen, another problem is that it frequently drops special characters when I type them, such as hyphen, colon, and also seems to drop the fact that the shift key is pressed.  Still another problem is that auto-repeat on keys does not function at all.

I use both the TightVNC and UltraVNC clients for vnc servers on other Linux machines (RHEL 5.3, for example) with no problems at all, so I don't think it's the client.

Further, I should note that I recently updated the tigervnc-server because I had been having other problems with it: in the previous version, there were frequent 13-second delays from getting screen updates after a change occurred.  Taking the tigervnc-server update cleared up that problem, but introduced these other bugs.
Comment 1 Adam Tkac 2009-04-27 10:04:05 EDT
All problems except keyboard repeating issue should be fixed in tigervnc-0.0.90-0.6.20090427svn3789.fc11. Keyboard issue will be tracked under bug #497835. If problems still exist please note here.
Comment 2 Corey Ashford 2009-04-27 17:04:02 EDT
I tried the above-mentioned server, and this is what I get when I start up the server:

localhost.localdomain:corey-61% vncserver -depth 16 -geometry 1280x875

WARNING: The first attempt to start Xvnc failed, possibly because the X Font
Server is not running and this system does not use a font catalog.  Attempting
to determine an appropriate font path for this system and restart Xvnc using
that font path ...
Could not start Xvnc.


If I run the 0.0.90-0.5 version, this problem does not occur.

I should mention that after seeing that error message, I installed the xfs package and started up the xfs service:
localhost.localdomain:corey-68% /sbin/service xfs status
xfs (pid  16168) is running...

Uninstalling the 0.6 version and reinstalling the 0.5 version got me going again (but with the know bugs, of course).
Comment 3 Corey Ashford 2009-04-27 17:13:49 EDT
My previous comments were not clear... I'd like to clarify that starting up the xfs server did *not* solve the problem; the error message still occurs even with the xfs server running.
Comment 4 Adam Tkac 2009-04-28 04:51:59 EDT
Hm, do you have xorg-x11-fonts-misc package installed?
Comment 5 Corey Ashford 2009-04-28 15:09:18 EDT
I just now tried that and it did indeed fix the problems (except for the key repeat).

So this is a change of behavior that we now need xfs and the misc fonts package installed?  Should these xorg packages be on the list of dependencies of the tigervnc-server rpm?
Comment 6 Adam Tkac 2009-04-29 07:23:31 EDT
I opened separate bug for missing dependency (bug #498184). Installation of xorg-x11-fonts-misc is sufficient and running xfs is not required.
Comment 7 Dick Dunbar 2009-08-05 03:30:07 EDT
I have tigerVNC 0.91-0.11.fc11 installed.
Worked great while I was on the same internal network on a fresh Fedora install.

Connecting from home with Cisco VPN to that same network,
using TightVNC Viewer version 1.3.9, the desktop still works correctly,
but the session will not accept any keyboard entries ... just mouse clicks.

I'm stumped.  Is there a configuration change I missed?
Comment 8 NM 2009-11-23 11:32:32 EST
I just freshly installed FC12 (2.6.31.6-134.fc12.x86_64). 

As root: service vncserver start 
returns:
WARNING: The first attempt to start Xvnc failed, possibly because the X Font
Server is not running and this system does not use a font catalog.  Attempting
to determine an appropriate font path for this system and restart Xvnc using
that font path ...
Could not start Xvnc.

I do have xorg-x11-fonts-misc installed. Is it possible that the bug-fix mentioned above did not propagated into FC12?

In any case what can I do here? 
Thanks, 
Andrew

Note You need to log in before you can comment on or make changes to this bug.