Bug 497851 - QGIS segmentation fault after qt update
QGIS segmentation fault after qt update
Status: CLOSED DUPLICATE of bug 498111
Product: Fedora
Classification: Fedora
Component: qgis (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Douglas E. Warner
Fedora Extras Quality Assurance
:
Depends On: 498111
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-27 10:56 EDT by christy.m.n
Modified: 2009-07-30 15:13 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-30 15:13:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description christy.m.n 2009-04-27 10:56:18 EDT
Description of problem:
In fedora 9 i386 and x86_64 and fedora 10 i368, QGIS no longer started after a recent update.  I believe it was related to the update of qt to qt-4.5.0-14


Version-Release number of selected component (if applicable):
qgis-1.0.1-1.fc10.i386 from fedora 10 updates repository

qgis-1.0.1-1.fc9.x86_64 from silfreednet repository

qgis 0.11 custom build against geos 3 for fedora 9 x86_64 

How reproducible:
Always

Steps to Reproduce:
1. attempt to start QGIS
  
Actual results:
segmentation fault


Expected results:
Program launches

Additional info:
gdb traceback on Fedora 10 i386

[Thread debugging using libthread_db enabled]
warning: "/usr/lib/debug/usr/lib/libcurl.so.4.1.1.debug": The separate debug info file has no debug info
warning: "/usr/lib/debug/usr/lib/atlas/liblapack.so.3.0.debug": The separate debug info file has no debug info
warning: "/usr/lib/debug/usr/lib/atlas/libblas.so.3.0.debug": The separate debug info file has no debug info
[New Thread 0xb7fd4770 (LWP 12139)]
Detaching after fork from child process 12146.

Program received signal SIGSEGV, Segmentation fault.
0x05b9d8b4 in QListData::isEmpty () at ../../src/corelib/tools/qlist.h:88
88	    inline bool isEmpty() const { return d->end  == d->begin; }
Comment 1 cje 2009-04-29 06:37:39 EDT
see also bug 497741.
Comment 2 Rex Dieter 2009-04-29 10:30:48 EDT
please give the full backtrace, not just the last item.
Comment 3 Rex Dieter 2009-04-29 10:38:49 EDT
Does this crash in a kde desktop or != kde or both?
Comment 4 Rex Dieter 2009-04-29 11:02:50 EDT
likely another libgdal issue, adding dep on bug #498111
Comment 5 christy.m.n 2009-04-29 11:39:42 EDT
(In reply to comment #2)
> please give the full backtrace, not just the last item.  

Sorry, here is the gdb backtrace output:

GNU gdb Fedora (6.8-29.fc10)
Copyright (C) 2008 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i386-redhat-linux-gnu"...
(gdb) run
Starting program: /usr/bin/qgis 
[Thread debugging using libthread_db enabled]
warning: "/usr/lib/debug/usr/lib/atlas/liblapack.so.3.0.debug": The separate debug info file has no debug info
warning: "/usr/lib/debug/usr/lib/atlas/libblas.so.3.0.debug": The separate debug info file has no debug info
[New Thread 0xb7fd0770 (LWP 10016)]
Detaching after fork from child process 10019.

Program received signal SIGSEGV, Segmentation fault.
0x00a198b4 in QListData::isEmpty () at ../../src/corelib/tools/qlist.h:88
88	    inline bool isEmpty() const { return d->end  == d->begin; }
(gdb) bt
#0  0x00a198b4 in QListData::isEmpty () at ../../src/corelib/tools/qlist.h:88
#1  QList<_XEvent>::isEmpty () at ../../src/corelib/tools/qlist.h:123
#2  x11EventSourcePrepare (s=0x829f378, timeout=0xbfffdf88)
    at kernel/qguieventdispatcher_glib.cpp:79
#3  0x01b73162 in IA__g_main_context_prepare (context=0x829e6c0, 
    priority=0xbfffdff8) at gmain.c:2464
#4  0x01b735ea in g_main_context_iterate (context=0x829e6c0, block=1, 
    dispatch=1, self=0x829c588) at gmain.c:2758
#5  0x01b73ac1 in IA__g_main_context_iteration (context=0x829e6c0, may_block=1)
    at gmain.c:2841
#6  0x0203fb07 in link_main_iteration (block_for_reply=1) at linc.c:285
#7  0x02021d5e in giop_recv_buffer_get (ent=0xbfffe0ac, timeout=0xbfffe0c4)
    at giop-recv-buffer.c:727
#8  0x02026f46 in ORBit_small_invoke_stub (obj=0x82df070, m_data=0x2003ca0, 
    ret=0xbfffe190, args=0x0, ctx=0x0, ev=0xbfffe1d8) at orbit-small.c:660
#9  0x02027179 in ORBit_small_invoke_stub_n (object=0x82df070, 
    methods=0x829f378, index=<value optimized out>, ret=0xbfffe190, args=0x0, 
    ctx=0x0, ev=0xbfffe1d8) at orbit-small.c:577
#10 0x0203400a in ORBit_c_stub_invoke (obj=0x82df070, methods=0x2003d24, 
    method_index=4, ret=0xbfffe190, args=0x0, ctx=0x0, ev=0xbfffe1d8, 
    class_id=0, method_offset=20, 
    skel_impl=0x1ff3810 <_ORBIT_skel_small_ConfigServer_ping>) at poa.c:2649
#11 0x01ff5fce in ConfigServer_ping (_obj=0x82df070, ev=0xbfffe1d8)
---Type <return> to continue, or q <return> to quit---
    at GConfX-stubs.c:279
#12 0x01fdada7 in gconf_activate_server (start_if_not_found=1, 
    error=0xbfffe390) at gconf-internals.c:2857
#13 0x01fe9309 in try_to_contact_server () at gconf.c:2234
#14 gconf_get_config_server (start_if_not_found=1, err=0x829f378)
    at gconf.c:2278
#15 0x01fea246 in gconf_engine_connect (conf=0x82d7150, start_if_not_found=1, 
    err=0xbfffe390) at gconf.c:364
#16 0x01fea4c6 in gconf_engine_get_database (conf=0x82d7150, 
    start_if_not_found=136967032, err=0xbfffe390) at gconf.c:439
#17 0x01fed68d in gconf_engine_get_fuller (conf=0x82d7150, 
    key=0x82d90a0 "/desktop/gnome/interface/gtk_theme", 
    locale=0x829c218 "en_US.utf8", use_schema_default=1, 
    is_default_p=0xbfffe394, is_writable_p=0xbfffe398, 
    schema_name_p=0xbfffe38c, err=0xbfffe390) at gconf.c:993
#18 0x01feda4e in gconf_engine_get_entry (conf=0x82d7150, 
    key=0x82d90a0 "/desktop/gnome/interface/gtk_theme", 
    locale=0x829c218 "en_US.utf8", use_schema_default=1, err=0xbfffe418)
    at gconf.c:1110
#19 0x01ff0db4 in get (client=0x82d8408, 
    key=0x82d90a0 "/desktop/gnome/interface/gtk_theme", use_default=1, 
    error=0xbfffe418) at gconf-client.c:1240
#20 0x01ff0f5e in gconf_client_get_full (client=0x82d8408, 
---Type <return> to continue, or q <return> to quit---
    key=0x82d90a0 "/desktop/gnome/interface/gtk_theme", locale=0x0, 
    use_schema_default=1, err=0xbfffe458) at gconf-client.c:1287
#21 0x01ff1d31 in gconf_client_get_string (client=0x82d8408, 
    key=0x82d90a0 "/desktop/gnome/interface/gtk_theme", err=0xbfffe500)
    at gconf-client.c:1486
#22 0x00d1dbe9 in getGConfString () at styles/gtksymbols.cpp:347
#23 getThemeName () at styles/gtksymbols.cpp:392
#24 0x00d1e1c0 in init_gtk_window () at styles/gtksymbols.cpp:401
#25 0x00d1f5dd in QGtk::initGtkWidgets () at styles/gtksymbols.cpp:656
#26 0x00d037b5 in QGtkStyle (this=0x82d5ea8) at styles/qgtkstyle.cpp:221
#27 0x00c7ac22 in QStyleFactory::create (key=@0xbfffe718)
    at styles/qstylefactory.cpp:169
#28 0x0097e6e8 in QApplication::style () at kernel/qapplication.cpp:1346
#29 0x009e97d8 in qt_set_x11_resources (font=0x0, fg=0x0, bg=0x0, button=0x0)
    at kernel/qapplication_x11.cpp:1229
#30 0x009f387b in qt_init (priv=0x829b6f0, display=0x0, visual=0, colormap=0)
    at kernel/qapplication_x11.cpp:2311
#31 0x0097ea73 in QApplicationPrivate::construct (this=0x829b6f0, dpy=0x0, 
    visual=0, cmap=0) at kernel/qapplication.cpp:762
#32 0x0097f63b in QApplication (this=0xbffff5dc, argc=@0xbffff730, 
    argv=0xbffff7b4, GUIenabled=<value optimized out>, _internal=263171)
    at kernel/qapplication.cpp:718
#33 0x0046db90 in QgsApplication (this=0xbffff5dc, argc=@0xbffff730, 
---Type <return> to continue, or q <return> to quit---
    argv=0xbffff7b4, GUIenabled=<value optimized out>)
    at /usr/src/debug/qgis_1.0.1/src/core/qgsapplication.cpp:55
#34 0x0809ad78 in main (argc=0, argv=0xbffff7b4)
    at /usr/src/debug/qgis_1.0.1/src/app/main.cpp:390
Comment 6 christy.m.n 2009-04-29 11:42:36 EDT
(In reply to comment #3)
> Does this crash in a kde desktop or != kde or both?  

The system does not have KDE, so it's crashing in GNOME with qt installed.
Comment 7 Zirneklitis 2009-05-05 02:32:25 EDT
I have tested under Fedora 11 Preview / GNOME. The same error when run as ordinary user. qgis CAN BE RUN only with root privileges !!!

(The same as https://bugzilla.redhat.com/show_bug.cgi?id=497741)
Comment 8 Zirneklitis 2009-05-05 03:44:12 EDT
qgis  works as expected under Fedora 11 Preview / Xfce
Comment 9 christy.m.n 2009-06-10 08:29:27 EDT
I have tried QGIS in GNOME on Fedora 9, 10 and now 11 and it still segfaults.  Possibly related to https://bugzilla.redhat.com/show_bug.cgi?id=498111 ?  I'm trying rebuilding gdal with the suggesting in comment 10 of that bug.
Comment 10 christy.m.n 2009-06-10 08:34:57 EDT
the comment I was referring to: https://bugzilla.redhat.com/show_bug.cgi?id=498111#c10
Comment 11 fred2 2009-06-13 01:59:17 EDT
i got qgis segfault under fedora 10/gnome. i upgraded to f11, with same problem.
i tried the workaround given at http://forum.qgis.org/viewtopic.php?f=3&t=4335#p8204
(run /usr/bin/qtconfig-qt4; appearance -> select gui style; change from default to e.g., cleanlooks); then file -> save.
qgis now runs ok.

for ref:
[root@localhost ~]# rpm -qa|grep qgis
qgis-1.0.1-2.fc11.x86_64
qgis-grass-1.0.1-2.fc11.x86_64
qgis-python-1.0.1-2.fc11.x86_64
[root@localhost ~]# uname -a
Linux localhost.localdomain 2.6.29.4-167.fc11.x86_64 #1 SMP Wed May 27 17:27:08 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux
Comment 12 christy.m.n 2009-06-13 08:25:21 EDT
Just tried changing the qt gui style, and now QGIS works for me on Fedora 11 as well.
Comment 13 Pontus Enhager 2009-06-14 04:33:55 EDT
also tried solution in Comment #11 which seems to work (no heavier work done yet though)
Comment 14 Troels Arvin 2009-07-30 07:21:22 EDT
An additional confirmation: I also see qgis crashing in a fresh FC11 (including all updates). The gui style workaround/hack works for now.
Comment 15 Douglas E. Warner 2009-07-30 15:13:55 EDT
Closing this bug as a dupe of bug#498111.

*** This bug has been marked as a duplicate of bug 498111 ***

Note You need to log in before you can comment on or make changes to this bug.