Bug 497874 - Plethora of typos in error messages
Plethora of typos in error messages
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: avahi (Show other bugs)
5.3
All Linux
low Severity low
: rc
: ---
Assigned To: Lennart Poettering
BaseOS QE
:
: 515115 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-27 13:04 EDT by Jay Turner
Modified: 2015-01-07 19:16 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-22 14:13:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Turner 2009-04-27 13:04:14 EDT
Description of problem:
With 0.6.16-1.el5_2.1 there's a consistent misspelling of the work "received" in the error messages.  Appears that "response" gets misspelled a few times as well.  Should really do an audit to ensure we're not shipping code with embarrassing spellings.

Version-Release number of selected component (if applicable):
0.6.16-1.el5_2.1

Additional info:

# grep -ri "recieved" *
avahi-autoipd/main.c:                    daemon_log(LOG_INFO, "Recieved conflicting normal ARP packet.");
avahi-autoipd/main.c:                        daemon_log(LOG_INFO, "Recieved conflicting probe ARP packet.");
avahi-core/server.c.0001-Don-t-get-confused-by-UDP-packets-with-a-source-port:            avahi_log_debug("Recieved conflicting probe [%s]. Local host won.", t);
avahi-core/server.c.0001-Don-t-get-confused-by-UDP-packets-with-a-source-port:            avahi_log_debug("Recieved conflicting probe [%s]. Local host lost. Withdrawing.", t);
avahi-core/server.c.0001-Don-t-get-confused-by-UDP-packets-with-a-source-port:                avahi_log_debug("Recieved goodbye record for one of our records [%s]. Refreshing.", t);
avahi-core/server.c.0001-Don-t-get-confused-by-UDP-packets-with-a-source-port:                avahi_log_debug("Recieved record with bad TTL [%s]. Refreshing.", t);
avahi-core/server.c.0001-Don-t-get-confused-by-UDP-packets-with-a-source-port:            avahi_log_debug("Recieved conflicting record [%s] with local record to be. Withdrawing.", t);
avahi-core/server.c.0001-Don-t-get-confused-by-UDP-packets-with-a-source-port:            avahi_log_debug("Recieved conflicting record [%s]. Resetting our record.", t);
avahi-core/server.c.0001-Don-t-get-confused-by-UDP-packets-with-a-source-port:        avahi_log_warn("Recieved packet from invalid interface.");
avahi-core/server.c.0001-Don-t-get-confused-by-UDP-packets-with-a-source-port:        avahi_log_warn("Recieved invalid packet.");
avahi-core/server.c.0001-Don-t-get-confused-by-UDP-packets-with-a-source-port:            avahi_log_warn("Recieved repsonse with invalid source port %u on interface '%s.%i'", port, i->hardware->name, i->protocol);
avahi-core/server.c.0001-Don-t-get-confused-by-UDP-packets-with-a-source-port:            avahi_log_warn("Recieved response with invalid TTL %u on interface '%s.%i'.", ttl, i->hardware->name, i->protocol);
avahi-core/server.c.0001-Don-t-get-confused-by-UDP-packets-with-a-source-port:        avahi_log_warn("Recieved invalid packet.");
avahi-core/server.c.0001-Don-t-get-confused-by-UDP-packets-with-a-source-port:        avahi_log_warn("Recieved legacy unicast response with unknown id");
avahi-core/server.c.0001-Don-t-get-confused-by-UDP-packets-with-a-source-port:            avahi_log_error("Incoming packet recieved on address that isn't local.");
avahi-core/server.c:            avahi_log_debug("Recieved conflicting probe [%s]. Local host won.", t);
avahi-core/server.c:            avahi_log_debug("Recieved conflicting probe [%s]. Local host lost. Withdrawing.", t);
avahi-core/server.c:                avahi_log_debug("Recieved goodbye record for one of our records [%s]. Refreshing.", t);
avahi-core/server.c:                avahi_log_debug("Recieved record with bad TTL [%s]. Refreshing.", t);
avahi-core/server.c:            avahi_log_debug("Recieved conflicting record [%s] with local record to be. Withdrawing.", t);
avahi-core/server.c:            avahi_log_debug("Recieved conflicting record [%s]. Resetting our record.", t);
avahi-core/server.c:        avahi_log_warn("Recieved packet from invalid interface.");
avahi-core/server.c:        avahi_log_warn("Recieved invalid packet.");
avahi-core/server.c:            avahi_log_warn("Recieved repsonse with invalid source port %u on interface '%s.%i'", port, i->hardware->name, i->protocol);
avahi-core/server.c:            avahi_log_warn("Recieved response with invalid TTL %u on interface '%s.%i'.", ttl, i->hardware->name, i->protocol);
avahi-core/server.c:        avahi_log_warn("Recieved invalid packet.");
avahi-core/server.c:        avahi_log_warn("Recieved legacy unicast response with unknown id");
avahi-core/server.c:            avahi_log_error("Incoming packet recieved on address that isn't local.");
avahi-core/iface.c:     * packet is recieved. We have to work around that limitation by
docs/NEWS:  * Don't disable all static services when SIGHUP is recieved.

# grep -ri "repsonse" *
avahi-core/server.c.0001-Don-t-get-confused-by-UDP-packets-with-a-source-port:            avahi_log_warn("Recieved repsonse with invalid source port %u on interface '%s.%i'", port, i->hardware->name, i->protocol);
avahi-core/server.c:            avahi_log_warn("Recieved repsonse with invalid source port %u on interface '%s.%i'", port, i->hardware->name, i->protocol);
Comment 8 Lennart Poettering 2009-06-08 16:16:49 EDT
These are the same typos as in bug 429138.

This should be merged, but I guess that would upset the errata system, so I am not going to do that.
Comment 18 errata-xmlrpc 2009-06-22 14:13:56 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1119.html
Comment 19 Lennart Poettering 2009-11-13 19:11:16 EST
*** Bug 515115 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.