Bug 497997 - Crash on trying to print
Crash on trying to print
Status: CLOSED DUPLICATE of bug 478933
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-28 07:18 EDT by David Woodhouse
Modified: 2009-05-19 11:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-29 04:07:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
PPD fille (22.93 KB, text/plain)
2009-04-28 07:25 EDT, David Woodhouse
no flags Details

  None (edit)
Description David Woodhouse 2009-04-28 07:18:43 EDT
For the last day or two, OOo has been crashing occasionally when I try to print. I don't remember trying to print from it since upgrading to F-11, until yesterday.

It's done it on two simple oowriter documents; letters which I've typed into OOo from scratch.

It doesn't do it all the time -- usually _not_ the first time I try to print. But when I correct a typo and print the page again, it's more likely to happen.

(I)    x.org loaded video driver of...
(WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
(II) Loading /usr/lib64/xorg/modules/drivers//nv_drv.so
(--) Depth 24 pixmap format is 32 bpp
(III)  Desktop is: GNOME
(IV)   openoffice.org-kde version is: package openoffice.org-kde is not installed
(V)    libgcj version is: libgcj-4.4.0-1-x86_64
(VI)   kernel is: Linux 2.6.29.1-100.fc11.x86_64 #1 SMP Sat Apr 18 18:16:41 EDT 2009 x86_64 x86_64 x86_64
(VII)  OpenOffice.org core rpm version is: openoffice.org-core-3.1.0-10.2.fc11-x86_64
(VIII) accessibility is: false
(IX)   gtk theme is: Nodoka
(X)    icon theme is: Fedora
(XI)   metacity theme is: Nodoka
(XII)  fedora release is: Fedora release 10.92 (Rawhide)
(XIII) LANG is: en_GB.UTF-8
...start free space details ...
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/sda3            206237776 166330668  29430800  85% /
/dev/sda3            206237776 166330668  29430800  85% /
...end free space details ...
...start (default) java details ...
java version "1.6.0_0"
OpenJDK Runtime Environment (IcedTea6 1.4.1) (fedora-19.b14.fc11-x86_64)
OpenJDK 64-Bit Server VM (build 14.0-b08, mixed mode)
...end (default) java details ...
...start sestatus details ...
SELinux status:                 enabled
SELinuxfs mount:                /selinux
Current mode:                   permissive
Mode from config file:          permissive
Policy version:                 24
Policy from config file:        targeted
...end sestatus details ...
...start stackreport details ...
0x7fe0582fbf7f: 0x1ebbc8: /usr/lib64/openoffice.org3/program/../basis-link/ure-link/lib/libuno_sal.so.3 + 0x37f7f
0x7fe0582fcabe: 0x1ebbc8: /usr/lib64/openoffice.org3/program/../basis-link/ure-link/lib/libuno_sal.so.3 + 0x38abe
0x3ac740ef20: 0x16d88: /lib64/libpthread.so.0 + 0xef20
0x7fe0535bebdc: 0xa98f0: /usr/lib64/openoffice.org3/program/../basis-link/program/libpsplx.so + 0x4ebdc (psp::PPDParser::getKey(String const&) const + 0x1c)
0x7fe0551dc6c9: 0x3eb608: /usr/lib64/openoffice.org3/program/../basis-link/program/libvcllx.so + 0x1536c9
0x7fe0551ddbf2: 0x3eb608: /usr/lib64/openoffice.org3/program/../basis-link/program/libvcllx.so + 0x154bf2 (JobSetup::Reset() + 0x202)
0x7fe0565e6eb1: 0x4870b0: /usr/lib64/openoffice.org3/program/../basis-link/program/libsvtlx.so + 0x248eb1 (PrintDialog::Execute() + 0xde1)
0x7fe056fd9574: 0x444088: /usr/lib64/openoffice.org3/program/../basis-link/program/libsfxlx.so + 0x27e574
0x7fe0570189b2: 0x444088: /usr/lib64/openoffice.org3/program/../basis-link/program/libsfxlx.so + 0x2bd9b2 (SfxShell::ExecuteSlot(SfxRequest&, SfxInterface const*) + 0x62)
0x7fe03b1b6366: 0xbb3938: /usr/lib64/openoffice.org3/program/../basis-link/program/libswlx.so + 0x9d7366 (SwView::ExecutePrint(SfxRequest&) + 0x186)
0x7fe057006808: 0x444088: /usr/lib64/openoffice.org3/program/../basis-link/program/libsfxlx.so + 0x2ab808
0x7fe057006c4b: 0x444088: /usr/lib64/openoffice.org3/program/../basis-link/program/libsfxlx.so + 0x2abc4b
0x7fe0570339ca: 0x444088: /usr/lib64/openoffice.org3/program/../basis-link/program/libsfxlx.so + 0x2d89ca
0x7fe055357789: 0x3eb608: /usr/lib64/openoffice.org3/program/../basis-link/program/libvcllx.so + 0x2ce789
0x7fe04ccd2418: 0x8ec70: /usr/lib64/openoffice.org/basis3.1/program/libvclplug_genlx.so + 0x61418 (SalDisplay::DispatchInternalEvent() + 0xb8)
0x7fe04cf44b00: 0x57528: /usr/lib64/openoffice.org/basis3.1/program/libvclplug_gtklx.so + 0x18b00
0x3ac843818e: 0xde1e8: /lib64/libglib-2.0.so.0 + 0x3818e (g_main_context_dispatch + 0x22e)
0x3ac843b8e8: 0xde1e8: /lib64/libglib-2.0.so.0 + 0x3b8e8
0x3ac843ba5c: 0xde1e8: /lib64/libglib-2.0.so.0 + 0x3ba5c (g_main_context_iteration + 0x6c)
0x7fe04cf44c6d: 0x57528: /usr/lib64/openoffice.org/basis3.1/program/libvclplug_gtklx.so + 0x18c6d
0x7fe055177e8e: 0x3eb608: /usr/lib64/openoffice.org3/program/../basis-link/program/libvcllx.so + 0xeee8e (Application::Yield(bool) + 0x3e)
0x7fe055177f07: 0x3eb608: /usr/lib64/openoffice.org3/program/../basis-link/program/libvcllx.so + 0xeef07 (Application::Execute() + 0x27)
0x7fe05807616b: 0x73eb8: /usr/lib64/openoffice.org3/program/../basis-link/program/libsofficeapp.so + 0x2916b
0x7fe05517caf9: 0x3eb608: /usr/lib64/openoffice.org3/program/../basis-link/program/libvcllx.so + 0xf3af9
0x7fe05517cbf5: 0x3eb608: /usr/lib64/openoffice.org3/program/../basis-link/program/libvcllx.so + 0xf3bf5 (SVMain() + 0x25)
0x7fe0580a86cc: 0x73eb8: /usr/lib64/openoffice.org3/program/../basis-link/program/libsofficeapp.so + 0x5b6cc (soffice_main + 0x9c)
0x400f8b: 0x1930: /usr/lib64/openoffice.org3/program/soffice.bin + 0xf8b (main + 0xb)
0x3ac681e83d: 0x167b40: /lib64/libc.so.6 + 0x1e83d (__libc_start_main + 0xfd)
0x400eb9: 0x1930: /usr/lib64/openoffice.org3/program/soffice.bin + 0xeb9
...end stackreport details ...
...start sample ldd details ...
	linux-vdso.so.1 =>  (0x00007fffe5fff000)
	libgtk-x11-2.0.so.0 => /usr/lib64/libgtk-x11-2.0.so.0 (0x00007f0edd68f000)
	libgdk-x11-2.0.so.0 => /usr/lib64/libgdk-x11-2.0.so.0 (0x00007f0edd3ef000)
	libatk-1.0.so.0 => /usr/lib64/libatk-1.0.so.0 (0x00007f0edd1d0000)
	libgio-2.0.so.0 => /lib64/libgio-2.0.so.0 (0x00007f0edcf57000)
	libpangoft2-1.0.so.0 => /usr/lib64/libpangoft2-1.0.so.0 (0x00007f0edcd28000)
	libgdk_pixbuf-2.0.so.0 => /usr/lib64/libgdk_pixbuf-2.0.so.0 (0x00007f0edcb0a000)
	libpangocairo-1.0.so.0 => /usr/lib64/libpangocairo-1.0.so.0 (0x00007f0edc8ff000)
	libcairo.so.2 => /usr/lib64/libcairo.so.2 (0x00007f0edc687000)
	libpango-1.0.so.0 => /usr/lib64/libpango-1.0.so.0 (0x00007f0edc43e000)
	libfreetype.so.6 => /usr/lib64/libfreetype.so.6 (0x00007f0edc1a4000)
	libfontconfig.so.1 => /usr/lib64/libfontconfig.so.1 (0x00007f0edbf6e000)
	libgmodule-2.0.so.0 => /lib64/libgmodule-2.0.so.0 (0x00007f0edbd6b000)
	libgthread-2.0.so.0 => /lib64/libgthread-2.0.so.0 (0x00007f0edbb67000)
	librt.so.1 => /lib64/librt.so.1 (0x00007f0edb95e000)
	libdbus-glib-1.so.2 => /usr/lib64/libdbus-glib-1.so.2 (0x00007f0edb73d000)
	libdbus-1.so.3 => /lib64/libdbus-1.so.3 (0x00007f0edb4ff000)
	libgobject-2.0.so.0 => /lib64/libgobject-2.0.so.0 (0x00007f0edb2bb000)
	libglib-2.0.so.0 => /lib64/libglib-2.0.so.0 (0x00007f0edafdb000)
	libvclplug_genlx.so => /usr/lib64/openoffice.org/basis3.1/program/libvclplug_genlx.so (0x00007f0edad44000)
	libvcllx.so => /usr/lib64/openoffice.org/basis3.1/program/libvcllx.so (0x00007f0eda74b000)
	libpsplx.so => /usr/lib64/openoffice.org/basis3.1/program/libpsplx.so (0x00007f0eda458000)
	libsotlx.so => /usr/lib64/openoffice.org/basis3.1/program/libsotlx.so (0x00007f0eda1f3000)
	libutllx.so => /usr/lib64/openoffice.org/basis3.1/program/libutllx.so (0x00007f0ed9f54000)
	libtllx.so => /usr/lib64/openoffice.org/basis3.1/program/libtllx.so (0x00007f0ed9ca6000)
	libcomphelp4gcc3.so => /usr/lib64/openoffice.org/basis3.1/program/libcomphelp4gcc3.so (0x00007f0ed9945000)
	libucbhelper4gcc3.so => /usr/lib64/openoffice.org/basis3.1/program/libucbhelper4gcc3.so (0x00007f0ed96c2000)
	libuno_cppuhelpergcc3.so.3 => /usr/lib64/openoffice.org/basis3.1/program/../ure-link/lib/libuno_cppuhelpergcc3.so.3 (0x00007f0ed9419000)
	libuno_cppu.so.3 => /usr/lib64/openoffice.org/basis3.1/program/../ure-link/lib/libuno_cppu.so.3 (0x00007f0ed91eb000)
	libvos3gcc3.so => /usr/lib64/openoffice.org/basis3.1/program/libvos3gcc3.so (0x00007f0ed8fc4000)
	libuno_sal.so.3 => /usr/lib64/openoffice.org/basis3.1/program/../ure-link/lib/libuno_sal.so.3 (0x00007f0ed8bcd000)
	libXrandr.so.2 => /usr/lib64/libXrandr.so.2 (0x00007f0ed89c5000)
	libX11.so.6 => /usr/lib64/libX11.so.6 (0x00007f0ed8689000)
	libXext.so.6 => /usr/lib64/libXext.so.6 (0x00007f0ed8477000)
	libdl.so.2 => /lib64/libdl.so.2 (0x00007f0ed8273000)
	libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f0ed8056000)
	libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00007f0ed7d4a000)
	libm.so.6 => /lib64/libm.so.6 (0x00007f0ed7ac6000)
	libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00007f0ed78ab000)
	libc.so.6 => /lib64/libc.so.6 (0x00007f0ed753d000)
	libXfixes.so.3 => /usr/lib64/libXfixes.so.3 (0x00007f0ed7338000)
	libXrender.so.1 => /usr/lib64/libXrender.so.1 (0x00007f0ed712e000)
	libXinerama.so.1 => /usr/lib64/libXinerama.so.1 (0x00007f0ed6f2c000)
	libXi.so.6 => /usr/lib64/libXi.so.6 (0x00007f0ed6d22000)
	libXcursor.so.1 => /usr/lib64/libXcursor.so.1 (0x00007f0ed6b17000)
	libXcomposite.so.1 => /usr/lib64/libXcomposite.so.1 (0x00007f0ed6915000)
	libXdamage.so.1 => /usr/lib64/libXdamage.so.1 (0x00007f0ed6713000)
	libselinux.so.1 => /lib64/libselinux.so.1 (0x00007f0ed64f4000)
	libpng12.so.0 => /usr/lib64/libpng12.so.0 (0x00007f0ed62ce000)
	libpixman-1.so.0 => /usr/lib64/libpixman-1.so.0 (0x00007f0ed6088000)
	libz.so.1 => /lib64/libz.so.1 (0x00007f0ed5e73000)
	libexpat.so.1 => /lib64/libexpat.so.1 (0x00007f0ed5c4b000)
	/lib64/ld-linux-x86-64.so.2 (0x0000003ac6400000)
	libcap.so.2 => /lib64/libcap.so.2 (0x00007f0ed5a46000)
	libbasegfxlx.so => /usr/lib64/openoffice.org/basis3.1/program/libbasegfxlx.so (0x00007f0ed579e000)
	libSM.so.6 => /usr/lib64/libSM.so.6 (0x00007f0ed5595000)
	libICE.so.6 => /usr/lib64/libICE.so.6 (0x00007f0ed5379000)
	libi18nisolang1gcc3.so => /usr/lib64/openoffice.org/basis3.1/program/libi18nisolang1gcc3.so (0x00007f0ed5172000)
	libi18nutilgcc3.so => /usr/lib64/openoffice.org/basis3.1/program/libi18nutilgcc3.so (0x00007f0ed4f5f000)
	libicuuc.so.40 => /usr/lib64/libicuuc.so.40 (0x00007f0ed4c17000)
	libicudata.so.40 => /usr/lib64/libicudata.so.40 (0x00007f0ed3cd1000)
	libicule.so.40 => /usr/lib64/libicule.so.40 (0x00007f0ed3a9c000)
	libjvmaccessgcc3.so.3 => /usr/lib64/openoffice.org/basis3.1/program/../ure-link/lib/libjvmaccessgcc3.so.3 (0x00007f0ed3895000)
	libuno_salhelpergcc3.so.3 => /usr/lib64/openoffice.org/basis3.1/program/../ure-link/lib/libuno_salhelpergcc3.so.3 (0x00007f0ed3690000)
	libcrypt.so.1 => /lib64/libcrypt.so.1 (0x00007f0ed3458000)
	libxcb.so.1 => /usr/lib64/libxcb.so.1 (0x00007f0ed323d000)
	libXau.so.6 => /usr/lib64/libXau.so.6 (0x00007f0ed303b000)
	libattr.so.1 => /lib64/libattr.so.1 (0x00007f0ed2e36000)
	libuuid.so.1 => /lib64/libuuid.so.1 (0x00007f0ed2c32000)
	libfreebl3.so => /lib64/libfreebl3.so (0x00007f0ed29d2000)
...end sample ldd details ...
Comment 1 David Woodhouse 2009-04-28 07:25:12 EDT
Created attachment 341553 [details]
PPD fille

I noticed 'PPDParser' in the backtrace, so this might be relevant. The printer is a Konica Minolta 2430DL, supported by the 'foo2zjs' package in rpmfusion. I've attached its PPD file from /etc/cups/ppd/2430dl.ppd
Comment 2 David Woodhouse 2009-04-28 07:31:42 EDT
This seems repeatable now -- I print page 2 of a 2-page document, print page 1, then edit it and print page 2 again.
Comment 3 Caolan McNamara 2009-04-28 07:44:45 EDT
Hmm, that gtk print dialog was supposed to be disabled in F-11, didn't happen apparently.
Comment 4 Caolan McNamara 2009-04-29 04:07:50 EDT
As has been typically the case with this bug, attempting to reproduce even with the same .ppd and reported sequence of steps, either under or not under valgrind neither crashes for me or shows valgrind warnings that might indicate anything :-(

*** This bug has been marked as a duplicate of bug 478933 ***
Comment 5 Mark van Rossum 2009-05-19 11:41:52 EDT
Same bug here with a remote Postscript printer.

For me it is 100% reproducible for all openoffice components.

It is definitely related to the dialog, as printing by clicking the print icon works fine.

Note You need to log in before you can comment on or make changes to this bug.