This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 478933 - Openoffice crash when printing
Openoffice crash when printing
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
10
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
: Reopened
: 476037 486169 494133 497997 501926 502374 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-05 20:59 EST by Thomas Quinn
Modified: 2009-05-27 11:21 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-27 11:21:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Quinn 2009-01-05 20:59:12 EST
Description of problem:

Openoffice crashed when printing a letter.

Version-Release number of selected component (if applicable):


How reproducible:

Very intermittent.

Steps to Reproduce:
1.Open document
2.Choose file->print
3.Choose "High quality" in Advanced tab
4.Select many copies
5."Print"
  
Actual results:

Crash with the following info.

Expected results:

Printed file

Additional info:

(I)    x.org loaded video driver of...
(WW) AllowEmptyInput is on, devices using drivers 'kbd' or 'mouse' will be disabled.
(II) Loading /usr/lib/xorg/modules/drivers//nv_drv.so
(--) Depth 24 pixmap format is 32 bpp
(III)  Desktop is: GNOME
(IV)   openoffice.org-kde version is: package openoffice.org-kde is not installed
(V)    libgcj version is: libgcj-4.3.2-7-i386
(VI)   kernel is: Linux 2.6.27.9-159.fc10.i686 #1 SMP Tue Dec 16 15:12:04 EST 2008 i686 i686 i386
(VII)  OpenOffice.org core rpm version is: openoffice.org-core-3.0.0-9.10.fc10-i386
(VIII) accessibility is: false
(IX)   fedora release is: Fedora release 10 (Cambridge)
(X)    LANG is: en_US.utf8
...start free space details ...
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/mapper/VolGroup00-LogVol00
                      65570580  20080000  45490580  31% /
/dev/mapper/VolGroup00-LogVol00
                      65570580  20080000  45490580  31% /
...end free space details ...
...start (default) java details ...
java version "1.6.0_0"
IcedTea6 1.4 (fedora-7.b12.fc10-i386) Runtime Environment (build 1.6.0_0-b12)
OpenJDK Client VM (build 10.0-b19, mixed mode)
...end (default) java details ...
...start sestatus details ...
SELinux status:                 enabled
SELinuxfs mount:                /selinux
Current mode:                   enforcing
Mode from config file:          enforcing
Policy version:                 23
Policy from config file:        targeted
...end sestatus details ...
...start stackreport details ...
0x44246c4: 0x1b4a38: /usr/lib/openoffice.org3/program/../basis-link/ure-link/lib/libuno_sal.so.3 + 0x256c4
0x4424fff: 0x1b4a38: /usr/lib/openoffice.org3/program/../basis-link/ure-link/lib/libuno_sal.so.3 + 0x25fff
0x110400: 0x0:  + 0x400 (__kernel_sigreturn + 0x0)
0x56a4e1f: 0x807c0: /usr/lib/openoffice.org3/program/../basis-link/program/libpspli.so + 0x36e1f (psp::PPDParser::getKey(String const&) const + 0x2b)
0x5cc5b1c: 0x2ebbbc: /usr/lib/openoffice.org3/program/../basis-link/program/libvclli.so + 0xf1b1c
0x5cc61ee: 0x2ebbbc: /usr/lib/openoffice.org3/program/../basis-link/program/libvclli.so + 0xf21ee (JobSetup::Reset() + 0x13c)
0x605e595: 0x329240: /usr/lib/openoffice.org3/program/../basis-link/program/libsvtli.so + 0x194595 (PrintDialog::Execute() + 0x19c9)
0x63a3725: 0x2e6520: /usr/lib/openoffice.org3/program/../basis-link/program/libsfxli.so + 0x1a4725
0x63d2d22: 0x2e6520: /usr/lib/openoffice.org3/program/../basis-link/program/libsfxli.so + 0x1d3d22 (SfxShell::ExecuteSlot(SfxRequest&, SfxInterface const*) + 0xb4)
0xb24f9c3a: 0x8d9410: /usr/lib/openoffice.org3/program/../basis-link/program/libswli.so + 0x7a1c3a (SwView::ExecutePrint(SfxRequest&) + 0x504)
0xb24d1cb6: 0x8d9410: /usr/lib/openoffice.org3/program/../basis-link/program/libswli.so + 0x779cb6
0x63c6b45: 0x2e6520: /usr/lib/openoffice.org3/program/../basis-link/program/libsfxli.so + 0x1c7b45
0x63c6e92: 0x2e6520: /usr/lib/openoffice.org3/program/../basis-link/program/libsfxli.so + 0x1c7e92
0x63e2da3: 0x2e6520: /usr/lib/openoffice.org3/program/../basis-link/program/libsfxli.so + 0x1e3da3
0x63e2d59: 0x2e6520: /usr/lib/openoffice.org3/program/../basis-link/program/libsfxli.so + 0x1e3d59
0x5de7847: 0x2ebbbc: /usr/lib/openoffice.org3/program/../basis-link/program/libvclli.so + 0x213847
0xf13434: 0x65614: /usr/lib/openoffice.org/basis3.0/program/libvclplug_genli.so + 0x46434 (SalDisplay::DispatchInternalEvent() + 0x96)
0xe5713c: 0x41188: /usr/lib/openoffice.org/basis3.0/program/libvclplug_gtkli.so + 0x1213c
0x8ba301: 0xe2108: /lib/libglib-2.0.so.0 + 0x35301
0x8bc238: 0xe2108: /lib/libglib-2.0.so.0 + 0x37238 (g_main_context_dispatch + 0x1e8)
0x8bf8e3: 0xe2108: /lib/libglib-2.0.so.0 + 0x3a8e3
0x8bfaa1: 0xe2108: /lib/libglib-2.0.so.0 + 0x3aaa1 (g_main_context_iteration + 0x71)
0xe571f4: 0x41188: /usr/lib/openoffice.org/basis3.0/program/libvclplug_gtkli.so + 0x121f4
0xf19c4d: 0x65614: /usr/lib/openoffice.org/basis3.0/program/libvclplug_genli.so + 0x4cc4d (X11SalInstance::Yield(bool, bool) + 0x2f)
0x5c70991: 0x2ebbbc: /usr/lib/openoffice.org3/program/../basis-link/program/libvclli.so + 0x9c991 (Application::Yield(bool) + 0x57)
0x5c709df: 0x2ebbbc: /usr/lib/openoffice.org3/program/../basis-link/program/libvclli.so + 0x9c9df (Application::Execute() + 0x2b)
0x69ef722: 0x51904: /usr/lib/openoffice.org3/program/../basis-link/program/libsofficeapp.so + 0x1e722
0x5c73fcb: 0x2ebbbc: /usr/lib/openoffice.org3/program/../basis-link/program/libvclli.so + 0x9ffcb
0x5c74167: 0x2ebbbc: /usr/lib/openoffice.org3/program/../basis-link/program/libvclli.so + 0xa0167 (SVMain() + 0x2c)
0x6a0f6a8: 0x51904: /usr/lib/openoffice.org3/program/../basis-link/program/libsofficeapp.so + 0x3e6a8 (soffice_main + 0xd0)
0x8048c74: 0x1510: /usr/lib/openoffice.org3/program/soffice.bin + 0xc74 (main + 0x20)
0x7256e5: 0x16fd7c: /lib/libc.so.6 + 0x166e5 (__libc_start_main + 0xe5)
0x8048bc1: 0x1510: /usr/lib/openoffice.org3/program/soffice.bin + 0xbc1
...end stackreport details ...
...start sample ldd details ...
	linux-gate.so.1 =>  (0x00110000)
	libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0 (0x00158000)
	libgdk-x11-2.0.so.0 => /usr/lib/libgdk-x11-2.0.so.0 (0x0053e000)
	libatk-1.0.so.0 => /usr/lib/libatk-1.0.so.0 (0x005f6000)
	libgio-2.0.so.0 => /lib/libgio-2.0.so.0 (0x00613000)
	libpangoft2-1.0.so.0 => /usr/lib/libpangoft2-1.0.so.0 (0x00686000)
	libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0 (0x006b0000)
	libpangocairo-1.0.so.0 => /usr/lib/libpangocairo-1.0.so.0 (0x006cd000)
	libcairo.so.2 => /usr/lib/libcairo.so.2 (0x006d8000)
	libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0x00750000)
	libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x00796000)
	libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x00829000)
	libgmodule-2.0.so.0 => /lib/libgmodule-2.0.so.0 (0x00858000)
	libgthread-2.0.so.0 => /lib/libgthread-2.0.so.0 (0x0085c000)
	librt.so.1 => /lib/librt.so.1 (0x00861000)
	libdbus-glib-1.so.2 => /usr/lib/libdbus-glib-1.so.2 (0x0086b000)
	libdbus-1.so.3 => /lib/libdbus-1.so.3 (0x00889000)
	libgobject-2.0.so.0 => /lib/libgobject-2.0.so.0 (0x008ca000)
	libglib-2.0.so.0 => /lib/libglib-2.0.so.0 (0x0090b000)
	libvclplug_genli.so => /usr/lib/openoffice.org/basis3.0/program/libvclplug_genli.so (0x009ee000)
	libvclli.so => /usr/lib/openoffice.org/basis3.0/program/libvclli.so (0x00a5b000)
	libpspli.so => /usr/lib/openoffice.org/basis3.0/program/libpspli.so (0x00d4f000)
	libsotli.so => /usr/lib/openoffice.org/basis3.0/program/libsotli.so (0x00e18000)
	libutlli.so => /usr/lib/openoffice.org/basis3.0/program/libutlli.so (0x00e66000)
	libtlli.so => /usr/lib/openoffice.org/basis3.0/program/libtlli.so (0x00ed5000)
	libcomphelp4gcc3.so => /usr/lib/openoffice.org/basis3.0/program/libcomphelp4gcc3.so (0x00f57000)
	libucbhelper4gcc3.so => /usr/lib/openoffice.org/basis3.0/program/libucbhelper4gcc3.so (0x076da000)
	libuno_cppuhelpergcc3.so.3 => /usr/lib/openoffice.org/basis3.0/program/../ure-link/lib/libuno_cppuhelpergcc3.so.3 (0x058a9000)
	libuno_cppu.so.3 => /usr/lib/openoffice.org/basis3.0/program/../ure-link/lib/libuno_cppu.so.3 (0x02eb1000)
	libvos3gcc3.so => /usr/lib/openoffice.org/basis3.0/program/libvos3gcc3.so (0x05da2000)
	libuno_sal.so.3 => /usr/lib/openoffice.org/basis3.0/program/../ure-link/lib/libuno_sal.so.3 (0x06365000)
	libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0x062ef000)
	libX11.so.6 => /usr/lib/libX11.so.6 (0x07389000)
	libXext.so.6 => /usr/lib/libXext.so.6 (0x01041000)
	libdl.so.2 => /lib/libdl.so.2 (0x02b97000)
	libpthread.so.0 => /lib/libpthread.so.0 (0x02c15000)
	libstlport_gcc.so => /usr/lib/openoffice.org/basis3.0/program/../ure-link/lib/libstlport_gcc.so (0x03035000)
	libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x018cb000)
	libm.so.6 => /lib/libm.so.6 (0x035e5000)
	libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x0341a000)
	libc.so.6 => /lib/libc.so.6 (0x04be0000)
	libXcomposite.so.1 => /usr/lib/libXcomposite.so.1 (0x0335f000)
	libXdamage.so.1 => /usr/lib/libXdamage.so.1 (0x052a3000)
	libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0x01307000)
	libpng12.so.0 => /usr/lib/libpng12.so.0 (0x01744000)
	libXrender.so.1 => /usr/lib/libXrender.so.1 (0x01383000)
	libXinerama.so.1 => /usr/lib/libXinerama.so.1 (0x012c9000)
	libXi.so.6 => /usr/lib/libXi.so.6 (0x05e78000)
	libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0x05e8b000)
	libselinux.so.1 => /lib/libselinux.so.1 (0x05fe1000)
	libpixman-1.so.0 => /usr/lib/libpixman-1.so.0 (0x0330a000)
	libz.so.1 => /lib/libz.so.1 (0x02f74000)
	libexpat.so.1 => /lib/libexpat.so.1 (0x02164000)
	/lib/ld-linux.so.2 (0x005d3000)
	libnsl.so.1 => /lib/libnsl.so.1 (0x020e2000)
	libcap.so.2 => /lib/libcap.so.2 (0x02010000)
	libSM.so.6 => /usr/lib/libSM.so.6 (0x06a3f000)
	libICE.so.6 => /usr/lib/libICE.so.6 (0x06c25000)
	libi18nisolang1gcc3.so => /usr/lib/openoffice.org/basis3.0/program/libi18nisolang1gcc3.so (0x01051000)
	libbasegfxli.so => /usr/lib/openoffice.org/basis3.0/program/libbasegfxli.so (0x06aba000)
	libicuuc.so.40 => /usr/lib/libicuuc.so.40 (0x01056000)
	libicule.so.40 => /usr/lib/libicule.so.40 (0x02aeb000)
	libjvmaccessgcc3.so.3 => /usr/lib/openoffice.org/basis3.0/program/../ure-link/lib/libjvmaccessgcc3.so.3 (0x048e8000)
	libuno_salhelpergcc3.so.3 => /usr/lib/openoffice.org/basis3.0/program/../ure-link/lib/libuno_salhelpergcc3.so.3 (0x048ca000)
	libcrypt.so.1 => /lib/libcrypt.so.1 (0x01194000)
	libxcb-xlib.so.0 => /usr/lib/libxcb-xlib.so.0 (0x02fc0000)
	libxcb.so.1 => /usr/lib/libxcb.so.1 (0x0300e000)
	libXau.so.6 => /usr/lib/libXau.so.6 (0x03915000)
	libuuid.so.1 => /lib/libuuid.so.1 (0x07bdb000)
	libicudata.so.40 => /usr/lib/libicudata.so.40 (0xb738b000)
	libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x01351000)
...end sample ldd details ...
Comment 1 Caolan McNamara 2009-01-06 08:37:45 EST
I don't see a problem here, so what is the type of printer being used, maybe that's the difference. (i.e. system->administration->printing, right click on the printer->properties, and copy and paste the "make and model"
Comment 2 Caolan McNamara 2009-01-13 07:22:28 EST
*** Bug 476037 has been marked as a duplicate of this bug. ***
Comment 3 Caolan McNamara 2009-02-18 17:58:42 EST
*** Bug 486169 has been marked as a duplicate of this bug. ***
Comment 4 Pete Zaitcev 2009-02-18 19:24:47 EST
Brother HL-2170W Foomatic/pxlmono (recommended)

(BTW it's very nice that it can be copy-pasted from a dialog)
Comment 5 Caolan McNamara 2009-02-19 08:01:44 EST
rats, that still didn't help reproduce it. If it was to happen I'd expect an option tweaked away from the .ppd default in the UI would trigger it.
Comment 6 Caolan McNamara 2009-04-05 05:38:59 EDT
*** Bug 494133 has been marked as a duplicate of this bug. ***
Comment 7 Caolan McNamara 2009-04-17 18:25:05 EDT
Never was able to reproduce this, but almost certainly related to the gtk unix print dialog infrastructure which will be disabled in F-11 again for other reasons, so this will go away in F-11. Suboptional resolution.
Comment 8 Caolan McNamara 2009-04-29 04:07:50 EDT
*** Bug 497997 has been marked as a duplicate of this bug. ***
Comment 9 Caolan McNamara 2009-05-26 05:13:44 EDT
*** Bug 501926 has been marked as a duplicate of this bug. ***
Comment 10 Caolan McNamara 2009-05-26 05:13:58 EDT
*** Bug 502374 has been marked as a duplicate of this bug. ***
Comment 11 Caolan McNamara 2009-05-26 05:15:20 EDT
Slight cock-up. F-11 change to revert to the "traditional" dialog didn't go through. Trac request submitted for that to happen. Re-opening to track that state.
Comment 12 Caolan McNamara 2009-05-27 11:21:30 EDT
Reverted to traditional dialog in openoffice.org-3.1.0-11.3.fc11

Note You need to log in before you can comment on or make changes to this bug.