Bug 498157 - clean RPM DB environment
clean RPM DB environment
Status: CLOSED DUPLICATE of bug 493249
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-29 03:36 EDT by Rahul Sundaram
Modified: 2014-01-21 18:09 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-15 09:35:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rahul Sundaram 2009-04-29 03:36:09 EDT
Description of problem:

Using preupgrade to upgrade from Fedora 10 to Fedora 11 results in RPM DB errors such as:

"rpmdb: Program version 4.7 doesn't match environment version 4.5
error: db4 error(-30971) from dbenv->open: DB_VERSION_MISMATCH ..."

Anaconda just was get struck very close to the end of the upgrade process due to this problem.

Talking to Panu, apparently Anaconda cleans the rpmdb environment after an upgrade to prevent such issues which seems to be not what preupgrade is doing somehow. 

Preupgrade needs to do that to ensure a more reliable upgrade.
Comment 1 Will Woods 2009-04-29 11:12:47 EDT
preupgrade uses anaconda to perform the upgrade. There's basically no difference between the two.

Where do you see that rpmdb error message? As far as I know that happens at the beginning of all upgrades, due to the difference in RPM versions between F10 and F11, and the message is harmless.

Furthermore, are you sure anaconda is actually *stuck*? The last stage of the upgrade can take a very long time - sometimes an hour or more. How long did you wait? What makes you think it's not just taking a long time to finish?

As for what Panu said - that's bug 496961.
Comment 2 Rahul Sundaram 2009-04-30 01:46:55 EDT
It happens at the end and not the beginning and it was struck and wouldn't go forward for a long time. RPM commands wouldn't work after the reboot and I had to do the usual rm -rf and --rebuilddb dance to get it going again.

I am aware it can take a long time but I did waited for more than half an hour and I don't think users can be reasonably expected to wait for a long time without any indication whatsoever of how much time one must time.
Comment 3 Rahul Sundaram 2009-04-30 01:47:16 EDT
It happens at the end and not the beginning and it was struck and wouldn't go forward for a long time. RPM commands wouldn't work after the reboot and I had to do the usual rm -rf and --rebuilddb dance to get it going again.

I am aware it can take a long time but I did waited for more than half an hour and I don't think users can be reasonably expected to wait for a long time without any indication whatsoever of how much time one must wait
Comment 4 Rahul Sundaram 2009-04-30 01:47:25 EDT
It happens at the end and not the beginning and it was struck and wouldn't go forward for a long time. RPM commands wouldn't work after the reboot and I had to do the usual rm -rf and --rebuilddb dance to get it going again.

I am aware it can take a long time but I did waited for more than half an hour and I don't think users can be reasonably expected to wait for a long time without any indication whatsoever of how much time one must wait
Comment 5 Will Woods 2009-05-15 09:35:58 EDT
As far as I can tell, your problem was caused by rebooting before the "Finishing upgrade" step completed. It can take hours to complete, and we need a better indicator of progress there to prevent this kind of confusion.

*** This bug has been marked as a duplicate of bug 493249 ***

Note You need to log in before you can comment on or make changes to this bug.