Bug 493249 - RFE: "Finishing upgrade" takes longer than upgrade; has no progress information.
RFE: "Finishing upgrade" takes longer than upgrade; has no progress information.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
: 498157 505346 532082 597064 (view as bug list)
Depends On:
Blocks: AnacondaUI
  Show dependency treegraph
 
Reported: 2009-04-01 01:03 EDT by Gilboa Davara
Modified: 2014-01-21 18:08 EST (History)
17 users (show)

See Also:
Fixed In Version: anaconda-15.5-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-28 15:27:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gilboa Davara 2009-04-01 01:03:38 EDT
As the title suggest, when (pre)upgrading a rather large installation, "finishing upgrade" stage takes longer than the actual package install, and unlike the package install stage, the user has no visual indication on what's going on, and how much time it'll take.
I saw the same behavior on a number of F9 machines. (that were upgraded to F10).
I assume that at least part of this stage is yum-cleanup. (Am I wrong?)

In short, the RFE is rather simple - please add some kind of progress information to the last upgrade stage.

- Gilboa
P.S. I filed it against preupgrade (as I encountered it while using preupgrade) - but I assume that this is actually an anaconda issue.
Comment 1 Will Woods 2009-04-01 12:12:21 EDT
Yes, this is not a preupgrade bug. The problem belongs to either anaconda, or rpm.

The reason the feedback is bad here is that it's really hard to estimate the amount of time this part of the transaction will take. 

%posttrans scripts - like rpm %post scripts in general - don't report any useful status, so we have no way of knowing how much work they're going to do, or how far along they've gotten. As it stands, there's nothing more we can do.

I'm sure there are plenty of bugs filed about this elsewhere.
Comment 2 Chris Lumens 2009-04-01 12:47:06 EDT
About all we can do here is overlay a "package 47 of 1337" thing over the pulse bar on that dialog.  As Will said, we have no other information about how long things are going to take given that scriptlets can do anything they want.
Comment 3 Gilboa Davara 2009-04-01 15:01:30 EDT
Chris & Will,

I understand that trying to guesstimate time is more-or-less impossible.
Never the less, even a "Performing post-upgrade clean-up on package X/Y" can give the user a rough progress estimation.

Any change of having such fix land in-time for F11 release?

- Gilboa
Comment 4 Will Woods 2009-05-15 09:33:04 EDT
We tried a couple of simple hacks but they didn't work out. It looks like this isn't going to get fixed in time for F11. I'd like to revisit it for F12, though.
Comment 5 Will Woods 2009-05-15 09:35:58 EDT
*** Bug 498157 has been marked as a duplicate of this bug. ***
Comment 6 Gilboa Davara 2009-05-16 06:44:30 EDT
Thanks for the update.
Comment 7 Timothy Murphy 2009-06-21 15:08:56 EDT
This is really annoying.
People have been complaining about it for years.
Just tell us what is going on.

You may not be able to estimate how long it will take
but at least you must know what is happening.

This is worse - much worse - than Windows.
Comment 8 Chris Lumens 2009-06-29 08:10:22 EDT
Thanks for your opinion.  I appreciate the kind words.
Comment 9 Gilboa Davara 2009-06-29 10:21:57 EDT
Trolls aside, any chance of getting it in F12 GA?
Comment 10 Chris Lumens 2009-06-29 10:38:20 EDT
Yeah - check out item #2 at https://fedoraproject.org/wiki/Anaconda/Features/YuminstallCleanup
Comment 11 Gilboa Davara 2009-06-29 10:54:11 EDT
Great.
Thanks again for the update.
Comment 12 Chris Lumens 2009-10-30 11:29:40 EDT
*** Bug 532082 has been marked as a duplicate of this bug. ***
Comment 13 Chris Lumens 2009-11-18 09:43:36 EST
*** Bug 505346 has been marked as a duplicate of this bug. ***
Comment 14 Robert Hancock 2009-11-22 23:52:42 EST
This isn't fixed in Fedora 12.
Comment 15 Chris Lumens 2010-05-28 08:49:31 EDT
*** Bug 597064 has been marked as a duplicate of this bug. ***
Comment 16 Joel 2010-10-18 16:50:13 EDT
This hasn't been fixed in Fedora 14 yet either.  This step has been running for over an hour.  Doesn't qualify as "This may take a little while."  

This is a preupgrade from F12 to F14.
Comment 17 Chris Lumens 2010-10-28 15:27:51 EDT
Well rpm doesn't tell me how many packages it's processing in the cleanup phase nor what number we're on.  But it at least tells me which package name is being processed.  So I can't do a proper progress bar, but I can at least display the name of the package as we process it.  That's better than nothing, I suppose.
Comment 18 Joel 2010-10-28 16:32:17 EDT
Isn't the number of packages upgraded a good estimate for the number of packages to be cleaned?  Then as you get a new package being cleaned you can advance the progress bar?  It's ok if the bar suddenly jumps to being done at the end.
Comment 19 Robert Hancock 2010-10-28 21:11:55 EDT
Indeed, some progress indication would be better than nothing. And in any case, yum does provide this information, so obviously it's possible to get it out of rpm somehow.

Just indicating which package is being cleaned up doesn't really help the situation much.
Comment 20 Gilboa Davara 2010-10-29 11:11:04 EDT
I second the above.
Saying "Cleaning up 1291/1430 with a 90% progress bar, is far better.
Comment 21 Tony Foiani 2010-11-04 21:17:45 EDT
Adding another vote for this (and for the many "closed duplicate" bugs with similar complaints).

F12 -> F14 on a 1.9GHz Pentium IV had "finishing upgrade" for an hour or two, with only the cylon "doing stuff" bar; a progress bar of *any* sort would be much better.

Thanks!
Comment 22 Tony Foiani 2010-11-04 21:58:47 EDT
Various other bugs that are duplicates (or at least very similar) to this one:

bug 208725 (dups: bug 450343)
bug 452724 (dups: bug 474460)
bug 493249 (dups: bug 532082, bug 597064)
Comment 23 Mike Hudson 2011-06-13 16:20:11 EDT
Another vote here ... 

To the non expert user it really looks like Fedora has hung.  He/she may turn off the machine in frustration, without some indication that progress is being made.
Comment 24 Robert Hancock 2011-06-13 20:07:30 EDT
In F15 it at least tells you what package it's cleaning up, which is an improvement but it still doesn't tell you how far it is through the process.

Note You need to log in before you can comment on or make changes to this bug.