Bug 498163 - gdm hang right before showing user list with KMS with Intel graphic card (Apple Macbook)
Summary: gdm hang right before showing user list with KMS with Intel graphic card (App...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel
Version: 11
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kristian Høgsberg
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-04-29 08:52 UTC by Federico Pedemonte
Modified: 2018-04-11 10:23 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-19 12:59:16 UTC
Type: ---


Attachments (Terms of Use)
Xorg.0.log (38.28 KB, text/plain)
2009-05-24 14:26 UTC, Federico Pedemonte
no flags Details

Description Federico Pedemonte 2009-04-29 08:52:13 UTC
Description of problem:



Version-Release number of selected component (if applicable):

F11 preview (live cd)

How reproducible:

always

Steps to Reproduce:
1. boot from the live cd into a white Macbook (Intel Corporation Mobile 945GM/GMS/940GML Express Integrated Graphics Controller) 
  
Actual results:

hangs in the gdm login screen (just before completing painting the user list)

Expected results:

shows the "autologin" user and allow the user to log in

Additional info:

everything works fine if booting with the "nomodeset" grub option
as a side note, the lower white bar of plymouth shows some unexpected artifacts

Comment 1 Federico Pedemonte 2009-05-04 09:07:20 UTC
a clean installation from DVD (F11 preview) shows the same behaviour (during installation too).

You _always_ have to boot with the nomodeset option

Comment 2 Matěj Cepl 2009-05-15 14:56:12 UTC
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

And of course you can edit /boot/grub/menu.lst and add that nomodeset keyword to the kernel line there to make it premanent.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 3 Mildred 2009-05-24 08:41:00 UTC
I have a similar problem and created a bug #495149 Perhaps you can find information you need here.

Comment 4 Matěj Cepl 2009-05-24 13:28:17 UTC
I need those information from the original reporter to know what we are talking about.

Comment 5 Federico Pedemonte 2009-05-24 14:26:53 UTC
Created attachment 345250 [details]
Xorg.0.log

Xorg.0.log

Comment 6 Federico Pedemonte 2009-05-24 14:31:28 UTC
Hello!I'm the original poster. I've just attached my Xorg.0.log. On that machine I don't have an xorg.conf.

With the latest update gdm doesn't even come out, and all I get after the boot now is a blank black screen with a corrupted mouse pointer (that work). 

Although i can access the machine via ssh, i'm not able to switch to a working console via alt+Fn

thanks in advance!

Comment 7 Bug Zapper 2009-06-09 14:45:48 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 8 Paul Jenner 2009-07-06 19:49:50 UTC
I see this on F11 on a Mac Mini after booting nomodeset.

[root@localhost ~]# lspci -nn | grep Graphics
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller [8086:27a2] (rev 03)

Boot completes, Plymouth transitions to GDM and then GDM "hangs" before showing the user list. Mouse cursor is responsive but otherwise display is frozen.

More detail including logs to follow.

Comment 9 Paul Jenner 2009-08-26 19:13:28 UTC
This is resolved for me with kernel 2.6.30.5-32 from F11 updates-testing. On a
Mac Mini with this chipset booting in legacy BIOS mode, I am now able to boot
with KMS, X starts in default UXA, GDM starts and automatically logs in as expected.

[root@localhost xsessions]# lspci -nn | grep Graphics
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GM/GMS,
943/940GML Express Integrated Graphics Controller [8086:27a2] (rev 03)

[root@localhost xsessions]# rpm -q kernel xorg-x11-drv-intel
kernel-2.6.30.5-32.fc11.x86_64
xorg-x11-drv-intel-2.7.0-7.fc11.x86_64
gdm-2.26.1-13.fc11.x86_64

Comment 10 Federico Pedemonte 2009-08-26 20:24:51 UTC
(In reply to comment #9)
> This is resolved for me with kernel 2.6.30.5-32 from F11 updates-testing. On a
> Mac Mini with this chipset booting in legacy BIOS mode, I am now able to boot
> with KMS, X starts in default UXA, GDM starts and automatically logs in as
> expected.

That kernel resolved the bug for me too (Macbook "white") as they seems to have the same graphic chipset (same lspci output)

Comment 11 Paul Jenner 2009-08-27 18:47:45 UTC
If that kernel resolved the bug for you (origina poster), can this bugzilla be closed?

Comment 12 Federico Pedemonte 2009-08-27 22:30:14 UTC
(In reply to comment #11)
> If that kernel resolved the bug for you (origina poster), can this bugzilla be
> closed?  

since Paul's solution (comment #9) worked perfectly for me, I consider this bug  be closed.

However, don't know if it is reasonable to close it before the working kernel hit fedora-updates.

But that's just a doubt that I have: you surely knows what do to :)

thank you!

Federico

Comment 13 Fedora Update System 2009-08-28 22:28:25 UTC
kernel-2.6.30.5-43.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/kernel-2.6.30.5-43.fc11

Comment 14 Fedora Update System 2009-09-06 20:44:03 UTC
kernel-2.6.30.5-43.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Paul Jenner 2009-09-19 11:57:45 UTC
Kernel package which resolved this has been pushed to F11 stable updates. Can someone close this bug?


Note You need to log in before you can comment on or make changes to this bug.