Bug 498175 - crashes on a sftp location
crashes on a sftp location
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: nautilus-open-terminal (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Paul W. Frields
Fedora Extras Quality Assurance
:
: 500854 511152 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-29 05:59 EDT by Rahul Sundaram
Modified: 2013-03-13 01:44 EDT (History)
5 users (show)

See Also:
Fixed In Version: 0.13-1.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-18 20:08:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
'bt full' from nautilus-open-terminal-0.9-12 crash (27.10 KB, text/plain)
2009-05-21 11:37 EDT, Paul W. Frields
no flags Details
Output from bug-buddy (1.82 KB, application/octet-stream)
2009-06-15 07:19 EDT, Steve
no flags Details

  None (edit)
Description Rahul Sundaram 2009-04-29 05:59:48 EDT
Description of problem:

# rpm -q nautilus nautilus-open-terminal
nautilus-2.26.2-2.fc11.i586
nautilus-open-terminal-0.9-12.fc11.i586

Use connect to server to connect to another system via sftp. Right click and click open in terminal and watch nautilus crash. 

If you need more information, let me know
Comment 1 Paul W. Frields 2009-05-20 10:05:27 EDT
*** Bug 500854 has been marked as a duplicate of this bug. ***
Comment 2 Paul W. Frields 2009-05-21 10:57:12 EDT
Can you fellows try out:
http://koji.fedoraproject.org/koji/buildinfo?buildID=103005

And let me know how it works for you?
Comment 3 Rahul Sundaram 2009-05-21 11:06:31 EDT
Didn't fix it but I got some crash details:

Distribution: Fedora release 11 (Leonidas)
Gnome Release: 2.26.1 2009-04-29 (Red Hat, Inc)
BugBuddy Version: 2.26.0

System: Linux 2.6.29.1-111.fc11.i586 #1 SMP Fri Apr 24 10:42:21 EDT 2009 i686
X Vendor: The X.Org Foundation
X Vendor Release: 10601000
Selinux: Enforcing
Accessibility: Disabled
GTK+ Theme: Nodoka
Icon Theme: Fedora
GTK+ Modules: canberra-gtk-module, pk-gtk-module, gnomebreakpad

Memory status: size: 0 vsize: 0 resident: 0 share: 0 rss: 0 rss_rlim: 0
CPU usage: start_time: 0 rtime: 0 utime: 0 stime: 0 cutime:0 cstime: 0 timeout: 0 it_real_value: 0 frequency: 0



---- Critical and fatal warnings logged during execution ----

** GLib **: g_hash_table_lookup: assertion `hash_table != NULL' failed 
** GLib **: g_hash_table_lookup: assertion `hash_table != NULL' failed 


----------- .xsession-errors ---------------------

(nautilus:2043): GLib-CRITICAL **: g_hash_table_lookup: assertion `hash_table != NULL' failed
(nautilus:2043): libgnomevfs-WARNING **: Internal error: the configuration system was not initialized. Did you call _gnome_vfs_configuration_init?
(nautilus:2043): GLib-CRITICAL **: g_hash_table_lookup: assertion `hash_table != NULL' failed
(nautilus:2043): libgnomevfs-WARNING **: Internal error: the configuration system was not initialized. Did you call _gnome_vfs_configuration_init?
**
Nautilus-Open-Terminal:ERROR:nautilus-open-terminal.c:163:append_sftp_info: assertion failed: (vfs_uri != NULL)
--------------------------------------------------
Comment 4 Paul W. Frields 2009-05-21 11:37:21 EDT
Created attachment 344984 [details]
'bt full' from nautilus-open-terminal-0.9-12 crash

Forgot to mention that I did some snooping earlier this morning and was finally able to reproduce on another machine.  Backtrace with full symbols attached.  There were numerous gvfs improvements made upstream, and with the new release you get shortcuts for "Open Remote in Terminal" (SSH) and "Open Local in Terminal" (gvfs fuse mount).
Comment 5 Bug Zapper 2009-06-09 10:46:26 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Paul W. Frields 2009-06-11 11:54:52 EDT
Did anyone try the koji packages above?  Results?
Comment 7 Tait Clarridge 2009-06-11 12:01:51 EDT
Hi Paul,

Yes I have, it works for me.

Both opening remote/local works just fine with SFTP. The only strange thing that happens is the window opens in one place, then jumps to another part of the screen. Not by any means a real problem, just an FYI.
Comment 8 Tait Clarridge 2009-06-11 12:13:57 EDT
(In reply to comment #7)
> Hi Paul,
> 
> Yes I have, it works for me.
> 
> Both opening remote/local works just fine with SFTP. The only strange thing
> that happens is the window opens in one place, then jumps to another part of
> the screen. Not by any means a real problem, just an FYI.  

Not sure how to edit comments here, but the strange behaviour that I mentioned doesn't happen when I do it from an SFTP connection, only when local (on my desktop/documents where it says "Open in Terminal").
Comment 9 Steve 2009-06-15 06:28:57 EDT
In my case, when i make a right-click to Desktop -> Open In Terminal, nautilus crashes.

nautilus-open-terminal-0.12-1.fc12.i586
nautilus-2.27.1-1.fc12.i586
Comment 10 Steve 2009-06-15 07:19:36 EDT
Created attachment 347912 [details]
Output from bug-buddy
Comment 11 Paul W. Frields 2009-07-13 19:25:11 EDT
Steve, that's a very different issue so it really doesn't belong in this bug.  Conflating bugs makes them harder to solve.  You might want to check bug #510685, which I believe is actually fixed now because the problem wasn't in nautilus-open-terminal.

Is anyone having this trouble still on Fedora 11, with current updates applied?  I can no longer get this bug to reproduce.
Comment 12 Rahul Sundaram 2009-07-13 19:30:10 EDT
I can still see it

# rpm -q nautilus nautilus-open-terminal

nautilus-2.26.3-1.fc11.i586
nautilus-open-terminal-0.9-12.fc11.i586
Comment 13 Paul W. Frields 2009-07-14 14:16:47 EDT
*** Bug 511152 has been marked as a duplicate of this bug. ***
Comment 14 Fedora Update System 2009-08-19 08:22:47 EDT
nautilus-open-terminal-0.13-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/nautilus-open-terminal-0.13-1.fc11
Comment 15 Fedora Update System 2009-08-19 19:14:45 EDT
nautilus-open-terminal-0.13-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update nautilus-open-terminal'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-8750
Comment 16 Fedora Update System 2009-09-18 20:08:27 EDT
nautilus-open-terminal-0.13-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.