Bug 500854 - Nautilus crashes when opening terminal on an SSH view
Nautilus crashes when opening terminal on an SSH view
Status: CLOSED DUPLICATE of bug 498175
Product: Fedora
Classification: Fedora
Component: nautilus-open-terminal (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Paul W. Frields
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-14 11:07 EDT by Simo Sorce
Modified: 2009-05-20 10:05 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-20 10:05:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Simo Sorce 2009-05-14 11:07:41 EDT
Description of problem:
Hitting Open in Terminal while nautilus is displaying a remote directory via ssh makes Nautilus crash.

Version-Release number of selected component (if applicable):
Fedora 11 current Nautilus 2.26.2 package

How reproducible:
Always, just click open in terminal while browsing a remote ssh directory.
Comment 1 Paul W. Frields 2009-05-14 11:40:05 EDT
I can't reproduce this in a fresh user account.  I did this:

1. Hit Ctrl+L
2. Enter "ssh://username@remotehost/home/username"
3. Accept unknown fingerprint after verification
4. Provide passphrase, with "forget immediately" selected
4. In resulting Nautilus window, right-click and select "Open in Terminal"
5. GNOME Terminal appears asking for SSH passphrase as expected


nautilus-open-terminal-0.9-12.fc11.x86_64
nautilus-2.26.2-2.fc11.x86_64
nautilus-extensions-2.26.2-2.fc11.x86_64
Comment 2 Simo Sorce 2009-05-14 12:08:12 EDT
Mine is an upgraded account (was using F9 till last week on this machine).
Not sure if that makes any difference ?

Btw, why should Gnome Terminal ask again for the passphrase?
All the contents are already available under ~/.gvfs anyway ...
Comment 3 Paul W. Frields 2009-05-14 12:54:56 EDT
Not sure either. This machine is a regular installation, and I used a fresh account.  Apparently nautilus-open-terminal is respecting regular ~/.ssh/config stuff, because when I use ControlMaster I just get a straight-up prompt with no additional passphrase required.  (I protect all my keys with passphrases.)
Comment 4 Paul W. Frields 2009-05-14 17:37:23 EDT
Does the problem occur in a fresh account on that same system?
Comment 5 Simo Sorce 2009-05-14 18:32:49 EDT
Yes happens to me also with a brand new account
Comment 6 Paul W. Frields 2009-05-20 10:05:27 EDT
Let me get Rahul's bug report tied in here too -- I hadn't seen that until today.

*** This bug has been marked as a duplicate of bug 498175 ***

Note You need to log in before you can comment on or make changes to this bug.