Bug 498827 - gpk update fails with error popup
gpk update fails with error popup
Status: CLOSED DUPLICATE of bug 498328
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-03 13:29 EDT by Beartooth
Modified: 2009-05-12 17:51 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-12 17:51:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
details from error message popup (1.23 KB, text/plain)
2009-05-03 13:29 EDT, Beartooth
no flags Details

  None (edit)
Description Beartooth 2009-05-03 13:29:10 EDT
Created attachment 342245 [details]
details from error message popup

Description of problem:
gpk update function fails

Version-Release number of selected component (if applicable):


How reproducible:
every time

Steps to Reproduce:
1.launch it from a panel
2.
3.
  
Actual results:
bug report -- without updating

Expected results:


Additional info:
yum update and rpm --rebuilddb also fail:
[root@Hbsk2 btth]# rpm --rebuilddb
rpmdb: Thread/process 22733/3086984896 failed: Thread died in Berkeley DB library
error: db4 error(-30975) from dbenv->failchk: DB_RUNRECOVERY: Fatal error, run database recovery
error: cannot open Packages index using db3 -  (-30975)
[root@Hbsk2 btth]# yum update
Loaded plugins: refresh-packagekit
rpmdb: Thread/process 22733/3086984896 failed: Thread died in Berkeley DB library
error: db4 error(-30975) from dbenv->failchk: DB_RUNRECOVERY: Fatal error, run database recovery
error: cannot open Packages index using db3 -  (-30975)
error: cannot open Packages database in /var/lib/rpm
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 229, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 84, in main
    base.getOptionsConfig(args)
  File "/usr/share/yum-cli/cli.py", line 184, in getOptionsConfig
    enabled_plugins=self.optparser._splitArg(opts.enableplugins))
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 192, in _getConfig
    self._conf = config.readMainConfig(startupconf)
  File "/usr/lib/python2.5/site-packages/yum/config.py", line 774, in readMainConfig
    yumvars['releasever'] = _getsysver(startupconf.installroot, startupconf.distroverpkg)
  File "/usr/lib/python2.5/site-packages/yum/config.py", line 844, in _getsysver
    idx = ts.dbMatch('provides', distroverpkg)
TypeError: rpmdb open failed
[root@Hbsk2 btth]#
Comment 1 Christoph Wickert 2009-05-12 17:51:08 EDT

*** This bug has been marked as a duplicate of bug 498328 ***

Note You need to log in before you can comment on or make changes to this bug.