Bug 49836 - running make on individual tables doesn't produce correct file locations
running make on individual tables doesn't produce correct file locations
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: ypserv (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
Jay Turner
: FutureFeature
: 52726 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-24 10:36 EDT by Kurt Ludwig
Modified: 2015-01-07 18:49 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-12 21:54:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kurt Ludwig 2001-07-24 10:36:34 EDT
Description of Problem:
running 'Make' in /var/yp works, but 'Make passwd' or any other individual 
table for that matter results in the new table being created in /var/yp 
and not in /var/yp/NISDOMAIN

How Reproducible:



Steps to Reproduce:
1. cd /var/yp
2. make  (this works correctly)
3. make passwd (this doesn't)

Actual Results:

passwd.byname and passwd.byuid get created in /var/yp

Expected Results:

*should* have been created in /var/yp/DOMAINNAME

Additional Information:
	
This *does* work on a sun-based Solaris NIS domain that I also manage.
so, at the very least, the Makefile needs to be updated to correctly 
position the created files.
Comment 1 Alexander Larsson 2002-03-21 10:54:22 EST
*** Bug 52726 has been marked as a duplicate of this bug. ***
Comment 2 Alexander Larsson 2002-03-21 16:30:35 EST
This would need some serious changes to the makefile. I don't see why you need
it anyway. The idea is that you just type make and it will only rebuild the
tables that need rebuilding.
Comment 3 Kurt Ludwig 2002-03-21 16:38:58 EST
welp, then there should be something in the readme on it so say 'just run make' 
dont run 'make passwd'. The 2 other OS's that I've used as YPServers (Tru64 and 
Solaris) both treat it correctly and make just the table you ask for in the 
right place.

My big argument for at least noting the change in operability is that someone 
coming over from a different environment (another *nix) may expect one 
functionality and get another. It may also affect any cron jobs that someone 
has set up.

At the very least, it should be noted in the readme, or maybe some block in the 
makefile for calling the specific tables from make.

Note You need to log in before you can comment on or make changes to this bug.