Bug 52726 - /var/yp/Makefile buggy
/var/yp/Makefile buggy
Status: CLOSED DUPLICATE of bug 49836
Product: Red Hat Linux
Classification: Retired
Component: ypserv (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-28 10:28 EDT by Kurt Ludwig
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-19 10:56:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kurt Ludwig 2001-08-28 10:28:00 EDT
Description of Problem:

if you try to make any individual database under /var/yp it never puts it 
under /var/yp/DOMAINNAME, just under /var/yp. running 'make' and 
rebuilding everything works OK.

Version-Release number of selected component (if applicable):


How Reproducible:

very... This bug has existed since at LEAST RH7.1 when I discovered it.


Steps to Reproduce:
1. set a domainname
2. start ypbind
3. go into /var/yp and make an individual database, such as passwd

Actual Results:
the new databases get created under /var/yp

Expected Results:
the databases SHOULD get created under /var/yp/DOMAINNAME where DOMAINNAME 
is the current NIS domainname of the server

Additional Information:
This could confuse a user coming from a standard UNIX environment where 
he/she can make just the one database that needs updating instead of re-
running everything. (BTW.... this works correctly in solaris 2.6 2.7 2.8. 
Those are the only ones I've tested. Prolly works ok in most of the rest 
too)
	
filed under another bug number for RH7.1
Comment 1 Alexander Larsson 2002-03-21 10:54:27 EST

*** This bug has been marked as a duplicate of 49836 ***

Note You need to log in before you can comment on or make changes to this bug.