Bug 498415 - spinner icon is mangled
spinner icon is mangled
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
11
All Linux
low Severity low
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
: 498865 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-30 08:06 EDT by Dan Winship
Modified: 2009-07-21 21:01 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-21 21:01:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch (651 bytes, patch)
2009-05-26 20:24 EDT, Matthias Clasen
no flags Details | Diff

  None (edit)
Description Dan Winship 2009-04-30 08:06:08 EDT
I forget exactly what step it was at, but at some point when installing some new software, gpk-application tried to show a spinner image in the lower left corner of the window, except that it sliced up the base png with the wrong dimensions and so it came out like a TV with broken vertical hold. Probably it got a 24x24 icon and thought it was 22x22, or vice versa?

(A quick check shows that this wasn't any of the icons in /usr/share/gnome-packagekit/icons/hicolor/*/animations/... it was the standard OS X-like spinner. Maybe it's accidentally getting a fallback stock icon?)
Comment 1 Dan Winship 2009-04-30 09:08:58 EDT
(In reply to comment #0)
> I forget exactly what step it was at

"Getting information" while installing a package.
gnome-packagekit-2.27.2-0.2.20090414git.fc11.i586
Comment 2 Gideon Mayhak 2009-05-16 15:35:01 EDT
I see this same behavior when PackageKit is "thinking" and displaying the circular animation.  All other animations seem normal and smooth.  I'm running the latest x86_64 rawhide.
Comment 3 Matthias Clasen 2009-05-26 20:24:09 EDT
Created attachment 345546 [details]
patch

Here is a silly hack to fix this problem for the process-working icon. But the same problem can occur for any of the other animated icons as well, depending on how the symbolic icon sizes are set by the gtk theme.

There is no way to fix this properly, unless we can attach the rows/cols information as additional metadata to the icon.
Comment 4 Matthias Clasen 2009-05-26 21:31:48 EDT
*** Bug 498865 has been marked as a duplicate of this bug. ***
Comment 5 Richard Hughes 2009-05-27 11:38:26 EDT
(In reply to comment #3)
> Here is a silly hack to fix this problem for the process-working icon. But the
> same problem can occur for any of the other animated icons as well, depending
> on how the symbolic icon sizes are set by the gtk theme.

commit c8d4d72ece8a40d5e8c9d99f954343bc9648141f
Author: Matthias Clasen <mclasen@redhat.com>
Date:   Wed May 27 16:37:08 2009 +0100

    Add a silly hack until we get some metadata about animated icon sizes
    
    Signed-off-by: Richard Hughes <richard@hughsie.com>
Comment 6 Richard Hughes 2009-06-03 05:15:36 EDT
Can you try installing https://admin.fedoraproject.org/updates/F11/FEDORA-2009-5750 and https://admin.fedoraproject.org/updates/F11/FEDORA-2009-5748 and then reboot please. If it fixes things, please report that as positive karma for the update. Thanks.
Comment 7 Bug Zapper 2009-06-09 10:52:42 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Steven M. Parrish 2009-07-21 21:01:02 EDT
Going to close this as CURRENTRELEASE.  Please feel free to reopen if the problem returns.

-- 
Steven M. Parrish - KDE Triage Master
                  - PackageKit Triager
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.