Bug 498435 - Fedora11 Preview: Anaconda installer crashed while opening custom partition gui
Fedora11 Preview: Anaconda installer crashed while opening custom partition gui
Status: CLOSED DUPLICATE of bug 498350
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
ppc64 All
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-30 10:02 EDT by IBM Bug Proxy
Modified: 2009-04-30 10:50 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-30 10:50:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda dump log (63.96 KB, text/plain)
2009-04-30 10:03 EDT, IBM Bug Proxy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 53118 None None None Never

  None (edit)
Description IBM Bug Proxy 2009-04-30 10:02:55 EDT
=Comment: #0=================================================
PAVAN NAREGUNDI <pavan.naregundi@in.ibm.com> - 

Anaconda dump log

While installing Fedora11 Preview, anaconda installer crashed while opening custom partition gui
giving the call trace shown below,

=========================
anaconda 11.5.0.47 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/iw/partition_gui.py", line 917, in populate
    devname = "%s" % device.path
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1339, in getScreen
    self.populate(initial = 1)
  File "/usr/lib/anaconda/gui.py", line 1414, in setScreen
    new_screen = self.currentWindow.getScreen(anaconda)
  File "/usr/lib/anaconda/gui.py", line 1331, in nextClicked
    self.setScreen ()
AttributeError: 'NoneType' object has no attribute 'path'
=========================

Machine: P550
CPU type: Power5

Steps to reproduce,
1. Start the installation in vnc mode
2. At the Partition stage select "custom partitioning" and press next
This should give the above mentioned issue.

Attaching this anaconda dump file generated.
      
=================================================
Hello Red Hat,

It looks like the same traceback from Red Hat Bugzilla 493219.

Please let us know if you need any additional information.

Thanks.
Comment 1 IBM Bug Proxy 2009-04-30 10:03:07 EDT
Created attachment 341929 [details]
Anaconda dump log
Comment 2 Chris Lumens 2009-04-30 10:50:35 EDT

*** This bug has been marked as a duplicate of bug 498350 ***

Note You need to log in before you can comment on or make changes to this bug.