This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 498350 - Anaconda crashes in the partitioner screen.
Anaconda crashes in the partitioner screen.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 498435 504400 517608 (view as bug list)
Depends On:
Blocks: 513303
  Show dependency treegraph
 
Reported: 2009-04-29 21:58 EDT by mclaud2000
Modified: 2009-12-09 23:45 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 513303 (view as bug list)
Environment:
Last Closed: 2009-08-19 17:23:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
This is the error report displayed when anaconda crashes. (313.76 KB, text/plain)
2009-04-29 21:59 EDT, mclaud2000
no flags Details
Anaconda dump log (63.96 KB, text/plain)
2009-04-30 10:53 EDT, IBM Bug Proxy
no flags Details
Anaconda log (5.14 KB, text/plain)
2009-05-20 11:30 EDT, Edoardo Patelli
no flags Details

  None (edit)
Description mclaud2000 2009-04-29 21:58:00 EDT
Description of problem:
Anaconda crashes while installing Fedora 11 preview.

Version-Release number of selected component (if applicable):


How reproducible:
Installing Fedora 11 preview, when the partitioner screen is reached, select 'Create custom layout', click next and anaconda crashes.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Anaconda crashes without completing installation.

Expected results:
Fedora 11 preview installation completes.

Additional info:
I attached the error log displayed when anaconda crashed.
Comment 1 mclaud2000 2009-04-29 21:59:25 EDT
Created attachment 341856 [details]
This is the error report displayed when anaconda crashes.
Comment 2 Chris Lumens 2009-04-30 10:50:35 EDT
*** Bug 498435 has been marked as a duplicate of this bug. ***
Comment 3 IBM Bug Proxy 2009-04-30 10:53:37 EDT
*** This bug has been marked as a duplicate of 498350 ***
Comment 4 IBM Bug Proxy 2009-04-30 10:53:53 EDT
Created attachment 341935 [details]
Anaconda dump log
Comment 5 IBM Bug Proxy 2009-05-11 03:30:54 EDT
------- Comment From pavan.naregundi@in.ibm.com 2009-05-11 03:24 EDT-------
Redhat, Any updates on this. Still seeing this issue in latest rawhide.

Thanks
Pavan
Comment 6 Edoardo Patelli 2009-05-20 11:29:30 EDT
I have a similar behaviour on my laptop.

It crashes every time it tried to detect the partition table. 

Description of problem:
Anaconda crashes while installing Fedora 11 preview.

Version-Release number of selected component: 
anaconda version 11.5.0.54 on i386 starting


How reproducible:
Installing Fedora 11 (rawhide), when anaconda try to detect the medium it crashes.

Additional info:
I attached the error log displayed when anaconda crashed.
Comment 7 Edoardo Patelli 2009-05-20 11:30:08 EDT
Created attachment 344830 [details]
Anaconda log
Comment 8 Chris Lumens 2009-05-20 11:46:22 EDT
Edoardo - you are seeing a completely different bug.  You can tell because the traceback in your attached file is not at all the same as what's in the first comment on this bug report.
Comment 9 Chris Lumens 2009-05-20 11:49:41 EDT
We haven't been able to reproduce this problem here, so it's probably dependent either on what's on the disk to begin with or what selections you make in the custom partitioning screen.  Can someone outline what they're doing so we have a chance to reproduce and fix?
Comment 10 Edoardo Patelli 2009-05-20 11:54:51 EDT
Sorry for posting my bug in the wrong place!
Comment 11 Chris Lumens 2009-06-08 09:36:49 EDT
*** Bug 504400 has been marked as a duplicate of this bug. ***
Comment 12 Bug Zapper 2009-06-09 10:50:22 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 13 mlamagrar 2009-06-13 05:21:17 EDT
It doesn't only crash for "custom layout".  I tried custom after it crashed for an automatic "use entire disk" partitioning.

For reproduction:  (please note: on my machine it takes SO LONG to boot the liveCD, and then I have to download system-config-display just to stop seeing quadruple, and all that takes so long that I'm not going through it again just to give EXACT quotes here, so this is just accurate enough to help the programmer(s) find the failure path.)

SYSTEM: Acer 5520 laptop, SATA internal drive (intended to remain untouched),
USB external 2.5G Seagate pocket drive (actual hard disk, not flash memory).

FAILURE 1: When asked which disks to use for the installation, DESELECTED sda (laptop internal disk), left sdb selected (external USB hard disk).  Selected automatic "use entire disk" option.  Clicked Next, and it said Unhandled Exception from anaconda.

FAILURE 2: Ran installer afresh and tried Custom Layout option, after again deselecting sda and leaving sdb selected.  Clicked Next, and got Unhandled Exception from anaconda.

CHECKS: That USB disk works perfectly in Fedora-8, and also in Fedora-11 from the LiveCD desktop.  That is, it mounts and files show up, and dismounts.  It's formatted with a single FAT32 filesystem, as it came out of the box.  Never been repartitioned.

WHAT I DIDN'T TRY:  There's no way I'm going to risk having the Fedora installer wipe out or corrupt my main hard disk, since 4 years ago it did just that by doing whatever it liked with my partition table without properly asking me first and making clear what it was about to do and when.  Therefore, I did not try it with sda selected and the external disk deselected.  Nor did I try deleting the partition table on the external disk before running the installer.  However, any OS installer in the year 2009 should be able to handle that by itself without crashing or needing an assist.

I think this should be higher than "low" priority, I'm about to throw the F11 CD in the trash and just keep using F8, and I'm sure not being able to install will make many other people do the same thing.
Comment 14 Denise Dumas 2009-07-23 11:40:46 EDT
Dup'd to 513303 as well
Comment 15 Chris Lumens 2009-08-19 17:23:45 EDT
This should be fixed in F12 beta.  Thanks for the bug report.
Comment 16 IBM Bug Proxy 2009-08-26 09:01:35 EDT
------- Comment From pavan.naregundi@in.ibm.com 2009-08-26 08:55 EDT-------
I didn't face this issue on F12 Alpha.

Redhat, Is the fix is in F12 Alpha?
Comment 17 Chris Lumens 2009-12-09 23:45:24 EST
*** Bug 517608 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.