This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 49854 - BETA2 TUI installer Crash on grub config
BETA2 TUI installer Crash on grub config
Status: CLOSED DUPLICATE of bug 47278
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-24 12:25 EDT by Daniel Powell
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-24 16:43:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel Powell 2001-07-24 12:25:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010710

Description of problem:
trying to edit the name of the other boot partition in the grub / OS config
of the installer crashes anaconda. hitting enter on the other partition
(NTFS) to change the boot name from none to something else crashes the
installer...

How reproducible:
Always

Steps to Reproduce:
1. choose grub for the boot manager
2. on the screen that asks you to set names and defaults for the boot
loader, select the other partition (NTFS or whatever) 
3. hit enter and the installer will crash.
	

Actual Results:  installer crashes, dumps traceback

Expected Results:  Should have allowed me to name "none" to whatever i wanted.

Additional info:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 580, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/lib/anaconda/text.py", line 362, in run
    rc = apply(win, (self.screen, ) + args)
  File "/usr/lib/anaconda/textw/bootloader_text.py", line 275, in __call__
    (label, type) = images[item]
ValueError: unpack tuple of wrong size
Comment 1 Glen Foster 2001-07-24 16:43:25 EDT
This defect is considered MUST-FIX for Fairfax.
Comment 2 Jeremy Katz 2001-07-24 16:50:37 EDT
Continuing in the "bugzilla is a race condition" concept here, let's try to mark
this as a duplicate for the third time

*** This bug has been marked as a duplicate of 47278 ***

Note You need to log in before you can comment on or make changes to this bug.