Bug 498720 - Packaging bug: metalink
Packaging bug: metalink
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fedora-release (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
: Reopened
: 504941 (view as bug list)
Depends On:
Blocks: 506040
  Show dependency treegraph
 
Reported: 2009-05-02 10:13 EDT by Ralf Corsepius
Modified: 2013-01-10 00:11 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-07 18:59:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Corsepius 2009-05-02 10:13:58 EDT
Description of problem:
/etc/yum.repos.d/fedora*.repo files use "metalink" mirrorlist URLs.

Such URLs are unreadable by FC10's yum, nevertheless 
the package fedora-release-10.92-1.noarch.rpm
installs without complaints on FC10.

=> Packaging bug: missing "Requires: ... > xxx"
(likely some version of yum-metadata-parser)

Version-Release number of selected component (if applicable):
fedora-release-10.92-1.noarch.rpm


How reproducible:
Always

Steps to Reproduce:
1. On FC10: rpm -U fedora-release-10.92-1.noarch.rpm
2. yum update
  
Actual results:
yum complains about invalid mirrorlists and aborts.

Expected results:
fedora-release being non-installable on systems with insufficent yum-metadata-parsers

Additional info:
The metalink-URL breaks the traditional approach to distro upgrading (Manually upgrade fedora-release, then run yum upgrade).
Comment 1 Bug Zapper 2009-06-09 10:59:51 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 James Antill 2009-06-09 13:10:29 EDT
Get the yum from updates-testing in Fed-10.
Comment 3 James Antill 2009-06-09 13:12:47 EDT
I'm not sure there's a point in keeping this open.
Comment 4 Ralf Corsepius 2009-06-09 14:13:45 EDT
(In reply to comment #3)
> I'm not sure there's a point in keeping this open.  

You may close this bug when you released a bug-fixed package in F-10
Until then this bug is still present.

Besides this, this bug should have been addressed long before F11 had been released, unfortunately this package's maintainer (Jesse Keating) preferred to ignore it.
Comment 5 James Antill 2009-06-10 10:11:23 EDT
*** Bug 504941 has been marked as a duplicate of this bug. ***
Comment 6 shrek-m 2009-06-10 12:53:46 EDT
a really bad timing :-(

fc11 release date was 2009-06-10
'yum update' before the upgrade == yum 3.2.21-2.fc10

yum  3.2.23-3.fc10  in updates-testing is from 2009-05-23
yum  3.2.21-2.fc10  in fedora-updates is from 2009-02-04

imho it would be no bad idea if the working  yum package would be as soon as possible in fedora-updates before the release date.
Comment 7 Jesse Keating 2009-06-10 14:37:27 EDT
I ignored it because the yum folks said they would be putting out a yum update that would fix it.  We're trying to get that yum moved over, however something in the F12 content has made our rawhide composes take longer than a day which is making it difficult to get any update pushes out.
Comment 8 Dave Malcolm 2009-06-12 06:25:48 EDT
I ran into this one trying to yum upgrade one of my F10 boxes to F11.

Workaround appears to be described here:
https://www.redhat.com/archives/fedora-list/2009-June/msg00783.html

I've added a link to this bug and to the workaround to:
https://fedoraproject.org/wiki/Upgrading_Fedora_using_yum#Fedora_10_-.3E_Fedora_11_.28tentative.29

Note You need to log in before you can comment on or make changes to this bug.