Bug 506040 - version of ntp shipped in fedora 11 prevent correct update of fedora 10 using yum
version of ntp shipped in fedora 11 prevent correct update of fedora 10 using...
Status: CLOSED DUPLICATE of bug 504980
Product: Fedora
Classification: Fedora
Component: ntp (Show other bugs)
11
x86_64 Linux
low Severity urgent
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
Depends On: 498720
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-15 07:37 EDT by Jean-Baptiste Vignaud
Modified: 2009-06-15 07:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-15 07:53:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jean-Baptiste Vignaud 2009-06-15 07:37:10 EDT
Description of problem:

version of ntp shipped in fedora 11 is ntp-4.2.4p6-4

version if ntp in updated fedora 10 is ntp-4.2.4p7-1

when trying to upgrade fc10 to fc11 using yum upgrade, the process gives an error regarding libcrypto.so

version ntp-4.2.4p7-1.fc10 needs libcrypto.so.7()(64bit)
version ntp-4.2.4p6-4.fc11 needs libcrypto.so.8()(64bit)

As the fc11 package is lesser thant the one on updated fc10, ntp is not included in the upgrade process, inducing a dependency for libcrypto.so.7 in fc11 from old ntp package.

Steps to Reproduce:

1. get a fc10 updated
2. try to upgrade to fc11
3. get the dependency error
  
Actual results:

cannot upgade

Expected results:

correct upgrade

Additional info:

To 'temp fix' the proble, i removed ntp/ntpdate (with --nodeps), and re-run the yum upgrade.

The new ntp package of fc11 was added and the upgrade went ok.
Comment 1 Miroslav Lichvar 2009-06-15 07:53:28 EDT

*** This bug has been marked as a duplicate of bug 504980 ***

Note You need to log in before you can comment on or make changes to this bug.