Bug 498812 - Amarok handbook missing; diagnostic misleading
Amarok handbook missing; diagnostic misleading
Status: CLOSED DUPLICATE of bug 473522
Product: Fedora
Classification: Fedora
Component: amarok (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Aurelien Bompard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-03 11:11 EDT by D. Hugh Redelmeier
Modified: 2009-05-04 11:20 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-04 11:20:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description D. Hugh Redelmeier 2009-05-03 11:11:09 EDT
Description of problem:
Amorak displays an error message when asked to show its handbook

Version-Release number of selected component (if applicable):
amarok-2.0.2-6.fc10.x86_64


How reproducible:
always

Steps to Reproduce:
1.press F1, or go to the Help drop-down menu and press "Amarok Handbook"
  
Actual results:
an error popup:
        The file or folder help:/amarok/index.html does not exist.

Expected results:
The handbook is presented.

Additional info:
According to Rex Dieter, the reason is that the amarok2 handbook hasn't been written yet.

If that is the case, surely a placeholder should be installed saying "the handbook hasn't been written yet".  I wasted considerable time trying to find out why the handbook hadn't been installed.

Perhaps better would be to install the old (pre-2) handbook, with warnings about accuracy pasted at the front.

https://www.redhat.com/archives/fedora-list/2009-May/msg00049.html

Could this bug be related to 489044?
Comment 1 Rex Dieter 2009-05-03 12:01:46 EDT
No, it's not related... but odd, since I wasn't aware of any direct or indirect dependence between amarok/khelpcenter and rarian.  ??

That said, upstream and us are already aware of the missing handbook, and any help to implement the missing handbook appreciated.  I'm not sure how helpful opening a bug here will be to help address that, short of serving to track the issue (ie, highlight when it gets fixed by closing this bug).
Comment 2 Rex Dieter 2009-05-03 12:13:56 EDT
Hopefully to help address the "diagnostic" issue, and well as advertise a call for help, I'll see how hard it would be to drop in a short handbook placeholder.
Comment 3 Rex Dieter 2009-05-04 11:20:12 EDT

*** This bug has been marked as a duplicate of bug 473522 ***

Note You need to log in before you can comment on or make changes to this bug.