Bug 498848 - gnome-terminal and firefox input and display dorked after update
gnome-terminal and firefox input and display dorked after update
Status: CLOSED DUPLICATE of bug 495323
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
rawhide
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-03 19:30 EDT by Joel
Modified: 2009-05-05 13:25 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-05 13:25:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
UXA Enabled log file (101.01 KB, text/plain)
2009-05-04 16:44 EDT, Joel
no flags Details
Xorg log with EXA enabled (108.61 KB, text/plain)
2009-05-04 16:45 EDT, Joel
no flags Details
xorg.conf (1.17 KB, text/plain)
2009-05-04 16:46 EDT, Joel
no flags Details

  None (edit)
Description Joel 2009-05-03 19:30:48 EDT
Description of problem:

Running rawhide, 01 May upgrade broke gnome-terminal and firefox after logout-login.
May 01 Update:

May 01 10:36:36 Updated: 1:openoffice.org-ure-3.1.0-11.2.fc11.x86_64
May 01 10:36:43 Updated: gtk2-2.16.1-4.fc11.x86_64
May 01 10:36:44 Updated: lcms-libs-1.18-2.fc11.x86_64
May 01 10:36:50 Updated: gnome-desktop-2.26.1-4.fc11.x86_64
May 01 10:36:50 Updated: 32:bind-libs-9.6.1-0.3.b1.fc11.x86_64
May 01 10:36:51 Updated: nss_compat_ossl-0.9.5-3.fc11.x86_64
May 01 10:36:54 Updated: 1:openoffice.org-opensymbol-fonts-3.1.0-11.2.fc11.x86_64
May 01 10:36:54 Updated: 1:autocorr-ja-3.1.0-11.2.fc11.x86_64
May 01 10:36:54 Updated: kde-settings-kdm-4.2-9.20090429svn.fc11.noarch
May 01 10:36:55 Updated: 1:autocorr-en-3.1.0-11.2.fc11.x86_64
May 01 10:37:42 Updated: 1:openoffice.org-core-3.1.0-11.2.fc11.x86_64
May 01 10:37:43 Updated: 1:openoffice.org-brand-3.1.0-11.2.fc11.x86_64
May 01 10:37:49 Updated: 1:openoffice.org-calc-core-3.1.0-11.2.fc11.x86_64
May 01 10:37:51 Updated: 1:openoffice.org-impress-core-3.1.0-11.2.fc11.x86_64
May 01 10:37:59 Updated: 1:openoffice.org-presenter-screen-3.1.0-11.2.fc11.x86_64
May 01 10:38:00 Updated: 1:openoffice.org-math-core-3.1.0-11.2.fc11.x86_64
May 01 10:38:02 Updated: 1:openoffice.org-writer-core-3.1.0-11.2.fc11.x86_64
May 01 10:38:03 Updated: 1:openoffice.org-graphicfilter-3.1.0-11.2.fc11.x86_64
May 01 10:38:06 Updated: kdm-4.2.2-5.fc11.x86_64
May 01 10:38:11 Updated: 32:bind-9.6.1-0.3.b1.fc11.x86_64
May 01 10:38:12 Updated: opencv-1.0.0-15.fc11.x86_64
May 01 10:38:21 Updated: rhythmbox-0.12.1-2.fc11.x86_64
May 01 10:38:21 Updated: ksysguardd-4.2.2-5.fc11.x86_64
May 01 10:38:28 Updated: 1:openoffice.org-writer-3.1.0-11.2.fc11.x86_64
May 01 10:38:29 Updated: 1:openoffice.org-impress-3.1.0-11.2.fc11.x86_64
May 01 10:38:29 Updated: 1:openoffice.org-calc-3.1.0-11.2.fc11.x86_64
May 01 10:38:31 Updated: elinks-0.12-0.13.pre3.fc11.x86_64
May 01 10:38:32 Updated: 32:bind-utils-9.6.1-0.3.b1.fc11.x86_64
May 01 10:38:55 Updated: gnome-settings-daemon-2.26.1-3.fc11.x86_64
May 01 10:39:12 Updated: gnome-screensaver-2.26.1-2.fc11.x86_64
May 01 10:39:13 Updated: lcms-1.18-2.fc11.x86_64
May 01 10:39:25 Updated: scribus-1.3.5-0.12.beta.fc11.x86_64
May 01 10:39:28 Updated: 1:mx4j-3.0.1-8.9.fc11.x86_64
May 01 10:39:29 Updated: jakarta-commons-el-1.0-10.5.fc11.x86_64
May 01 10:39:29 Updated: 1:openoffice.org-draw-core-3.1.0-11.2.fc11.x86_64
May 01 10:39:35 Updated: 1:openoffice.org-pdfimport-3.1.0-11.2.fc11.x86_64
May 01 10:39:37 Updated: boo-0.8.1.2865-6.fc11.x86_64
May 01 10:39:38 Updated: kde-settings-4.2-9.20090429svn.fc11.noarch
May 01 10:39:54 Updated: latex2html-2008-2.fc11.noarch
May 01 10:39:54 Updated: 1:openoffice.org-draw-3.1.0-11.2.fc11.x86_64
May 01 10:39:55 Updated: kde-settings-pulseaudio-4.2-9.20090429svn.fc11.noarch
May 01 10:39:55 Updated: 32:bind-chroot-9.6.1-0.3.b1.fc11.x86_64
May 01 10:39:56 Updated: 1:openoffice.org-math-3.1.0-11.2.fc11.x86_64
May 01 10:39:57 Updated: 1:openoffice.org-xsltfilter-3.1.0-11.2.fc11.x86_64
May 01 10:39:57 Updated: 1:openoffice.org-langpack-en-3.1.0-11.2.fc11.x86_64
May 01 10:40:03 Updated: 1:openoffice.org-langpack-ja_JP-3.1.0-11.2.fc11.x86_64
May 01 10:40:04 Updated: lcms-devel-1.18-2.fc11.x86_64
May 01 10:40:05 Updated: grub-0.97-50.fc11.x86_64
May 01 10:40:06 Updated: fedora-release-10.93-2.noarch
May 01 10:40:10 Updated: gtk2-2.16.1-4.fc11.i586
May 01 10:40:18 Updated: gtk2-devel-2.16.1-4.fc11.i586
May 01 10:40:18 Updated: lcms-libs-1.18-2.fc11.i586
May 01 10:40:21 Updated: gnome-desktop-2.26.1-4.fc11.i586
May 01 10:40:25 Updated: gtk2-devel-2.16.1-4.fc11.x86_64
May 01 10:40:26 Updated: lcms-devel-1.18-2.fc11.i586
May 01 10:40:27 Updated: gnome-desktop-devel-2.26.1-4.fc11.x86_64
May 01 10:40:29 Updated: kdebase-workspace-libs-4.2.2-5.fc11.x86_64
May 01 10:40:40 Updated: kdebase-workspace-4.2.2-5.fc11.x86_64

How reproducible:
Start gnome-terminal and type.  Lots of white squares appear.  Cursor location doesn't match text location. Typing ls and enter may or may not have output appear.  Etc.  Was working fine before that.

Also, firefox has similar input problems.  And page redraws do not happen automatically.  Need to shade/unshade to see updates (usually works).  

Removed SCIM completely and restarted.  No change.
Comment 1 Joel 2009-05-04 16:44:36 EDT
Created attachment 342379 [details]
UXA Enabled log file
Comment 2 Joel 2009-05-04 16:45:13 EDT
Created attachment 342380 [details]
Xorg log with EXA enabled
Comment 3 Joel 2009-05-04 16:46:07 EDT
Created attachment 342381 [details]
xorg.conf
Comment 4 Joel 2009-05-04 16:47:54 EDT
Tried downgrading to previous gtk2 release.  NO change!

switched from UXA to EXA in xorg.conf and problem resolved!  Probably is an intel bug, not a gtk2 bug.  Funny thing is that xterm and non gtk apps don't seem to exhibit problem.
Comment 5 Joel 2009-05-04 16:48:32 EDT
PS.  Problem is on Q965
Comment 6 Matěj Cepl 2009-05-05 13:25:33 EDT

*** This bug has been marked as a duplicate of bug 495323 ***

Note You need to log in before you can comment on or make changes to this bug.