Bug 495323 - (intel-corrupt) text corruption with intel kms driver
text corruption with intel kms driver
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
: Reopened
: 495908 498174 498330 498499 498848 501713 502841 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-11 18:05 EDT by Tomasz Torcz
Modified: 2013-01-10 00:09 EST (History)
41 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-16 10:18:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
web browser with corrupted text (333.98 KB, image/png)
2009-04-11 18:05 EDT, Tomasz Torcz
no flags Details
Xorg.0.log while text corrupted (80.03 KB, text/plain)
2009-04-11 18:06 EDT, Tomasz Torcz
no flags Details
Weird screen (594.91 KB, image/png)
2009-04-13 20:54 EDT, Edney Matias
no flags Details
xterm and gnome-terminal (251.96 KB, image/png)
2009-05-03 13:37 EDT, Dan Williams
no flags Details
screenshot of the problem (185.43 KB, image/png)
2009-05-23 19:53 EDT, Matěj Cepl
no flags Details
another screenshot ... now it's "c"s (159.62 KB, image/png)
2009-05-23 19:59 EDT, Matěj Cepl
no flags Details
Artifacts when KMS is active for Intel driver (6.31 KB, image/png)
2009-05-24 05:25 EDT, Joachim Frieben
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 21790 None None None Never

  None (edit)
Description Tomasz Torcz 2009-04-11 18:05:18 EDT
Created attachment 339197 [details]
web browser with corrupted text

Description of problem:
Sometimes some letters became corrupted. It happens after running compiz, but even after stopping compiz and staring metacity (within one session) text stays corrupted.
I'm not using xorg.conf, so I have whatever configuration is default in F11 (so KMS, UXA, DRI2 I believe).

Version-Release number of selected component (if applicable):
xorg-x11-drv-intel-2.6.99.902-2.fc11.x86_64
mesa-libGL-7.5-0.8.fc11.x86_64
kernel-2.6.29.1-52.fc11.x86_64
compiz-0.7.8-18.fc11.x86_64
xorg-x11-server-Xorg-1.6.0-19.fc11.x86_64

How reproducible:
Always, corruption appear withing hour of running compiz. If compiz is started as part of session (by enabling Desktop Effects), corruption is visible in terminal at once.

Steps to Reproduce:
1. Start compiz
2. Do anything for some time.
3.
  
Actual results:
Some letters became garbled, see screenshot.

Expected results:
Ponies.


Additional info:
Hardware is Lenovo Thinkpad T400 with Centrino 2, 4GB RAM.
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
Comment 1 Tomasz Torcz 2009-04-11 18:06:10 EDT
Created attachment 339198 [details]
Xorg.0.log while text corrupted
Comment 2 Edney Matias 2009-04-13 13:12:30 EDT
Seeing this here also. Running KDE 4.2 with compositing enabled, no xorg.conf either and the texts get corrupted after a long period of use. Anothere way to make it happen is to run wine, in my case i run it to play Warcraft. When i get back, texts are messy. Any information, i can get.
Comment 3 Edney Matias 2009-04-13 20:54:24 EDT
Created attachment 339402 [details]
Weird screen

Just in case it wasn't clear yet.
Comment 4 James 2009-04-17 18:37:34 EDT
Seen here, too. Most often noticed in Firefox, but corruption of glyphs shows up elsewhere.

xorg-x11-server-Xorg-1.6.1-6.fc11.x86_64
freetype-2.3.9-3.fc11.x86_64
freetype-2.3.9-3.fc11.i586
xorg-x11-drv-intel-2.6.99.902-3.fc11.x86_64
Comment 5 Jesse Keating 2009-04-22 12:10:41 EDT
I'm seeing this as well with i965
Comment 6 Jesse Keating 2009-04-22 12:10:55 EDT
Oh and yes, I'm using compiz.
Comment 7 Kevin Fenzi 2009-04-24 12:27:59 EDT
I am seeing this here as well with Xfce. 

Some observations: 

It seems that it's just some random font that gets corrupted glyphs after some time, then any use of that font results in the corrupted glyphs. 

I have seen it in: midori, xchat, Terminal. It varies. 

I have COMPOSITE enabled, but disabling it doesn't bring back the fonts once they are corrupted. 

My card is: 
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)

I don't see anything out of the ordinary in my /var/log/Xorg.0.log. 

An example of corruption: 
http://www.scrye.com/~kevin/fedora/fonts-20090423.png

I'm happy to help with any additional debugging. This would be a very good one to fix before release.
Comment 8 Wade Mealing 2009-04-24 13:02:53 EDT
Getting the same thing, 

00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)

http://www.freeimagehosting.net/uploads/0cc0fdd364.png

Going to try and create a reproducer or find a pattern in what is happening.
Comment 9 Tomasz Torcz 2009-04-26 08:36:15 EDT
Now I'm getting corruptions even with metacity as compositor (it was happening only under compiz previously).
Comment 10 Wade Mealing 2009-04-28 03:31:34 EDT
Have not had this for a few days now, always running current rawhide.
Comment 11 Wade Mealing 2009-04-28 03:59:19 EDT
Of course, as soon as I write the comment it appears.  First corrupted page at http://www.wired.com/politics/security/news/2009/04/fleetcom?currentPage=all
Comment 12 Dan Williams 2009-04-28 10:14:54 EDT
*** Bug 495908 has been marked as a duplicate of this bug. ***
Comment 13 Hubert Figuiere 2009-05-01 20:48:44 EDT
Getting it here. I don't know if it is related, but it started to appear when the memory usage on the system increased.

00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)


F11 (10.92)
Comment 14 Dan Williams 2009-05-03 13:21:28 EDT
Just got this on rawhide with i915 (Dell D410); have always had it with i830 (Dell C400).

00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)
Comment 15 Dan Williams 2009-05-03 13:22:08 EDT
xorg-x11-drv-intel-2.7.0-2.fc11.i586
xorg-x11-server-Xorg-1.6.1-6.fc11.i586
Comment 16 Dan Williams 2009-05-03 13:23:27 EDT
I'm not sure this is Intel specific though, I also get this on a PPC iBook G4 with ATI Radeon Mobility 7500 (M7LY) every time I switch VT back to X, even at GDM without having logged in.
Comment 17 Dan Williams 2009-05-03 13:37:08 EDT
It could also be caused by cairo/freetype interacting with other parts of the system; I ran an xterm (which appears to be using the same font as gnome-terminal, not 100% sure that's the case) and the xterm didn't have any corruption.  xterm does not use cairo/freetype at all, but all the apps I've noticed corruption in (Firefox, gnome-terminal, gnome-panel, etc) do use cairo for drawing text.
Comment 18 Dan Williams 2009-05-03 13:37:43 EDT
Created attachment 342246 [details]
xterm and gnome-terminal
Comment 19 Charles R. Anderson 2009-05-03 22:40:27 EDT
I was seeing this too on Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller, but the problems *seem* to have gone away with kernel 2.6.29.2-123.fc11.x86_64.

I'm still seeing a slightly different problem though--screen corruption when opening emacs or viewing jpeg images in Eye of GNOME, the GNOME Image Viewer.  Interestingly enough, gqview doesn't have the same corruption problems.
Comment 20 Matěj Cepl 2009-05-04 09:13:25 EDT
*** Bug 498330 has been marked as a duplicate of this bug. ***
Comment 21 Mary Ellen Foster 2009-05-04 10:55:29 EDT
I still see this on my Intel graphics with the latest kernel etc. -- I use KDE, and it's never happened to any of my KDE apps (yet?), only Firefox and OpenOffice.org.
Comment 22 Mary Ellen Foster 2009-05-04 10:57:44 EDT
And, in contrast to some other comments I've seen, for me the corruption generally goes away if I close and re-open the affected app -- no need to restart X or the computer.
Comment 23 Rahul Sundaram 2009-05-04 11:41:13 EDT
I am seeing this as well in Firefox primarily. Sorry no easy reproducer.
Comment 24 Clemens Eisserer 2009-05-04 11:46:35 EDT
For me suspend to disk makes it appear more often.
Comment 25 Christopher Aillon 2009-05-04 14:22:08 EDT
*** Bug 498499 has been marked as a duplicate of this bug. ***
Comment 26 Kevin Kofler 2009-05-04 17:05:26 EDT
Ben Boeckel (MathStuf) has seen this in Qt 3 and Qt 4 apps as well, but also not in a reproducible way. This is not confined to GTK+ apps.
Comment 27 Matěj Cepl 2009-05-05 13:24:23 EDT
*** Bug 496106 has been marked as a duplicate of this bug. ***
Comment 28 Matěj Cepl 2009-05-05 13:25:05 EDT
*** Bug 498174 has been marked as a duplicate of this bug. ***
Comment 29 Matěj Cepl 2009-05-05 13:25:33 EDT
*** Bug 498848 has been marked as a duplicate of this bug. ***
Comment 31 Hin-Tak Leung 2009-05-08 22:14:10 EDT
I have something similiar with the ati driver, but I'll file a separate bug...
Comment 33 Manny 2009-05-12 23:13:59 EDT
Changing firefox zoom level helps to see pages, but this is only a work around. Changing the zoom back results in the same glyph corruption.
Comment 34 Hin-Tak Leung 2009-05-14 00:16:57 EDT
Does anybody see something like this in .xsession-error when text corruption happens?

(firefox:18539): Pango-WARNING **: shaping failure, expect ugly output. shape-engine='BasicEngineFc', font='AR PL UMing HK Light 12.705078125', text='...

(I am on ati though)
Comment 35 Ben Levenson 2009-05-14 15:06:14 EDT
Reproduced on my Lenovo X61 with the following components:

$ rpm -q xorg-x11-server-Xorg kernel metacity pango
xorg-x11-server-Xorg-1.6.1-11.fc11.x86_64
kernel-2.6.29.1-102.fc11.x86_64
kernel-2.6.29.3-140.fc11.x86_64
metacity-2.26.0-1.fc11.x86_64
pango-1.24.1-1.fc11.x86_64
pango-1.24.1-1.fc11.i586

00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c) (prog-if 00 [VGA controller])
	Subsystem: Lenovo T61
	Flags: bus master, fast devsel, latency 0, IRQ 27
	Memory at f8000000 (64-bit, non-prefetchable) [size=1M]
	Memory at e0000000 (64-bit, prefetchable) [size=256M]
	I/O ports at 1800 [size=8]
	Expansion ROM at <unassigned> [disabled]
	Capabilities: [90] MSI: Mask- 64bit- Count=1/1 Enable+
	Capabilities: [d0] Power Management version 3
	Kernel driver in use: i915
	Kernel modules: i915

00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
	Subsystem: Lenovo T61
	Flags: bus master, fast devsel, latency 0
	Memory at f8100000 (64-bit, non-prefetchable) [size=1M]
	Capabilities: [d0] Power Management version 3
Comment 36 Ben Levenson 2009-05-14 15:08:39 EDT
(In reply to comment #35)
> Reproduced on my Lenovo X61 with the following components:
> 
> $ rpm -q xorg-x11-server-Xorg kernel metacity pango
> xorg-x11-server-Xorg-1.6.1-11.fc11.x86_64
> kernel-2.6.29.1-102.fc11.x86_64
> kernel-2.6.29.3-140.fc11.x86_64
> metacity-2.26.0-1.fc11.x86_64
> pango-1.24.1-1.fc11.x86_64
> pango-1.24.1-1.fc11.i586

and, xorg-x11-drv-intel-2.7.0-4.fc11.x86_64
Comment 37 Kristian Høgsberg 2009-05-18 09:49:54 EDT
upstream bug: https://bugs.freedesktop.org/show_bug.cgi?id=21790
Comment 38 Kristian Høgsberg 2009-05-20 14:32:50 EDT
*** Bug 501713 has been marked as a duplicate of this bug. ***
Comment 39 Hubert Figuiere 2009-05-22 01:59:00 EDT
I got suggested to disable KMS at boot time, and since I have done that, I haven't had any problem. Corruption hasn't happened yet.

If anybody else can confirm the work around...

(Note: I have forgotten what is the option to pass to the kernel to disable KMS... which is not good)
Comment 40 Tom "spot" Callaway 2009-05-22 08:15:36 EDT
Well, given that this bug explicitly is about the text corruption that occurs with KMS enabled... ;)
Comment 41 Byron Clark 2009-05-22 16:21:49 EDT
After running this morning's kernel upgrade (kernel-2.6.29.3-155.fc11.x86_64) for a few hours, the corrupted glyphs seem to be gone.  Hopefully they don't start appearing in a few hours.  I've been through suspend/resume and hibernate/resume cycles and everything still seems solid.  The kernel changelog mentions a patch called drm-intel-vmalloc.patch.
Comment 42 Edney Matias 2009-05-22 16:38:19 EDT
It's been awhile since it happend to me last time. I think this is the second kernel upgrade (kernel-PAE-2.6.29.3-155.fc11.i686) that doesn't have the corrupeted glyphs anymore. It's seems working flawless now!
Comment 43 Rahul Sundaram 2009-05-22 16:50:33 EDT
Thanks for your feedback. I am closing this bug based on a couple of confirmations. If anyone else sees this again, please feel free to reopen or file a new bug report.
Comment 44 Kristian Høgsberg 2009-05-22 17:30:03 EDT
Still happens, I'll close the bug when it's fixed.
Comment 45 Kristian Høgsberg 2009-05-22 17:43:49 EDT
Thinking more about this, the GEM patch from #498131 does change the allocation mechanism for page lists in the gem fault handler.  That might change the behaviour of this bug or maybe even fix it, though it's not clear why.

Can everybody please update to kernel -155 and let us know whether the bug persists?

Thanks!
Comment 46 Kristian Høgsberg 2009-05-22 18:01:37 EDT
Never mind, it's still there...
Comment 47 Matěj Cepl 2009-05-23 19:53:43 EDT
Created attachment 345210 [details]
screenshot of the problem

I can happily reproduce it as well on my brand shiny new T400 Thinkpad with these packages (yes, I will try xorg-x11-drv-intel-2.7.0-6.fc11 in a second and will le t you know if anything changed):

bradford:~$ rpm -q xorg-x11-drv-intel kernel
xorg-x11-drv-intel-2.7.0-6.fc11.x86_64
kernel-2.6.29.3-155.fc11.x86_64
kernel-2.6.29.3-159.fc11.x86_64
bradford:~$ uname -r
2.6.29.3-159.fc11.x86_64
bradford:~$ 

However, my smart wife when looking at the corrupt text in Pan the newsreader noticed a weird thing ... ALL (without one exception I was able to find) letters "b" were corrupted, not only them but dominance of "b"s over any other letter was absolutely huge. That and the fact it seems to be more common with specific fonts (for example, I haven't seen it yet on bugzilla sans-serif text) makes me thing whether there isn't some weird interaction between Xorg drivers and Pango/Cairo in play.
Comment 48 Matěj Cepl 2009-05-23 19:59:16 EDT
Created attachment 345213 [details]
another screenshot ... now it's "c"s

Hmm, on https://fedoraproject.org/wiki/Common_F11_bugs it's "c"s. Weird.
Comment 49 Milos Jakubicek 2009-05-23 20:46:55 EDT
Just adding a smolt link of another affected machine:
http://www.smolts.org/client/show/pub_bc0e2ea3-aa19-49f3-9439-b81881fb4a74
(xorg-x11-drv-intel-2.7.0-6.fc11.x86_64)
Comment 50 Joachim Frieben 2009-05-24 05:25:19 EDT
Created attachment 345231 [details]
Artifacts when KMS is active for Intel driver

I see artifacts on an "Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device rev 3" when KMS is enabled. Text in the web browser exhibits horizontal lines/dots. However, they disappears when the image is refreshed e.g. by scrolling. The system is updated to current F11 w/updates:
- kernel-2.6.29.3-155.fc11.i586
- libdrm-2.4.6-7.fc11.i586
- mesa-*-7.5-0.14.fc11.i586
- xorg-x11-drv-intel-2.7.0-6.fc11.i586
- xorg-x11-server-Xorg-1.6.1.901-1.fc11.i586
Comment 51 Matěj Cepl 2009-05-24 08:22:41 EDT
Could you all please also upgrade kernel to the latest package from koji for F11? I did so, and I haven't seen the problem for some time ... I was not able to reproduce it 100% before, so I am not sure it is really fixed, but with BOTH kernel 2.6.29.3-159.fc11.x86_64 and xorg-x11-drv-intel-2.7.0-6.fc11.x86_64 it seems to be much better.

Check with uname -r what version of kernel you are actually running
Comment 52 Thorsten Leemhuis 2009-05-24 08:38:30 EDT
Just FYI, I yesterday saw corruption with this stack:

kernel-2.6.29.3-155.fc11.x86_64
libdrm-2.4.6-7.fc11.x86_64
xorg-x11-server-Xorg-1.6.1.901-1.fc11.x86_64
libdrm-2.4.6-7.fc11.x86_64
xorg-x11-drv-intel-2.7.0-6.fc11.x86_64

00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller [8086:2a02] (rev 0c)

Works fine today, but I guess sooner or later it will show up again. Not sure, but seems playing video makes it happen sooner
Comment 53 Matěj Cepl 2009-05-24 13:29:15 EDT
(In reply to comment #51)
> Could you all please also upgrade kernel to the latest package from koji for
> F11? I did so, and I haven't seen the problem for some time ... I was not able
> to reproduce it 100% before, so I am not sure it is really fixed, but with BOTH
> kernel 2.6.29.3-159.fc11.x86_64 and xorg-x11-drv-intel-2.7.0-6.fc11.x86_64 it
> seems to be much better.
> 
> Check with uname -r what version of kernel you are actually running  

Unfortunately, after couple of hours of running the computer with pretty heavy load (installing RHEL in a virtual machine) the corruption is back with vengeance.
Comment 54 Edney Matias 2009-05-26 08:27:36 EDT
Unfortunately it also happend to me again after a heavy load (KDE system tray showing a lot of kopete status messages ). Copositing was disabled due the heavy load. My stack right now

2.6.29.3-155.fc11.i686.PAE
xorg-x11-drv-intel-2.7.0-6.fc11.i586
xorg-x11-server-Xorg-1.6.1.901-1.fc11.i586
libdrm-2.4.6-7.fc11.i586

and my hardware

00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)

I'm attaching a pic to show the effect on amarok.
Comment 55 Jens Petersen 2009-05-26 21:24:46 EDT
I have only really seen it lightly in firefox so far for the odd character (today is 'd' ;).
Comment 56 Matěj Cepl 2009-05-27 15:14:15 EDT
*** Bug 502841 has been marked as a duplicate of this bug. ***
Comment 57 Adam Williamson 2009-05-27 17:14:24 EDT
this bug should be fixed by:

http://koji.fedoraproject.org/koji/taskinfo?taskID=1380686

can you guys please test and confirm? we intend to use this kernel for F11 final. thanks!
Comment 58 Scott Tsai 2009-05-27 19:32:30 EDT
I never figured out a way to reliably reproduce this bug in a short amount of time but kernel-2.6.29.4-167.fc11.x86_64 does seem to make a difference.

Previously, if I fill my memory with random bytes to trigger swap with:
python -c 'import random; [ random.randrange(1024) for x in xrange(3*2**30)]'
and browse around in firefox, I have a good chance to see the glyph cache corruption in about 10 minutes. I no longer see that on kernel-2.6.29.4-167.fc11.x86_64.

I'll keep testing with video playback, openGL test programs with huge textures etc and report back if I can still reproduce this bug.
Comment 59 Adam Williamson 2009-05-27 20:17:07 EDT
Thanks. I realize it takes a few days to be entirely sure if the bug is fixed, so we'll wait :) we're going ahead with the work on the final release using this kernel, but the report on whether or not it actually fixes this problems will still be useful.
Comment 60 Tom "spot" Callaway 2009-05-28 08:53:03 EDT
This new kernel does _NOT_ fix the corruption issue I originally reported as 496106 ... this bug seems to be a catchall for several intel kms corruption bugs, mine only occurs when I am in a dual screen configuration (but is readily reproducable in that configuration by launching OOo or any TCL/TK application).
Comment 61 Kristian Høgsberg 2009-05-28 09:40:31 EDT
(In reply to comment #60)
> This new kernel does _NOT_ fix the corruption issue I originally reported as
> 496106 ... this bug seems to be a catchall for several intel kms corruption
> bugs, 

Most of the comments and screenshots here have the same kind of corruption (parts of glyphs replaced by other glyphs or garbage) but a number of different corruption bugs may have been duped to this one.

> mine only occurs when I am in a dual screen configuration (but is readily
> reproducable in that configuration by launching OOo or any TCL/TK application).  

Looking at the screenshot in #496106 it's definitely a different issue.  I've unduped it.
Comment 62 Saurabh Bathe 2009-05-29 02:42:13 EDT
kernel-2.6.29.4-167.fc11.x86_64 did fix corruption and incorrect rendering of characters in all applications for me. 
T400 (Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07) ) in a spanning desktop mode using 2 monitors.

The laptop has been on for more than a day now. Still no corruption.
Comment 63 Michal Pomorski 2009-05-29 06:44:29 EDT
I second that bug for pre -167 kernels. Still evaluating the new one.
Comment 64 Jesse Keating 2009-05-29 12:14:05 EDT
I can confirm fixed as well.  Closing the bug.
Comment 65 Adam Huffman 2009-06-15 17:23:55 EDT
For me the corruption is still there with kernel -167. It tends to happen when resuming from suspend to RAM, so far as I can tell.

00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
Comment 66 Edney Matias 2009-06-15 19:50:39 EDT
I don't see this bug for a long time now.
Comment 67 Kristian Høgsberg 2009-06-16 10:18:39 EDT
(In reply to comment #65)
> For me the corruption is still there with kernel -167. It tends to happen when
> resuming from suspend to RAM, so far as I can tell.
> 
> 00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML
> Express Integrated Graphics Controller (rev 03)  

No, this particular font corruption bug is fixed.  If you see corruption with your 945, please open a new bug describing the type of corruption and ideally attach a screen shot.
Comment 68 Edney Matias 2009-07-07 10:08:06 EDT
I did an upgrade of libdrm using the one provided at updates-testing repo. I was testing for this bug https://bugzilla.redhat.com/show_bug.cgi?id=476743 and then i suspended my machine to RAM. On resume i saw some corruptions on text and graphics until the machine freezed. I then rebooted and until now nothing strange happend. Just to let you know.

Note You need to log in before you can comment on or make changes to this bug.