Bug 49904 - OverflowError: float too large to convert
OverflowError: float too large to convert
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-24 18:41 EDT by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-25 12:58:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda Traceback (1.06 KB, text/plain)
2001-07-24 18:42 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2001-07-24 18:41:15 EDT
Description of Problem:

During the actual package installation, Anaconda crashes with an error
in the progress bar code.  This is different from bug # 43087.

How Reproducible:

It is reproducible every time.

Steps to Reproduce:
1. Choose either normal install, or text expert (the two I have tried, at
least).
2. During package selection, choose "install everything".

Actual Results:

Within the first 10% of total progress in installing packages, Anaconda
will crash with the attached debug information.

Additional Information:

System is a 750 Mhz Duron, MSI K7T Turbo motherboard, 128MB PC133, 20Gb
Western Digital hard drive, ATI Mach 64 8MB video, ATAPI CD, generic
floppy, 300 watt ATX PS.  Install is done with latest ISO's found for 7.1. 
CD's are verified to be in perfect condition on other systems, including
using the same CD-ROM drive in another system with the same MB/CPU.
Comment 1 Need Real Name 2001-07-24 18:42:41 EDT
Created attachment 24847 [details]
Anaconda Traceback
Comment 2 Matt Wilson 2001-07-25 11:00:16 EDT
the values it's using should fit well within a float.  very strange.
Comment 3 Need Real Name 2001-07-25 11:14:18 EDT
I've tried a few different things today, to no avail.

1)  Loading fail-safe options in BIOS.
2)  Updating to newest BIOS version.
3)  Double-checked all hardware for proper configuration.
4)  Running a much more minimal installation (server install, no optional
    packages selected).

It seems to crash at the point (in every case) when the first "tick" should
be displayed on the "total" progress bar.  Ironically, this is always in
glibc-common, whether you install ~907 packages or ~506 packages.

I have one machine that I *might* be able to start swapping parts with.  I'll
try to do so today, since I'm in a rather big rush to get this system up and
running.
Comment 4 Brent Fox 2001-07-26 14:36:05 EDT
This is a very odd bug.  I don't really know what to tell you.  glibc-common is
always the first package that gets installed, so there's nothing unusual about
that.   Flaky hardware is the only thing I can think of at this point.  If the
problem is in software, then it sounds like a Python problem.  Anaconda is
passing Python reasonable values to compute, and Python is having problems with
simple math.  

Now, I can run a Python interpreter on my machine to duplicate this computation,
and things work fine:

[bfox@foodog bfox]$ python
Python 1.5.2 (#1, Jul  5 2001, 03:02:19)  [GCC 2.96 20000731 (Red Hat Linux 7.1
2 on linux-i386
Copyright 1991-1995 Stichting Mathematisch Centrum, Amsterdam
>>> amount = 3282820
>>> total = 4668248
>>> print (int(((amount * 1.0)/total) * 100))
70
So, I've demonstrated that Python can handle these numbers...just not on your
machine for some reason.  I can't think of any reason other than hardware...

Please reopen this bug if you can reproduce it on another machine.
Comment 5 Need Real Name 2001-07-31 11:03:58 EDT
Further testing shows that this is indeed a bad motherboard or CPU.  I
originally suspected this, but figured someone else might benefit from this
entry if they happen to see a similar error.

Testing w/identical hardware with a new motherboard/cpu seems to resolve all
issues.

Note You need to log in before you can comment on or make changes to this bug.