Bug 499143 - Unnessesary warnings during text-installation
Unnessesary warnings during text-installation
Status: CLOSED DUPLICATE of bug 456325
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.3
All Linux
low Severity low
: rc
: ---
Assigned To: Martin Sivák
Release Test Team
https://www.redhat.com/archives/anaco...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-05 07:44 EDT by Niels de Vos
Modified: 2009-05-29 03:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-29 03:54:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Suppress warning about changing to text-mode if not in graphics-mode (1.59 KB, patch)
2009-05-05 07:47 EDT, Niels de Vos
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
CentOS 3606 None None None Never

  None (edit)
Description Niels de Vos 2009-05-05 07:44:38 EDT
Description of problem:
when starting the installer (anaconda) in text-mode, the installer (depending on hardware) gives following warnings about not using the graphical installer:

1) You do not have enough RAM to use the graphical installer. Starting text mode.
2) Graphical installation not available... Starting text mode.


Version-Release number of selected component (if applicable):
anaconda-11.1.2.168-1.el5


How reproducible:
Start the installer in text-mode. Add parameter 'text' on the kernel-cmdline or include this directive in ks.cfg.

1) is displayed when the system has 128MB of RAM.
2) is displayed when the installer uses minstg2.img instead of stage2.img 

  
Actual results:
Behavior as expected - installation finished ok.


Expected results:
Behavior as expected - installation finished ok.


Additional info:
minstg2.img contains an other error when installing in VMware. lspci is missing and makes anaconda backtrace. However this is not relevant to this issue, just a note for any other repoducers. (Bug 476476)
Comment 1 Niels de Vos 2009-05-05 07:47:06 EDT
Created attachment 342440 [details]
Suppress warning about changing to text-mode if not in graphics-mode

If the user requested text-mode or cmdline-mode it is not needed to display a message about missing X (minstg2.img) or too little memory.

Signed-off-by: Niels de Vos <niels.devos@wincor-nixdorf.com>
Comment 2 Niels de Vos 2009-05-08 09:33:23 EDT
looks like this one is related to bug 456325
Comment 5 RHEL Product and Program Management 2009-05-29 02:30:13 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 6 Martin Sivák 2009-05-29 03:54:21 EDT
I've just realized that the fix (and the proposed patch) is the same as the one for #456325 and was commited on 2nd of April. So I'm changing this to DUP after all and adding the content of this bug to #456325.

*** This bug has been marked as a duplicate of bug 456325 ***

Note You need to log in before you can comment on or make changes to this bug.