Bug 499301 - nouveau driver 20090501 causes display to be unreadable
nouveau driver 20090501 causes display to be unreadable
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-05 22:23 EDT by Jonathan Smith
Modified: 2009-05-17 18:07 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-17 18:01:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (1.39 KB, text/plain)
2009-05-05 22:23 EDT, Jonathan Smith
no flags Details
Xorg.0.log, as requested (107.16 KB, text/plain)
2009-05-05 22:35 EDT, Jonathan Smith
no flags Details
double-screen photo (118.61 KB, image/jpeg)
2009-05-05 22:36 EDT, Jonathan Smith
no flags Details
closeup of a single screen (108.26 KB, image/jpeg)
2009-05-05 22:37 EDT, Jonathan Smith
no flags Details
xorg.0.log from the failing session (71.89 KB, text/plain)
2009-05-07 14:37 EDT, Jonathan Smith
no flags Details
Xorg.0.log from the mirrored session using 20090514git9656762 (112.94 KB, text/plain)
2009-05-17 13:36 EDT, Jonathan Smith
no flags Details

  None (edit)
Description Jonathan Smith 2009-05-05 22:23:42 EDT
Created attachment 342578 [details]
xorg.conf

xorg-x11-drv-nouveau-0.0.12-31.20090421git47bb00f.fc11.x86_64 works wonderfully on rawhide.

However, upon updating to 0.0.12-33.20090501gitf69b34a.fc11, the display is unreadable. I believe the geometry is being incorrectly set, but I can't open an xterm to see what it is set to.

Other than xorg-x11-drv-nouveau, the system is fully up-to-date with rawhide as of 20090505.

I will attach my xorg.conf and pictures (crappy iPhone pictures) of the problem.
Comment 1 Ben Skeggs 2009-05-05 22:29:54 EDT
Can you also attach /var/log/Xorg.0.log please :)
Comment 2 Jonathan Smith 2009-05-05 22:35:25 EDT
Created attachment 342580 [details]
Xorg.0.log, as requested
Comment 3 Jonathan Smith 2009-05-05 22:36:29 EDT
Created attachment 342581 [details]
double-screen photo
Comment 4 Jonathan Smith 2009-05-05 22:37:11 EDT
Created attachment 342582 [details]
closeup of a single screen

Apologies for the photo quality... all I have to take them with is an iPhone.
Comment 5 Ben Skeggs 2009-05-05 23:01:25 EDT
Hmm, that X log isn't from the failing version of the driver (your outputs would be named DVI-I-0 and DVI-I-1 rather than DVI-1 and DVI-3 if it were) :)
Comment 6 Jonathan Smith 2009-05-07 14:37:34 EDT
Created attachment 342910 [details]
xorg.0.log from the failing session
Comment 7 Jonathan Smith 2009-05-07 14:39:33 EDT
I tried xorg-x11-drv-nouveau-0.0.12-34.20090507git1072103.fc11.x86_64 and it has the same problems. Since it had the same problems, I had to roll back xorg-server-{common,Xorg} due to bug 499570. So my current (working) stack is:

xorg-x11-drv-nouveau-0.0.12-31.20090421git47bb00f.fc11.x86_64.rpm
xorg-x11-server-common-1.6.1-6.fc11.x86_64.rpm
xorg-x11-server-Xorg-1.6.1-6.fc11.x86_64.rpm
Comment 8 Ben Skeggs 2009-05-16 04:20:33 EDT
Give xorg-x11-drv-nouveau-0.0.12-36.20090514git9656762.fc11 a shot, this should be fixed.  The build hasn't been tagged into the release yet, but you can grab it here: http://koji.fedoraproject.org/koji/buildinfo?buildID=102141

Thanks!
Comment 9 Jonathan Smith 2009-05-17 13:35:35 EDT
Using xorg-x11-drv-nouveau-0.0.12-36.20090514git9656762.fc11, the display is mirrored on the two monitors. Needless to say, this defeats the purpose of multiple monitors.

Are there any config changes I should make with newer versions? I have no modified my xorg.conf since the original posting.
Comment 10 Jonathan Smith 2009-05-17 13:36:58 EDT
Created attachment 344339 [details]
Xorg.0.log from the mirrored session using 20090514git9656762
Comment 11 Ben Skeggs 2009-05-17 18:01:34 EDT
This is not a bug, the default configuration is to bring all displays up in clone mode.  You can use gnome-display-properties to configure another layout if you desire.

I'll close this bug now as it's been fixed :)
Comment 12 Ben Skeggs 2009-05-17 18:07:17 EDT
Just a side-note, I see you've configured a non-default layout in xorg.conf.  You'll need to rename monitor-DVI-1 and monitor-DVI-3 to monitor-DVI-I-0 and monitor-DVI-I-1, nv50's connector naming changed in -32 to match the pre-nv50 code, and kms.

Note You need to log in before you can comment on or make changes to this bug.