Bug 499408 - can't install Fedora11preview to HP Proliant DL385 w/ cciss
can't install Fedora11preview to HP Proliant DL385 w/ cciss
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-06 11:01 EDT by Aron Griffis
Modified: 2009-06-25 15:28 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-25 15:28:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda exception report (93.07 KB, text/plain)
2009-05-06 11:01 EDT, Aron Griffis
no flags Details
patch to fix install on cciss (529 bytes, patch)
2009-05-14 18:02 EDT, Doug Chapman
no flags Details | Diff

  None (edit)
Description Aron Griffis 2009-05-06 11:01:40 EDT
Created attachment 342671 [details]
Anaconda exception report

Attempted VNC install of Fedora 11 Preview on DL385 w/ SmartArray.  Chose "custom partitioning". Anaconda choked.  See attached traceback.

Version-Release number of selected component (if applicable):
Fedora 11 preview

How reproducible:
Every time
Comment 1 Aron Griffis 2009-05-06 11:36:33 EDT
Fwiw, I pulled a couple older releases to test.  Fedora 11 Beta fails with the same problem.  Fedora 11 Alpha works.
Comment 2 Aron Griffis 2009-05-06 11:41:53 EDT
and Rawhide install via netboot fails the same way
Comment 3 Doug Chapman 2009-05-11 16:09:15 EDT
Still an issue on latest rawhide with anaconda-11.5.0.51

I will do some more digging on this.
Comment 4 Doug Chapman 2009-05-12 17:03:04 EDT
Still digging into this and learing more about how to debug anaconda.

I have found that it works OK when there are not any existing partitions on the cciss disks.  The traceback comes from when it tries to get info on existing partitions using getDeviceByName.  Looking at what data is available at that point I see the disk entries (i.e. cciss/c0d0) but I don't see that it ever added entries for partitions (such as cciss/c0d0p1)
Comment 5 Hans de Goede 2009-05-12 17:12:04 EDT
(In reply to comment #4)
> Still digging into this and learing more about how to debug anaconda.
> 
> I have found that it works OK when there are not any existing partitions on the
> cciss disks.  The traceback comes from when it tries to get info on existing
> partitions using getDeviceByName.  Looking at what data is available at that
> point I see the disk entries (i.e. cciss/c0d0) but I don't see that it ever
> added entries for partitions (such as cciss/c0d0p1)  

Where does it get the devicename from it passes to getDeviceByName ? If it is from a device node name, such as for example /dev/cciss/c0d0p1, the correct
way to get the name from the device node path is to use devicePathToName(),
some places used to do devicepath.split('/')[-1], which is wrong, maybe I missed one.
Comment 6 Doug Chapman 2009-05-14 18:02:16 EDT
Created attachment 344054 [details]
patch to fix install on cciss

since cciss device names have a subdirectory (i.e. cciss/c0d0p1) they are represented in sysfs with a ! so that it doesn't incorrectly have an extra subdir in the sysfs namespace.  When anaconda gets the device name from sysfs it was trying to lookup the name with a ! but anaconda stores them with the / in the name.

Simple 1 line fix is attached.  Please take this patch for F11 as nearly the entire HP Proliant line will be broken without it (nearly all of these systems use cciss for storage).
Comment 7 Linda Knippers 2009-05-14 18:40:27 EDT
I second that request.  Otherwise F11 will fail to install on practically all 
ProLiant servers and we'd really like to get some testing with 
Fedora before there are RHEL6 alphas. 

BTW, we also noticed in the F11 alpha, which does install on a ProLiant,
that the cciss driver was missing from the initrd.   It was reported
in https://bugzilla.redhat.com/show_bug.cgi?id=484260 an appeared to have
been fixed but it seems to be a chronic problem so hopefully it is 
still fixed.
Comment 8 Hans de Goede 2009-05-15 03:13:15 EDT
Doug, thanks1

The patch has been applied to the current anaconda tree, and will be
in the next build of anaconda (11.5.0.53), can you please test a rawhide
install when 11.5.0.53 is in rawhide, and report if cciss installs work now ?
Comment 9 Aron Griffis 2009-05-19 10:25:05 EDT
I don't see this in rawhide yet. Will it be in F11? It would be nice if we could test a couple installs with this patch before release.
Comment 10 Hans de Goede 2009-05-19 12:55:01 EDT
(In reply to comment #9)
> I don't see this in rawhide yet. Will it be in F11? It would be nice if we
> could test a couple installs with this patch before release.  

The fix is in this build:
http://koji.fedoraproject.org/koji/buildinfo?buildID=102607

Which has an f11-final tag, so it should show up in rawhide rsn.
Comment 11 Doug Chapman 2009-05-19 13:28:04 EDT
I see this on the internal redhat fedora mirror so it just has not made it out to all mirrors yet.  I did a quick test and it appears to be working properly on cciss now.  I will do a couple more installs with different cases but it looks like this should be resolved.
Comment 12 Bug Zapper 2009-06-09 11:15:27 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.