Bug 49942 - opl3sa2 isapnp activation broken
opl3sa2 isapnp activation broken
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
: 49948 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-25 11:48 EDT by Gerald Teschl
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-04 12:04:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/proc/isapnp befor setting up the card (2.23 KB, text/plain)
2001-08-21 09:21 EDT, Gerald Teschl
no flags Details
patch to opl3sa2.c (1.18 KB, patch)
2002-06-04 12:01 EDT, Gerald Teschl
no flags Details | Diff
patch which makes the use of dma channel 0 configurable (3.14 KB, patch)
2002-06-07 04:06 EDT, Gerald Teschl
no flags Details | Diff
patch which fixes the isapnp activation of newer opl3sa4 cards which only accept dma channel 0 (1.80 KB, patch)
2002-06-07 04:08 EDT, Gerald Teschl
no flags Details | Diff

  None (edit)
Description Gerald Teschl 2001-07-25 11:48:06 EDT
The opl3sa2 driver has an isapnp option but if inserted with isapnp=1 it
fails to
activate the card and subsequently does not find it. If I activate the card
by writing
to /proc/isapnp

cat > /proc/isapnp <<EOF
card 0 YMH0800
dev 0 YMH0021
port 0 0x220
port 1 0x530
port 2 0x388
port 3 0x330
port 4 0x370
irq 0 5
dma 0 0
dma 1 1
activate
dev 0 YMH0022
port 0 0x201
activate
EOF


and then insert the module with isapnp=1 it works fine.
Comment 1 Bill Nottingham 2001-07-25 13:25:52 EDT
*** Bug 49948 has been marked as a duplicate of this bug. ***
Comment 2 Glen Foster 2001-07-25 19:10:42 EDT
This defect is considered SHOULD-FIX for the Fairfax release.
Comment 3 Arjan van de Ven 2001-08-17 08:20:07 EDT
How is the card identified BEFORE you set values into it ?
Comment 4 Gerald Teschl 2001-08-21 09:20:03 EDT
You mean the content of /proc/isapnp ?

Comment 5 Gerald Teschl 2001-08-21 09:21:08 EDT
Created attachment 28695 [details]
/proc/isapnp befor setting up the card
Comment 6 Gerald Teschl 2002-05-24 07:32:53 EDT
Still broken in 7.3.
Comment 7 Gerald Teschl 2002-06-03 08:13:57 EDT
I debugged this problem: The cause is that the card requires dma=0 to work but
isapnp.c excludes "0" for dma values. I have sent a proposed patch to the
kernel mailing list.
Comment 8 Gerald Teschl 2002-06-04 12:01:56 EDT
Created attachment 59528 [details]
patch to opl3sa2.c
Comment 9 Gerald Teschl 2002-06-04 12:04:00 EDT
This is the patch which fixes the problem (it has been discussed on
the kernel/sound mailing list).
Comment 10 Arjan van de Ven 2002-06-05 07:33:04 EDT
Added for the next errata build
Comment 11 Gerald Teschl 2002-06-07 04:04:44 EDT
I had some further discussions with the maintainer of the opl3sa2 driver
and we decided that a better fix is to add this as a quirk to the isapnp
driver. I'll attach the two necessary patches. Sorry...
Comment 12 Gerald Teschl 2002-06-07 04:06:25 EDT
Created attachment 60004 [details]
patch which makes the use of dma channel 0 configurable
Comment 13 Gerald Teschl 2002-06-07 04:08:25 EDT
Created attachment 60005 [details]
patch which fixes the isapnp activation of newer opl3sa4 cards which only accept dma channel 0

Note You need to log in before you can comment on or make changes to this bug.