Bug 49948 - sndconfig fails to configur ym opl3sa2 card
Summary: sndconfig fails to configur ym opl3sa2 card
Status: CLOSED DUPLICATE of bug 49942
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sndconfig   
(Show other bugs)
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-25 16:02 UTC by Gerald Teschl
Modified: 2014-03-17 02:22 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-25 16:02:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gerald Teschl 2001-07-25 16:02:12 UTC
Subject says it all. If the card is not activated, there will be an error
playing the au sample. If I activate the card by hand it will play the au
sample fine
but produce an error when trying to play the midi sample.

The card works by calling

cat > /proc/isapnp <<EOF
card 0 YMH0800
dev 0 YMH0021
port 0 0x220
port 1 0x530
port 2 0x388
port 3 0x330
port 4 0x370
irq 0 5
dma 0 0
dma 1 1
activate
dev 0 YMH0022
port 0 0x201
activate
EOF

before inserting the module and with the following module parameters:

options sound dmabuf=1
alias synth0 opl3
options opl3 io=0x388
options opl3sa2 ymode=2 isapnp=1

Comment 1 Bill Nottingham 2001-07-25 17:25:57 UTC
For drivers with native ISAPnP support, sndconfig relies on the kernel to
be able to detect it correctly.

*** This bug has been marked as a duplicate of 49942 ***


Note You need to log in before you can comment on or make changes to this bug.