Bug 49943 - internal animation loop makes light sources to disappear
internal animation loop makes light sources to disappear
Status: CLOSED WONTFIX
Product: Red Hat Powertools
Classification: Retired
Component: povray (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: bero
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-25 11:49 EDT by David Nečas
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-17 10:33:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
scene and initialization files (1.09 KB, application/octet-stream)
2001-07-25 11:52 EDT, David Nečas
no flags Details

  None (edit)
Description David Nečas 2001-07-25 11:49:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT)

Description of problem:
When I use light sources with look_like statement in internal animation 
loop (the light source positions depend on time), they disappear (or just 
don't illuminate anything, or no_shadow stops working) in all frames 
except the first.  When I use external animation loop and specify the same 
times explicite, the light sources are rendered correctly.

How reproducible:
Always

Steps to Reproduce:
1. unpack the attached archive disappearing-light.tar.bz2
2. cd into the created directory disappearing-light
3. run
   $ povray internal.ini
4. run
   $ povray external.ini
	

Actual Results:  Two images are created by step 3 (disappearing-
light1.ppm, disappearing-light2.ppm) and one by step 4 (disappearing-
light.ppm), all showing a dark scene with a big red letter G and two shiny 
white balls (the only light sources in the scene) whose positions depend 
on clock value.

disappearing-light1.ppm is rendered with clock = 0 as first frame in 
internal animation loop, the two balls illimunate the G.

disappearing-light2.ppm is rendered with clock = 0.4 as second frame in 
internal animation loop, the balls are in different position, otherwise 
looking the same, but the letter G is NOT iluminated.

disappearing-light.ppm (this is a reference image) is rendered with 
explicitely specified clock = 0.4 showing two balls illimunating the G.

Expected Results:  Everything as in actual results, except: The images 
disappearing-light2.ppm and disappearing-light.ppm should be identical, 
both looking like disappearing-light.ppm.

Additional info:
Comment 1 David Nečas 2001-07-25 11:52:20 EDT
Created attachment 24927 [details]
scene and initialization files
Comment 2 David Nečas 2001-07-30 11:05:39 EDT
Small correction: the images are rendered at clock = 0.25, not clock = 0.4.

New observation: povray prints

  Scene contains 3 frame level objects; 0 infinite.

when rendering disappearing-light2.ppm (the bad one), while it prints

  Scene contains 15 frame level objects; 0 infinite.

when rendering the other (good) images.  So the lights seem to `phsically'
disappear.
Comment 3 Bernhard Rosenkraenzer 2002-02-21 08:41:02 EST
Since powertools has been discontinued, there's no future release to fix this in.

Note You need to log in before you can comment on or make changes to this bug.