Bug 499431 - fish:// copy freeze
fish:// copy freeze
Status: CLOSED DUPLICATE of bug 516416
Product: Fedora
Classification: Fedora
Component: kdebase-runtime (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Lorenzo Villani
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-06 12:13 EDT by Pierre Blavy
Modified: 2009-09-04 09:23 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-04 09:23:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pierre Blavy 2009-05-06 12:13:06 EDT
Description of problem:
- Remote copy with fish:// starts, and at a random point the speeds drops to 0o/s and the copy remains frozen. The pause resume button do not do anything.



- The freeze happens around 1 min or 30 seconds, the delay is random and do not depends on the files you are copying.





Version-Release number of selected component (if applicable): Fedora 10
last yum update : 06 may 2009



How reproducible:
- Random, but very frequent on big files or long file copy.
- independant on copied files : copying the sames files to the same destination can sometimes works or freeze.


Steps to Reproduce:
1. open 2 tabs in konqueror or dolphin (I've tried both) .
2. enter fish ://someone@remotemachine in the address bar of tab 1
3. enter some local place in the address bar of tab 2
4. copy files from your computer (tab2) to the remote machine (tab1) or from the remote machine to your computer. (I've tried both) 
5. click on the blue circle with a i inside and show the copy dialog box.
6. wait, drink a coffea, some beer, and have a social life.





Actual results:
ch.


- I've reproduced this bug with 4 differents computers (PC1 to PC 4). I've tried the following copy : 
PC1 : Fedora 10 to (and from) PC 2 : Fedora 10
PC1 : Fedora 10 to (and from) PC 3 : EEEbuntu
PC1 : Fedora 10 to (and from) PC 4 : Fedora 8
PC2 : Fedora 10 to (and from) PC 3 : EEEbuntu (and a live version of Fedora 9) 

PC1 : x86_64
PC2 : x86_64
PC3 : i686
PC4 : i686


- This bug doesn't seems to be related to a broken network : I tryed to ping the remote computer all the time with success, and others things such as ssh - X remotemachine worked perfectly. Morever, I've reproduced this bug on my personal network and on my office network so it's not a broken cable, or a bad switch.

- This bug happens with and WITHOUT hard or symbolic links in the copied filed.

- This bug happens with any number of files (including one),  and the freeze happens at any point in the file.

- I've never tried a command line remote copy (like rcp).


Expected results:
fish:// copy do not freeze.

Additional info:
Comment 1 Pierre Blavy 2009-05-11 05:17:19 EDT
scp in commandline works properly.
Comment 2 Lorenzo Villani 2009-07-03 08:15:07 EDT
This bug seems to be unrelated to the fish shell, since the wrong component was specified, I'm changing it to kdebase-workspace.
Comment 3 Kevin Kofler 2009-07-03 08:24:44 EDT
kio_fish is actually in kdebase-runtime.
Comment 4 Lorenzo Villani 2009-07-22 09:16:15 EDT
Anyway, this bug has been repored more than two months ago, I'm going to close this in two weeks unless the reporter adds some comments.

In addition: you can try kio_sftp, just use sftp:// instead of fish://, this requires the (usually enabled) sftp subsystem on the remote host.
Comment 5 Pierre Blavy 2009-07-22 10:18:49 EDT
I do not have a sftp server.
I'll try to install one but it will take me some time because I do not know how to do.

Since I've reported the bug, I've upgraded my fedora from 10 to 11, so I'll confirm if the bug still exists.
Comment 6 Kevin Kofler 2009-07-22 10:25:06 EDT
The SFTP server is part of the OpenSSH server. Some distros ship with it disabled for some stupid reason, but it's just one line in the config file on the server to enable it (add the following line:
Subsystem       sftp    /usr/libexec/openssh/sftp-server
to the server's /etc/ssh/sshd_config file).
Comment 7 Lorenzo Villani 2009-07-25 13:40:17 EDT
AFAIK, the sftp subsystem is enabled by default on Fedora, at least I have never had to enable it manually. I guess that if you didn't change the configuration files, and have sshd started, you should be able to use both fish and sftp.

Anyway, let us know if using sftp directly instead of fish works..
Comment 8 Pierre Blavy 2009-08-05 05:48:55 EDT
Thank you for your help.

fish:// does not work (even in Fedora 11 after the 03-august-2009 update) 
sftp:// works. (tested with a 3.2 GB folder)
Comment 9 Lorenzo Villani 2009-09-04 08:35:48 EDT
Thank you for the bug report. At the moment, the Fedora developers are busy fixing other issues and may not have time to work on this one. The best way to make sure your problem will get looked on is to report it to the authors of the program. Most upstream authors use a bug tracking system like Bugzilla, and more people who know the code will be looking at the bug report there. 

The upstream bug tracking system to use is: 
http://bugs.kde.org/

You are requested to add the bugzilla link here for tracking purposes. Please make sure the bug isn't already in the upstream bug tracker before filing it.
Comment 10 Lukáš Tinkl 2009-09-04 09:23:18 EDT

*** This bug has been marked as a duplicate of bug 516416 ***

Note You need to log in before you can comment on or make changes to this bug.