Bug 516416 - fish protocol broken in kde 4.3
fish protocol broken in kde 4.3
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kdebase-runtime (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Lukáš Tinkl
Fedora Extras Quality Assurance
:
: 499431 (view as bug list)
Depends On:
Blocks: kde-4.3.0
  Show dependency treegraph
 
Reported: 2009-08-09 10:02 EDT by Paul Scott
Modified: 2015-07-13 13:35 EDT (History)
11 users (show)

See Also:
Fixed In Version: 2.4-4.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-25 00:44:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 189235 None None None Never

  None (edit)
Description Paul Scott 2009-08-09 10:02:38 EDT
Description of problem:

I'm getting the following error in Dolphin when trying to connect to a
server via ssh.

Connection to server <name> is broken

It appears in the Dolphin window (either in the bottom or as a popup).

Unfortunately it doesn't happen all the time. If a successful
connection is made and I can browse the directory on the remote host,
then it will likely pop up when performing a file operation (e.g. copy
a local file to the remote host).

The dialog is an information dialog, there is no crash and nothing
written to stdout when it occurs.

Version-Release number of selected component (if applicable):
KDE 4.3

How reproducible:


Steps to Reproduce:
1. Create ssh connection in Dolphin to remove server
2. Connect to remote service via Dolphin
3. If it doesn't fail immediately, attempt few file operations 
  
Actual results:
Dialog or message at bottom of dolphin window Connection to server <name> is broken. Desired operation fails. 

Expected results:
Operation should succeed

Additional info:
Comment 1 Rex Dieter 2009-08-09 11:19:20 EDT
reassigning -> kdebase-runtime (that's where kio_fish lives)
Comment 2 Rex Dieter 2009-08-09 11:33:14 EDT
Tracking upstream @ http://bugs.kde.org/189235
Comment 3 Lukáš Tinkl 2009-08-12 07:27:00 EDT
I have reverted what we believe is the offending revision and built packages to test:

http://koji.fedoraproject.org/koji/taskinfo?taskID=1600490

Please grab and install them and tell us if it indeed fixes the fish protocol, thx.
Comment 4 Lukáš Tinkl 2009-08-12 08:15:29 EDT
Fixed submitted anyway, confirmed to work by me and others at #fedora-kde.

Will land with the 4.3 updates
Comment 5 Paul Scott 2009-08-13 13:33:21 EDT
(In reply to comment #3)
> I have reverted what we believe is the offending revision and built packages to
> test:
> 
> http://koji.fedoraproject.org/koji/taskinfo?taskID=1600490
> 
> Please grab and install them and tell us if it indeed fixes the fish protocol,
> thx.  

Grabbed the packages as requested and tested - I confirm this fixes the fish protocol. Thanks!
Comment 6 Fedora Update System 2009-08-15 04:19:24 EDT
qscintilla-2.4-4.fc11, kdebindings-4.3.0-4.fc11.1, kdeedu-4.3.0-4.fc11, kdepim-4.3.0-2.fc11, libmsn-4.0-0.12.beta7.fc11, PyKDE-3.16.3-1.fc11, PyQt4-4.5.4-1.fc11, PyQt-3.18.1-1.fc11, sip-4.8.2-1.fc11, kdelibs-4.3.0-2.fc11, kdeaccessibility-4.3.0-3.fc11, kdeadmin-4.3.0-1.fc11, kdeartwork-4.3.0-1.fc11, kdebase-4.3.0-1.fc11, kdebase-workspace-4.3.0-5.fc11, kdegames-4.3.0-2.fc11, kdegraphics-4.3.0-1.fc11, kdelibs-experimental-4.3.0-1.fc11, kdemultimedia-4.3.0-1.fc11, kdenetwork-4.3.0-1.fc11, kdepim-runtime-4.3.0-1.fc11, kdepimlibs-4.3.0-2.fc11, kdeplasma-addons-4.3.0-5.fc11, kdesdk-4.3.0-1.fc11, kdetoys-4.3.0-1.fc11, kdeutils-4.3.0-3.fc11, kde-plasma-stasks-0.5.1-6.fc11, soprano-2.3.0-2.fc11, strigi-0.7.0-1.fc11, akonadi-1.2.0-1.fc11, kdegames3-3.5.10-6.fc11, kde-i18n-3.5.10-9.fc11, kde-l10n-4.3.0-1.fc11, oxygen-icon-theme-4.3.0-1.fc11, digikam-0.10.0-2.fc11, kdebase-runtime-4.3.0-4.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update qscintilla kdebindings kdeedu kdepim libmsn PyKDE PyQt4 PyQt sip kdelibs kdeaccessibility kdeadmin kdeartwork kdebase kdebase-workspace kdegames kdegraphics kdelibs-experimental kdemultimedia kdenetwork kdepim-runtime kdepimlibs kdeplasma-addons kdesdk kdetoys kdeutils kde-plasma-stasks soprano strigi akonadi kdegames3 kde-i18n kde-l10n oxygen-icon-theme digikam kdebase-runtime'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-8368
Comment 7 Fedora Update System 2009-08-19 19:14:19 EDT
qscintilla-2.4-4.fc11, kdebindings-4.3.0-4.fc11.1, kdeedu-4.3.0-4.fc11, kdepim-4.3.0-2.fc11, libmsn-4.0-0.12.beta7.fc11, PyKDE-3.16.3-1.fc11, PyQt4-4.5.4-1.fc11, PyQt-3.18.1-1.fc11, sip-4.8.2-1.fc11, kdeaccessibility-4.3.0-3.fc11, kdeadmin-4.3.0-1.fc11, kdeartwork-4.3.0-1.fc11, kdebase-4.3.0-1.fc11, kdebase-workspace-4.3.0-5.fc11, kdegames-4.3.0-2.fc11, kdegraphics-4.3.0-1.fc11, kdelibs-experimental-4.3.0-1.fc11, kdemultimedia-4.3.0-1.fc11, kdenetwork-4.3.0-1.fc11, kdepim-runtime-4.3.0-1.fc11, kdepimlibs-4.3.0-2.fc11, kdeplasma-addons-4.3.0-5.fc11, kdesdk-4.3.0-1.fc11, kdetoys-4.3.0-1.fc11, kdeutils-4.3.0-3.fc11, kde-plasma-stasks-0.5.1-6.fc11, soprano-2.3.0-2.fc11, strigi-0.7.0-1.fc11, akonadi-1.2.0-1.fc11, kdegames3-3.5.10-6.fc11, kde-i18n-3.5.10-9.fc11, kde-l10n-4.3.0-1.fc11, oxygen-icon-theme-4.3.0-1.fc11, digikam-0.10.0-2.fc11, kdebase-runtime-4.3.0-4.fc11, kdelibs-4.3.0-5.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update qscintilla kdebindings kdeedu kdepim libmsn PyKDE PyQt4 PyQt sip kdeaccessibility kdeadmin kdeartwork kdebase kdebase-workspace kdegames kdegraphics kdelibs-experimental kdemultimedia kdenetwork kdepim-runtime kdepimlibs kdeplasma-addons kdesdk kdetoys kdeutils kde-plasma-stasks soprano strigi akonadi kdegames3 kde-i18n kde-l10n oxygen-icon-theme digikam kdebase-runtime kdelibs'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-8368
Comment 8 Fedora Update System 2009-08-21 20:57:38 EDT
qscintilla-2.4-4.fc11, kdebindings-4.3.0-4.fc11.1, kdelibs-4.3.0-6.fc11, kdeartwork-4.3.0-2.fc11, kdebase-workspace-4.3.0-8.fc11, kdeedu-4.3.0-5.fc11, kdepim-4.3.0-4.fc11, kdeplasma-addons-4.3.0-8.fc11, libmsn-4.0-0.12.beta7.fc11, PyKDE-3.16.3-1.fc11, PyQt4-4.5.4-1.fc11, PyQt-3.18.1-1.fc11, sip-4.8.2-1.fc11, kdeaccessibility-4.3.0-3.fc11, kdeadmin-4.3.0-1.fc11, kdebase-4.3.0-1.fc11, kdegames-4.3.0-2.fc11, kdegraphics-4.3.0-1.fc11, kdelibs-experimental-4.3.0-1.fc11, kdemultimedia-4.3.0-1.fc11, kdenetwork-4.3.0-1.fc11, kdepim-runtime-4.3.0-1.fc11, kdepimlibs-4.3.0-2.fc11, kdesdk-4.3.0-1.fc11, kdetoys-4.3.0-1.fc11, kdeutils-4.3.0-3.fc11, kde-plasma-stasks-0.5.1-6.fc11, soprano-2.3.0-2.fc11, strigi-0.7.0-1.fc11, akonadi-1.2.0-1.fc11, kdegames3-3.5.10-6.fc11, kde-i18n-3.5.10-9.fc11, kde-l10n-4.3.0-1.fc11, oxygen-icon-theme-4.3.0-1.fc11, digikam-0.10.0-2.fc11, kdebase-runtime-4.3.0-4.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update qscintilla kdebindings kdelibs kdeartwork kdebase-workspace kdeedu kdepim kdeplasma-addons libmsn PyKDE PyQt4 PyQt sip kdeaccessibility kdeadmin kdebase kdegames kdegraphics kdelibs-experimental kdemultimedia kdenetwork kdepim-runtime kdepimlibs kdesdk kdetoys kdeutils kde-plasma-stasks soprano strigi akonadi kdegames3 kde-i18n kde-l10n oxygen-icon-theme digikam kdebase-runtime'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-8368
Comment 9 Fedora Update System 2009-08-25 00:34:18 EDT
qscintilla-2.4-4.fc10, kdebase-workspace-4.3.0-9.fc10, kdeedu-4.3.0-6.fc10, kdelibs-4.3.0-6.fc10, kdeartwork-4.3.0-2.fc10, kdepim-4.3.0-4.fc10, kdeplasma-addons-4.3.0-8.fc10, qzion-0.4.0-1.fc10, qedje-0.4.0-1.fc10, libmsn-4.0-0.12.beta7.fc10, PyKDE-3.16.3-1.fc10, PyQt4-4.5.4-1.fc10, PyQt-3.18.1-1.fc10, sip-4.8.2-1.fc10, kdeaccessibility-4.3.0-3.fc10, kdeadmin-4.3.0-1.fc10, kdebase-4.3.0-1.fc10, kdegames-4.3.0-2.fc10, kdegraphics-4.3.0-1.fc10, kdelibs-experimental-4.3.0-1.fc10, kdemultimedia-4.3.0-1.fc10, kdenetwork-4.3.0-1.fc10, kdepim-runtime-4.3.0-1.fc10, kdepimlibs-4.3.0-2.fc10, kdesdk-4.3.0-1.fc10, kdetoys-4.3.0-1.fc10, kdeutils-4.3.0-3.fc10, kde-plasma-stasks-0.5.1-6.fc10, soprano-2.3.0-2.fc10, strigi-0.7.0-1.fc10, akonadi-1.2.0-1.fc10, kdegames3-3.5.10-6.fc10, kde-i18n-3.5.10-9.fc10, kde-l10n-4.3.0-1.fc10, oxygen-icon-theme-4.3.0-1.fc10, digikam-0.10.0-2.fc10, kdebase-runtime-4.3.0-4.fc10, kdebindings-4.3.0-4.fc10.1 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2009-08-25 00:43:53 EDT
qscintilla-2.4-4.fc11, kdebindings-4.3.0-4.fc11.1, kdebase-workspace-4.3.0-9.fc11, kdeedu-4.3.0-6.fc11, kdelibs-4.3.0-6.fc11, kdeartwork-4.3.0-2.fc11, kdepim-4.3.0-4.fc11, kdeplasma-addons-4.3.0-8.fc11, libmsn-4.0-0.12.beta7.fc11, PyKDE-3.16.3-1.fc11, PyQt4-4.5.4-1.fc11, PyQt-3.18.1-1.fc11, sip-4.8.2-1.fc11, kdeaccessibility-4.3.0-3.fc11, kdeadmin-4.3.0-1.fc11, kdebase-4.3.0-1.fc11, kdegames-4.3.0-2.fc11, kdegraphics-4.3.0-1.fc11, kdelibs-experimental-4.3.0-1.fc11, kdemultimedia-4.3.0-1.fc11, kdenetwork-4.3.0-1.fc11, kdepim-runtime-4.3.0-1.fc11, kdepimlibs-4.3.0-2.fc11, kdesdk-4.3.0-1.fc11, kdetoys-4.3.0-1.fc11, kdeutils-4.3.0-3.fc11, kde-plasma-stasks-0.5.1-6.fc11, soprano-2.3.0-2.fc11, strigi-0.7.0-1.fc11, akonadi-1.2.0-1.fc11, kdegames3-3.5.10-6.fc11, kde-i18n-3.5.10-9.fc11, kde-l10n-4.3.0-1.fc11, oxygen-icon-theme-4.3.0-1.fc11, digikam-0.10.0-2.fc11, kdebase-runtime-4.3.0-4.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Lukáš Tinkl 2009-09-04 09:23:18 EDT
*** Bug 499431 has been marked as a duplicate of this bug. ***
Comment 12 Pierre Blavy 2009-09-04 12:41:14 EDT
KDE 4.3.1 changelog:
Support for transferring files through SSH using KIO::Fish has been fixed 

So wait for the next fedora KDE release
Comment 13 Kevin Kofler 2009-09-04 13:00:18 EDT
That fix is already in kdelibs-4.3.0-2 and newer builds. No stable Fedora update had this issue at all. No need to wait for anything at all, this is already fixed! (And in fact this is why it's CLOSED ERRATA.)

Note You need to log in before you can comment on or make changes to this bug.