Bug 499458 - Defaults for proxy installer do not match documentation
Defaults for proxy installer do not match documentation
Status: CLOSED DUPLICATE of bug 498251
Product: Red Hat Satellite Proxy 5
Classification: Red Hat
Component: Installer (Show other bugs)
530
All Linux
high Severity high
: ---
: ---
Assigned To: Miroslav Suchý
Jeff Browning
:
Depends On:
Blocks: 456999
  Show dependency treegraph
 
Reported: 2009-05-06 14:19 EDT by Jeff Browning
Modified: 2009-08-07 15:04 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-07 04:24:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Browning 2009-05-06 14:19:33 EDT
Description of problem:
When installing proxy from the command like, the default for the version to install does not match what is in the documentation. The default is 0.5, while in the docs it says it should be 5.3.

Also, the default CA chain matches the docs when installing to an x86_64 box, but not when installing to an i386 box. For i386, the default is:

CA Chain [/usr/share/rhn/RHNS-CA-CERT]: 

Version-Release number of selected component (if applicable):
spacewalk-proxy-installer-0.5.25-2.el4sat

How reproducible:
100%

Steps to Reproduce
1. Install spacewalk-proxy-installer
2. Run the setup program without an answer file
  
Actual results:
For all cases, default Proxy version to install is 0.5

For i386, CA Chain [/usr/share/rhn/RHNS-CA-CERT]: 

Expected results:
It should match the docs, or the docs should match it...

Proxy version to activate [5.3]:

CA Chain [/usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT]:


Additional info:
Comment 1 Miroslav Suchý 2009-05-07 04:24:46 EDT
The first is duplicate of 498251

the default for CA Chain is taken from /etc/sysconfig/rhn/up2date 
Therefore if you register against hosted, you have there:
/usr/share/rhn/RHNS-CA-CERT
And against satellite there is 
/usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT
Which is IMO not a bug.

*** This bug has been marked as a duplicate of bug 498251 ***

Note You need to log in before you can comment on or make changes to this bug.