Bug 499544 - PartitionException: Can't have overlapping partitions.
PartitionException: Can't have overlapping partitions.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:d7b04c81ffd752d8c...
: CommonBugs
: 501547 (view as bug list)
Depends On:
Blocks: 512486
  Show dependency treegraph
 
Reported: 2009-05-07 02:11 EDT by A.J. Werkman
Modified: 2010-04-14 11:31 EDT (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 512486 (view as bug list)
Environment:
Last Closed: 2009-08-26 11:24:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
jlaska: fedora_requires_release_note?


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (228.68 KB, text/plain)
2009-05-07 02:11 EDT, A.J. Werkman
no flags Details
anaconda log (327.23 KB, text/plain)
2009-05-12 08:13 EDT, IBM Bug Proxy
no flags Details
Anaconda dump log (109.75 KB, text/plain)
2009-05-20 06:42 EDT, IBM Bug Proxy
no flags Details
Attached traceback automatically from anaconda. (452.44 KB, text/plain)
2009-05-23 04:45 EDT, Vladi
no flags Details
Attached traceback automatically from anaconda. (284.87 KB, text/plain)
2009-06-25 11:14 EDT, Prakash P
no flags Details
Attached traceback automatically from anaconda. (1.66 MB, text/plain)
2009-07-12 10:56 EDT, vadsys
no flags Details
Attached traceback automatically from anaconda. (906.95 KB, text/plain)
2009-07-21 07:15 EDT, Lorenzo Villani
no flags Details
Attached traceback automatically from anaconda. (372.52 KB, text/plain)
2010-04-05 12:43 EDT, Mukasa Chris
no flags Details

  None (edit)
Description A.J. Werkman 2009-05-07 02:11:32 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.49 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.6/site-packages/parted/disk.py", line 183, in addPartition
    constraint.getPedConstraint())
  File "/usr/lib/anaconda/storage/devices.py", line 778, in addPartition
    constraint=constraint)
  File "/usr/lib/anaconda/storage/devices.py", line 1160, in create
    self.disk.addPartition(self)
  File "/usr/lib/anaconda/storage/deviceaction.py", line 203, in execute
    self.device.create(intf=intf)
  File "/usr/lib/anaconda/storage/devicetree.py", line 671, in processActions
    action.execute(intf=self.intf)
  File "/usr/lib/anaconda/storage/__init__.py", line 238, in doIt
    self.devicetree.processActions()
  File "/usr/lib/anaconda/packages.py", line 117, in turnOnFilesystems
    anaconda.id.storage.doIt()
PartitionException: Can't have overlapping partitions.
Comment 1 A.J. Werkman 2009-05-07 02:11:40 EDT
Created attachment 342774 [details]
Attached traceback automatically from anaconda.
Comment 2 IBM Bug Proxy 2009-05-12 08:13:37 EDT
Created attachment 343574 [details]
anaconda log


------- Comment on attachment From pavan.naregundi@in.ibm.com 2009-05-12 06:47 EDT-------


While installing F11 rawhide with custom partitioning gave error saying  "Can't have overlapping partitions". 


===========================
anaconda 11.5.0.47 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.6/site-packages/parted/disk.py", line 183, in addPartition
    constraint.getPedConstraint())
  File "/usr/lib/anaconda/storage/devices.py", line 778, in addPartition
    constraint=constraint)
  File "/usr/lib/anaconda/storage/devices.py", line 1160, in create
    self.disk.addPartition(self)
  File "/usr/lib/anaconda/storage/deviceaction.py", line 203, in execute
    self.device.create(intf=intf)
  File "/usr/lib/anaconda/storage/devicetree.py", line 671, in processActions
    action.execute(intf=self.intf)
  File "/usr/lib/anaconda/storage/__init__.py", line 238, in doIt
    self.devicetree.processActions()
  File "/usr/lib/anaconda/packages.py", line 117, in turnOnFilesystems
    anaconda.id.storage.doIt()
PartitionException: Can't have overlapping partitions.
==============================

Machine: P550
CPU Type: Power5

Attaching anaconda dump file
Comment 3 Chris Lumens 2009-05-19 13:26:17 EDT
*** Bug 501547 has been marked as a duplicate of this bug. ***
Comment 4 Chris Lumens 2009-05-19 15:40:56 EDT
*** Bug 500664 has been marked as a duplicate of this bug. ***
Comment 5 IBM Bug Proxy 2009-05-20 06:42:48 EDT
Created attachment 344775 [details]
Anaconda dump log


------- Comment on attachment From pavan.naregundi@in.ibm.com 2009-05-20 06:39 EDT-------


Still the bug is reproducible in latest rawhide(anaconda 11.5.0.52)

Steps:
1. Select custom partition 
2. Select to resize the PreP partition. Call trace gets generated.
Comment 6 James Laska 2009-05-20 08:41:20 EDT
Straight forward reproducer in rh comment#5, thanks Pavan!
Comment 7 Vladi 2009-05-23 04:45:47 EDT
Created attachment 345185 [details]
Attached traceback automatically from anaconda.
Comment 8 James Laska 2009-05-26 11:45:43 EDT
This bug has been reproduced on IBM Power5 (using the 'prep' resize steps posted by Pavan in comment#5).  I have also reproduced this on x86 systems while editing existing partitions.

I am not clear about the exact nature of the reproducer.  I would like to document this issue on the Common_F11_Bugs page, but could use some guidance.
Comment 9 James Laska 2009-05-27 10:26:05 EDT
This issue has been documented in the Common_F11_Bugs page.  Please advise if the wording or recommended workaround are incorrect.

https://fedoraproject.org/wiki/Common_F11_bugs#499544

Thanks,
James
Comment 10 Bill McGonigle 2009-05-31 13:11:17 EDT
I got this with two blank 1TB disks (new from factory).  I created three RAID mirrors:

200MB /boot, /dev/md0, /dev/sda1, /dev/sdb1
16347MB swap, encrypted, /dev/md1, /dev/sda2, /dev/sdb2
65536MB /, encrypted, /dev/md2, /dev/sda3, /dev/sdb3

I then tried to create a new software RAID partition of 262144MB, and partitioning failed saying there was insufficient space to create a new partition (not so).  Figuring I could add my /home and /var after install, I decided to proceed, and hit this error.

Traceback in attachment 346016 [details].
Comment 11 Bug Zapper 2009-06-09 11:17:37 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 12 Thomas Vander Stichele 2009-06-20 12:20:58 EDT
In my case, I was not resizing existing partitions.  I encountered this while trying to install Fedora 11 on two fresh 1 TB Seagate drives.

The layout I was going for was:

on each disk:
 - 1 200 MB partition as sw raid
 - 1 2048 MB partition as swap
 - 1 (rest of disk) as sw raid

Then, /dev/md0 from the two first partitions, and /dev/md1 from the two third partitions.

Then, LVM on top of the third partition, with various partitions (/ and /home and others).
Comment 13 Thomas Vander Stichele 2009-06-20 12:26:58 EDT
some additional feedback: after rebooting, I noticed sda was partitioned, while sdb wasn't.

Running fdisk manually on sda complained that partition 1 and 2 were not ending on a cylinder boundary.

doing a manual fdisk of /dev/sdb with the same sizes as I had done in the GUI, showed very different results for the block counts.  So something seems messed up when anaconda partitions the first disk, probably indeed having overlapping blocks, then crapping out on disk sda and leaving sdb untouched.
Comment 14 Prakash P 2009-06-25 11:14:15 EDT
Created attachment 349411 [details]
Attached traceback automatically from anaconda.
Comment 15 vadsys 2009-07-12 10:56:44 EDT
Created attachment 351390 [details]
Attached traceback automatically from anaconda.
Comment 16 Antonio Gallardo 2009-07-17 17:56:10 EDT
Maybe this might help:

Automatic partitioning installing Fedora 11 x86_64 is creating the overlapping, but don't throw an exception.

We installed 3 machines on new discs of 40GB and 80GB with F11 x86_64 and we left default configuration for partitioning and we noted that on all machines there is overlapping. Note the overlapping: sda1 end in 26 and sda2 start in 26 when sda2 should start in 27. Here is the output of fdisk -l after installation:

# fdisk -l

Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x36273627

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1          26      204800   83  Linux
Partition 1 does not end on cylinder boundary.
/dev/sda2              26        9729    77943361   8e  Linux LVM

Disk /dev/dm-0: 75.7 GB, 75753324544 bytes
255 heads, 63 sectors/track, 9209 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00000000

Disk /dev/dm-0 doesn't contain a valid partition table

Disk /dev/dm-1: 4060 MB, 4060086272 bytes
255 heads, 63 sectors/track, 493 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00000000

Disk /dev/dm-1 doesn't contain a valid partition table
Comment 17 Denise Dumas 2009-07-20 10:38:40 EDT
Also cloned to rhel6 bz 512486
Comment 18 Bill McGonigle 2009-07-20 12:04:08 EDT
Should this block F12Alpha?
Comment 19 Lorenzo Villani 2009-07-21 07:15:02 EDT
Created attachment 354461 [details]
Attached traceback automatically from anaconda.
Comment 20 Joel Andres Granados 2009-08-03 10:21:36 EDT
(In reply to comment #16)
> Maybe this might help:
> 
> Automatic partitioning installing Fedora 11 x86_64 is creating the overlapping,
> but don't throw an exception.

Well, If anaconda encounters partitions that are invalid, it should error out. I am worried about the comments that state that the installation was executed on new disks and it failed.
Comment 21 Joel Andres Granados 2009-08-06 05:57:10 EDT
I posted some patches to pyparted that addressed partition size calculation (off by one error)  Should be present in pyparted 2.1.1.  I have also changed the way parted gives some error messages.  It used "Can't have overlapping partitions." When overlapping partitions was not the cause of the problem. Will be present in parted-1.9.0-10.  I think these two changes allow us to move forward with this issue.

When you are sure that you have these two versions of pyparted and parted, can you pls retest?
Comment 22 Joel Andres Granados 2009-08-06 08:34:09 EDT
on further study of the code I have decided not to change the parted message.  This means that you can test with parted-1.9.0-9.
Comment 23 IBM Bug Proxy 2009-08-26 08:43:48 EDT
------- Comment From pavan.naregundi@in.ibm.com 2009-08-26 08:37 EDT-------
I did not see this issue in F12 Alpha.

Thanks
Pavan
Comment 24 IBM Bug Proxy 2009-08-27 00:53:33 EDT
------- Comment From anoop.vijayan@in.ibm.com 2009-08-27 00:46 EDT-------
Closing at IBM ..
Comment 25 Mukasa Chris 2010-04-05 12:43:33 EDT
Created attachment 404513 [details]
Attached traceback automatically from anaconda.
Comment 26 Antonio Gallardo 2010-04-14 11:31:12 EDT
We did 2 new instalations with F12 and still the same issue is happenning. sda2 should start at 27 not at 26:

# fdisk -l /dev/sda

Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x0002bef6

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1          26      204800   83  Linux                                                                                                                     
Partition 1 does not end on cylinder boundary.                                                                                                                                    
/dev/sda2              26        9729    77943361   8e  Linux LVM


I have no right to reopen this issue. However it mgiht be worth to check if F13 has the same bug.

(In reply to comment #16)
> Maybe this might help:
> 
> Automatic partitioning installing Fedora 11 x86_64 is creating the overlapping,
> but don't throw an exception.
> 
> We installed 3 machines on new discs of 40GB and 80GB with F11 x86_64 and we
> left default configuration for partitioning and we noted that on all machines
> there is overlapping. Note the overlapping: sda1 end in 26 and sda2 start in 26
> when sda2 should start in 27. Here is the output of fdisk -l after
> installation:
> 
> # fdisk -l
> 
> Disk /dev/sda: 80.0 GB, 80026361856 bytes
> 255 heads, 63 sectors/track, 9729 cylinders
> Units = cylinders of 16065 * 512 = 8225280 bytes
> Disk identifier: 0x36273627
> 
>    Device Boot      Start         End      Blocks   Id  System
> /dev/sda1   *           1          26      204800   83  Linux
> Partition 1 does not end on cylinder boundary.
> /dev/sda2              26        9729    77943361   8e  Linux LVM
> 
> Disk /dev/dm-0: 75.7 GB, 75753324544 bytes
> 255 heads, 63 sectors/track, 9209 cylinders
> Units = cylinders of 16065 * 512 = 8225280 bytes
> Disk identifier: 0x00000000
> 
> Disk /dev/dm-0 doesn't contain a valid partition table
> 
> Disk /dev/dm-1: 4060 MB, 4060086272 bytes
> 255 heads, 63 sectors/track, 493 cylinders
> Units = cylinders of 16065 * 512 = 8225280 bytes
> Disk identifier: 0x00000000
> 
> Disk /dev/dm-1 doesn't contain a valid partition table

Note You need to log in before you can comment on or make changes to this bug.