Bug 501547 - PartitionException: Can't have overlapping partitions.
PartitionException: Can't have overlapping partitions.
Status: CLOSED DUPLICATE of bug 499544
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:247442041c03863f7...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-19 13:23 EDT by James Laska
Modified: 2013-09-02 02:36 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-19 13:26:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (470.94 KB, text/plain)
2009-05-19 13:23 EDT, James Laska
no flags Details
Attached traceback automatically from anaconda. (206.27 KB, text/plain)
2009-05-21 12:41 EDT, Marc Stammbach
no flags Details
Attached traceback automatically from anaconda. (550.25 KB, text/plain)
2009-05-26 11:42 EDT, James Laska
no flags Details
Attached traceback automatically from anaconda. (600.71 KB, text/plain)
2009-05-31 13:02 EDT, Bill McGonigle
no flags Details
Attached traceback automatically from anaconda. (251.80 KB, text/plain)
2009-06-10 06:32 EDT, Steven Whately
no flags Details
Attached traceback automatically from anaconda. (1.05 MB, text/plain)
2009-06-20 12:17 EDT, Thomas Vander Stichele
no flags Details
Attached traceback automatically from anaconda. (7.77 MB, text/plain)
2009-06-25 14:23 EDT, Nathanael Noblet
no flags Details
Attached traceback automatically from anaconda. (198.80 KB, text/plain)
2009-10-20 17:24 EDT, Charles Butterfield
no flags Details

  None (edit)
Description James Laska 2009-05-19 13:23:03 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.53 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.6/site-packages/parted/disk.py", line 183, in addPartition
    constraint.getPedConstraint())
  File "/usr/lib/anaconda/storage/devices.py", line 791, in addPartition
    constraint=constraint)
  File "/usr/lib/anaconda/storage/devices.py", line 1201, in create
    self.disk.addPartition(self)
  File "/usr/lib/anaconda/storage/deviceaction.py", line 203, in execute
    self.device.create(intf=intf)
  File "/usr/lib/anaconda/storage/devicetree.py", line 671, in processActions
    action.execute(intf=self.intf)
  File "/usr/lib/anaconda/storage/__init__.py", line 238, in doIt
    self.devicetree.processActions()
  File "/usr/lib/anaconda/packages.py", line 117, in turnOnFilesystems
    anaconda.id.storage.doIt()
PartitionException: Can't have overlapping partitions.
Comment 1 James Laska 2009-05-19 13:23:08 EDT
Created attachment 344653 [details]
Attached traceback automatically from anaconda.
Comment 2 Chris Lumens 2009-05-19 13:26:17 EDT

*** This bug has been marked as a duplicate of bug 499544 ***
Comment 3 Marc Stammbach 2009-05-21 12:41:05 EDT
Created attachment 344990 [details]
Attached traceback automatically from anaconda.
Comment 4 James Laska 2009-05-26 11:42:53 EDT
Created attachment 345488 [details]
Attached traceback automatically from anaconda.
Comment 5 Bill McGonigle 2009-05-31 13:02:27 EDT
Created attachment 346016 [details]
Attached traceback automatically from anaconda.
Comment 6 Steven Whately 2009-06-10 06:32:56 EDT
Created attachment 347193 [details]
Attached traceback automatically from anaconda.
Comment 7 Thomas Vander Stichele 2009-06-20 12:17:26 EDT
Created attachment 348747 [details]
Attached traceback automatically from anaconda.
Comment 8 Nathanael Noblet 2009-06-25 14:23:45 EDT
Created attachment 349443 [details]
Attached traceback automatically from anaconda.
Comment 9 Charles Butterfield 2009-10-20 17:24:22 EDT
Created attachment 365429 [details]
Attached traceback automatically from anaconda.

Note You need to log in before you can comment on or make changes to this bug.