Bug 499716 - NetworkManager kills wired and wireless networking on resume from suspend
NetworkManager kills wired and wireless networking on resume from suspend
Status: CLOSED DUPLICATE of bug 477964
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-07 15:04 EDT by Lindsay Murphy
Modified: 2009-05-07 18:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-07 18:01:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
System log of a typical suspend/resume cycle. Manual restart of NM at 14:26:39. (19.82 KB, text/plain)
2009-05-07 15:04 EDT, Lindsay Murphy
no flags Details

  None (edit)
Description Lindsay Murphy 2009-05-07 15:04:12 EDT
Created attachment 342920 [details]
System log of a typical suspend/resume cycle.  Manual restart of NM at 14:26:39.

Description of problem:
Resume from suspend results in NetworkManager disabling all network adapters.  Networking must be manually restarted.

Version-Release number of selected component (if applicable):
0.7.1-3.git20090414.fc11

How reproducible:
Always

Steps to Reproduce:
1. Boot laptop
2. Suspend (either from menu or close lid)
3. Resume
  
Actual results:
NetworkManager shows "disconnected" icon.  Left-click icon to see "Networking disabled."  Right-clicking icon produces "Enable Networking" check box.  After checking, networking resumes normal (automatic) operation.

Expected results:
NetworkManager restarts device(s), locates and connects to network automatically on resume from suspend.

Additional info:
Toshiba Satellite M55-S325, Intel Pentium M 1.73 GHz, 1.5 GB RAM, Intel PRO/Wireless 2200BG onboard.  Haven't tested this with wired networking, but suspect that bug #469303 may be involved, as I have seen occasional kernel oopses with this error.
Comment 1 Niels Haase 2009-05-07 18:01:39 EDT
Thank you for the bug report. This particular bug has already been reported into our bug tracking system, but please feel free to report any further bugs you find.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 477964 ***

Note You need to log in before you can comment on or make changes to this bug.