Bug 499778 - Unable to drop resolutions below 1280x960 on Dell Vostro 1510 with Intel X3100 and WUXGA display
Unable to drop resolutions below 1280x960 on Dell Vostro 1510 with Intel X310...
Status: CLOSED DUPLICATE of bug 487244
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-08 02:11 EDT by thomas.swan
Modified: 2009-05-08 14:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-08 14:00:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (58.90 KB, text/plain)
2009-05-08 02:17 EDT, thomas.swan
no flags Details
Output from monitor-get-edid (128 bytes, application/octet-stream)
2009-05-08 02:18 EDT, thomas.swan
no flags Details

  None (edit)
Description thomas.swan 2009-05-08 02:11:09 EDT
Description of problem:
The intel driver is unable to parse the EDID information from the WUXGA display
on a Vostro 1510 with an Intel X3100 video adapter.  The result is only 
the 1920x1200 resolution is avaialble.  I have manually been able to add
resolutions via xorg.conf and xrandr, but there are regressions with regards
to the resolutions that can be displayed.  Under Fedora 10, all "normal"/vesa
resolutions were available, due to correct parsing of the EDID data.

Version-Release number of selected component (if applicable):
xorg-x11-drv-intel-2.7.0-4.fc11.x86_64

How reproducible:
Always with the Prerelease Fedora 11 (Rawhide) 

Steps to Reproduce:
1. Remove xorg.conf from /etc/X11/xorg.conf
2. Start X
3. Go to display settings (Only 1920x1200) available
4. Add modes via xrandr 
5. Can only create modes that won't blank display down to 1280x960-60Hz
  
Actual results:
A. Blank display when manually trying to change resolutions below 1280x960
B. xrandr only shows 1920x1200-60 as a valid resolution
C  Starting StarCraft in wine displays the game in the upper left corner of the 
screen (at 1920x1200) and runs slow. 

Expected results:
From Fedora 10:
A. Change display modes down to 640x480 without blanking display
B. xrandr displays all valid modes between 1920x1200 and 640x400.
C. Running StarCraft under wine should change resolutions and go full screen at
   640x480


Additional info:
Output from Xorg.0.log will be attached.
Comment 1 thomas.swan 2009-05-08 02:17:19 EDT
Created attachment 343049 [details]
Xorg.0.log
Comment 2 thomas.swan 2009-05-08 02:18:43 EDT
Created attachment 343050 [details]
Output from monitor-get-edid
Comment 3 Adam Jackson 2009-05-08 12:00:04 EDT
No, it's parsing the EDID info correctly, the EDID is just crap and only contains the one mode.

There's a patch for this in CVS but we're not enabling it yet, there's still problems with tiling setup when going in and out of small video modes.  Screen full of garbage at the right mode isn't really that useful...
Comment 4 Adam Jackson 2009-05-08 14:00:15 EDT

*** This bug has been marked as a duplicate of bug 487244 ***

Note You need to log in before you can comment on or make changes to this bug.