Bug 487244 - Not detecting all possible resolutions
Not detecting all possible resolutions
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
card_965GM
: Reopened
: 499778 (view as bug list)
Depends On:
Blocks: F12Target
  Show dependency treegraph
 
Reported: 2009-02-24 18:23 EST by Michael Monreal
Modified: 2009-11-09 03:59 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-09 03:59:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (67.07 KB, text/plain)
2009-02-24 18:25 EST, Michael Monreal
no flags Details

  None (edit)
Description Michael Monreal 2009-02-24 18:23:01 EST
The 2.6.0-7 driver package solved Bug 486613 (not using native resolution) for me. But it introduced another problem: now, *only* the native resolution is listed as a possible resolution:

$ xrandr 
Screen 0: minimum 320 x 200, current 1280 x 800, maximum 8192 x 8192
VGA1 disconnected (normal left inverted right x axis y axis)
LVDS1 connected 1280x800+0+0 (normal left inverted right x axis y axis) 331mm x 207mm
   1280x800       60.0*+
TV1 unknown connection (normal left inverted right x axis y axis)
   1024x768       60.0  
   800x600        60.3  
   640x480        59.9
Comment 1 Michael Monreal 2009-02-24 18:25:58 EST
Created attachment 333098 [details]
Xorg.0.log

Here's the relevant Xorg log. I'm not using any xorg.conf
Comment 2 Michael Monreal 2009-04-03 07:46:33 EDT
I'm still only getting native (1280x800) resolution. While not a big deal for desktop usage, it's a big problem for games which now need to be played at this quite high resolution). Please fix this before F11 is released.
Comment 3 Adam Jackson 2009-05-08 13:59:53 EDT
There's a patch for this in CVS, but it's not enabled yet because there are still bugs when transitioning between tiled and linear screen layouts (>= 1024x768 are tiled, smaller are linear).
Comment 4 Adam Jackson 2009-05-08 14:00:17 EDT
*** Bug 499778 has been marked as a duplicate of this bug. ***
Comment 5 Bug Zapper 2009-06-09 07:38:02 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Michael Monreal 2009-08-15 08:21:32 EDT
Still the same in F11 but I recently tested a RawHide snapshot and there it seems to work fine. I don't think the fix will be ported back which means this bug can probably be closed now.
Comment 7 Vedran Miletić 2009-09-06 03:27:17 EDT
In Fedora 11 package is named xorg-x11-drv-intel. Changing bugs apropriately.
Comment 8 Michael Monreal 2009-09-09 13:00:21 EDT
Strike what I said in comment #6. While this *was* working at some point in RawHide after F11's release, it is not working anymore on today's RawHide :(

Was the patch you mentioned in comment #3 included at some point and then taken out again?
Comment 9 Matěj Cepl 2009-11-05 12:12:38 EST
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, which may have resolved this issue. Users who have experienced this problem are encouraged to upgrade their system to the latest version of their packages (at least F12Beta, but even better if the very latest versions).

Please, if you experience this problem on the up-to-date system, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[This is a bulk message for all open Fedora Rawhide Xorg-related bugs. I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]
Comment 10 Michael Monreal 2009-11-08 16:59:11 EST
Seems to be fixed in current F12, so the bug can be closed.
Comment 11 Matěj Cepl 2009-11-09 03:56:39 EST
Thank you for letting us know.

Note You need to log in before you can comment on or make changes to this bug.