Bug 499832 - Update Applet remains in GNOME taskbar after updates are complete
Update Applet remains in GNOME taskbar after updates are complete
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
11
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-08 09:52 EDT by Stephen Gallagher
Modified: 2009-06-25 05:32 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-25 05:32:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Gallagher 2009-05-08 09:52:14 EDT
Description of problem:
The update applet alerts the user that there are updates to install. I select "Update System Now" and it goes through the process and completely installs all updates. After it is finished, the applet remains visible and continues to report that updates are available.

Version-Release number of selected component (if applicable):
gnome-packagekit-2.27.2-0.2.20090414git.fc11.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Wait for an available update (in my case, this happened just after installing the Fedora 11 Preview three days ago and again today when further updates became available)
2. When the update applet notifies you of available updates, select "Update System Now"
3. Once the process is complete, observe that the applet does not go away.
  
Actual results:
The update applet reports that updates are available (the same number it was reporting before the update was run). If you attempt to run "Update System Now", it reports that there are no available updates, but still does not remove the applet notification from the taskbar.

Expected results:
After completing the update, the notification area should be cleared of the available updates notification.

Additional info:
Comment 1 Yul Rottmann 2009-05-09 17:06:50 EDT
I think this is a duplicate of:
https://bugzilla.redhat.com/show_bug.cgi?id=498709
Comment 2 Stephen Gallagher 2009-05-11 07:23:51 EDT
It's not quite a duplicate, as Bug 498709 states that it only happens when using yum from the commandline. My description above shows that it occurs when using the Software Update tool directly from the Update Applet.

If you wish to merge these two bugs and include that information, I'd be fine with that.
Comment 3 Yul Rottmann 2009-05-11 09:08:58 EDT
I'd say it's the same core problem. I can't put these two bugs together, so someone else would need to do this anyway. I'd say these two should be one bug with a note. :)
Comment 4 Dan Beard 2009-05-26 14:15:42 EDT

Same problem here with Update Applet 2.27.2. as of this morning.   

2.6.29.3-155.fc11.x86_64 

After updates complete, icon disappears, then reappears a few minutes later indicating updates are available.


Dan
Comment 5 Rodd Clarkson 2009-05-26 20:21:02 EDT
I suspect that this is actually a duplicate of #492005

https://bugzilla.redhat.com/show_bug.cgi?id=492005
Comment 6 Richard Hughes 2009-06-03 05:21:30 EDT
Can you try installing https://admin.fedoraproject.org/updates/F11/FEDORA-2009-5750 and https://admin.fedoraproject.org/updates/F11/FEDORA-2009-5748 and then reboot please. If it fixes things, please report that as positive karma for the update. Thanks.
Comment 7 Bug Zapper 2009-06-09 11:27:14 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.