This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 499851 - Why remove -devel and -libs
Why remove -devel and -libs
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: openmpi (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Doug Ledford
Fedora Extras Quality Assurance
:
: 511532 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-08 11:15 EDT by Orion Poplawski
Modified: 2009-11-20 17:01 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-20 17:01:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2009-05-08 11:15:22 EDT
Description of problem:

Why remove -devel and -libs sub-packages?  Guidelines state that files for development only should go into a -devel package:

https://fedoraproject.org/wiki/Packaging:Guidelines#Devel_Packages


At the very least it is usual to do:

Obsoletes: %{name}-devel < %{version}-%{release}
Provides: %{name}-devel = %{version}-%{release}

See https://fedoraproject.org/wiki/PackagingDrafts/ProvidesObsoletes

when dropping sub-packages.


I see that this has not been pushed as an update yet, but I ran into it trying to compile paraview which has a BR (properly I think) on openmpi-devel.

Version-Release number of selected component (if applicable):
openmpi-1.3.1-2.fc11.x86_64
Comment 1 Susi Lehtola 2009-05-25 03:03:46 EDT
Yes, please provide at least openmpi-devel, since otherwise one needs more conditionals in spec files (at the moment there is already one for mpi-selector in RHEL and another for environment-modules in newer Fedoras).

Also, please fix #476844 before pushing the update.
Comment 2 Bug Zapper 2009-06-09 11:27:49 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Doug Ledford 2009-06-30 10:31:00 EDT
I'll probably add the -devel back (or else make a psuedo provides for the -devel package).  The libs don't need separated out because they are intrinsically tied to the runtime.  You could link against the libs, but without the runtime, they don't provide a functional MPI interface (such as there are no MPI ranks available, etc).  You could also do without the -devel package under normal conditions, but at least for the openmpi-1.3.2 update that I'm preparing, the -devel package will be required as openmpi-1.3.2 is binary incompatible with all previous versions meaning all openmpi linked apps will have to be recompiled.  In the future that won't be the case and the -devel package would truly be optional.
Comment 4 Susi Lehtola 2009-07-15 05:48:46 EDT
*** Bug 511532 has been marked as a duplicate of this bug. ***
Comment 5 Susi Lehtola 2009-07-15 05:57:53 EDT
(In reply to comment #3)
> I'll probably add the -devel back (or else make a psuedo provides for the
> -devel package).  The libs don't need separated out because they are
> intrinsically tied to the runtime.  You could link against the libs, but
> without the runtime, they don't provide a functional MPI interface (such as
> there are no MPI ranks available, etc).  You could also do without the -devel
> package under normal conditions, but at least for the openmpi-1.3.2 update that
> I'm preparing, the -devel package will be required as openmpi-1.3.2 is binary
> incompatible with all previous versions meaning all openmpi linked apps will
> have to be recompiled.  In the future that won't be the case and the -devel
> package would truly be optional.  

Okay. OpenMPI 1.3.3 has been released, could you update to that?

I see you have removed the -devel and -libs packages in the cvs branch of F-11,
but haven't touched the rawhide branch..
Comment 6 Doug Ledford 2009-07-21 11:16:28 EDT
I've restored the -devel package (but not the -libs package as the libs are not really useful without the runtime anyway).  Resolved in openmpi-1.3.3-1
Comment 7 Fedora Update System 2009-07-21 11:52:07 EDT
openmpi-1.3.3-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/openmpi-1.3.3-1.fc11
Comment 8 Fedora Update System 2009-07-23 15:06:17 EDT
openmpi-1.3.3-2.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openmpi'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-7951
Comment 9 Alex Lancaster 2009-11-12 15:53:42 EST
Unfortunately a new update was pushed which omitted adding this bug to a new update to supercede the one above.  Please visit:

https://admin.fedoraproject.org/updates/F11/FEDORA-2009-10848

and test the version in updates-testing before it gets pushed to stable (which will happen very soon) to make sure there are no regressions.

Note You need to log in before you can comment on or make changes to this bug.