Bug 499940 - plymouth upgrades from F-10 doesn't work right.
plymouth upgrades from F-10 doesn't work right.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: plymouth (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Target
  Show dependency treegraph
 
Reported: 2009-05-09 05:15 EDT by Joachim Frieben
Modified: 2009-05-14 17:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-14 17:22:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2009-05-09 05:15:17 EDT
Description of problem:


Version-Release number of selected component (if applicable):
plymouth-0.7.0-0.2009.05.08.1.fc11.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Boot system with rhgb and KMS enabled.
  
Actual results:
Progress bar animation is used.

Expected results:
Spinfinity theme is used.

Additional info:
- Spinfinity theme used to work for previous versions of plymouth.

- Content of plugin directory reads
   lrwxrwxrwx. 1 root root    13 2009-04-30 16:32 default.so -> spinfinity.so*
   -rwxr-xr-x. 1 root root 11712 2009-05-08 20:29 details.so*
   -rwxr-xr-x. 1 root root  9032 2009-05-08 20:29 label.so*
   -rwxr-xr-x. 1 root root 19744 2009-05-08 20:29 spinfinity.so*
   -rwxr-xr-x. 1 root root 13688 2009-05-08 20:29 text.so*

- Installed packages include
   plymouth-0.7.0-0.2009.05.08.1.fc11.x86_64
   plymouth-gdm-hooks-0.7.0-0.2009.05.08.1.fc11.x86_64
   plymouth-libs-0.7.0-0.2009.05.08.1.fc11.x86_64
   plymouth-plugin-label-0.7.0-0.2009.05.08.1.fc11.x86_64
   plymouth-plugin-spinfinity-0.7.0-0.2009.05.08.1.fc11.x86_64
   plymouth-scripts-0.7.0-0.2009.05.08.1.fc11.x86_64
   plymouth-utils-0.7.0-0.2009.05.08.1.fc11.x86_64
Comment 1 Joachim Frieben 2009-05-09 05:16:21 EDT
Same regression observed on an Intel P4 i686 system.
Comment 2 Joachim Frieben 2009-05-09 05:18:53 EDT
Description of problem:
Plymouth only shows simple bar animation instead of spinfinity theme after update to version 0.7.0-0.2009.05.08.1.fc11. The default plugin link default.so points to spinfinity.so though.
Comment 3 Ray Strode [halfline] 2009-05-09 21:54:50 EDT
Do you have plymouth-system-theme installed?

Does running plymouth-set-default-theme spinfinity fix it?

We switched to the "charge" theme recently, I'm guessing what happened is:

- there's nothing to pull in charge on upgrades because you didn't have plymouth-system-theme installed
- We changed the way plugins work so defualt.so isn't how the default is picked anymore.
Comment 4 Joachim Frieben 2009-05-10 02:30:01 EDT
- Running 'yum install plymouth-system-theme' results in

    Installed: plymouth-plugin-two-step-0.7.0-0.2009.05.08.1.fc11.x86_64
    Installed: plymouth-theme-charge-0.7.0-0.2009.05.08.1.fc11.x86_64
    Installed: plymouth-system-theme-0.7.0-0.2009.05.08.1.fc11.x86_64

  However, upon reboot, the bar animation is still the active on.

- Running 'plymouth-set-default-theme' returns

  $ plymouth-set-default-theme spinfinity
  /usr/share/plymouth/themes/spinfinity/spinfinity.plymouth does not exist

  After running 'yum install plymouth-spinfinity-theme' as well and
  another 'plymouth-set-default-theme spinfinity', the shutdown screen
  shows the spinfinity background but without animation. Upon startup,
  the usual bar animation is displayed.

  $ ls -l /usr/share/plymouth/themes/
  total 16
  drwxr-xr-x. 2 root root 4096 2009-05-10 08:04 charge/
  lrwxrwxrwx. 1 root root   30 2009-05-10 08:16 default.plymouth
    -> spinfinity/spinfinity.plymouth
  drwxr-xr-x. 2 root root 4096 2009-05-09 07:54 details/
  drwxr-xr-x. 2 root root 4096 2009-05-10 08:13 spinfinity/
  drwxr-xr-x. 2 root root 4096 2009-05-09 07:54 text/

  The kernel command line reads:
  ro root=/dev/mapper/VolGroup00-LogVol00 rhgb quiet
Comment 5 Joachim Frieben 2009-05-12 08:28:13 EDT
For current "rawhide", the situation has slightly evolved:
- boot up:  "charge" animation even when default theme "spinfinity" has been
            chosen for plymouth.
- shutdown: * "charge" animation for default theme "charge"
            * "spinfinity" background for default theme "spinfinity" but
              without animation
Comment 6 Ray Strode [halfline] 2009-05-13 22:30:08 EDT
Note after setting a default theme you have to rebuild your initrd with

/usr/libexec/plymouth/plymouth-update-initrd

for the settings to take effect at boot up.  The shutdown behavior is expected (see bug 499274)

To be clear, the real problem here is we didn't do comps right in F10, so you never had plymouth-system-theme installed to migrate you to the new theme.

There's also a problem where plymouth-theme-spinfinity and plymouth-plugin-spinfinity now collectively do what just plymouth-plugin-spinfinity did before, so somehow we need to get rpm to pull in plymouth-theme-spinfinity on upgrade.
Comment 7 Ray Strode [halfline] 2009-05-13 22:47:51 EDT
So thinking about this more. The spinfinity plugin should really be called throbber-progress or throbgress or something, since it's only the art that makes it spinfinity, the plugin itself gets its art from the theme.

So my plan is:

1) rename plugin-spinfinity to plugin-throbgress
2) Make plymouth-theme-spinfinity obsolete/provides plymouth-plugin-spinfinity

I still don't know how i'm going to get plymouth-system-theme on people's systems though.  Needs more thought...
Comment 8 Joachim Frieben 2009-05-14 01:29:25 EDT
Ok, after running

  $ plymouth-set-default-theme spinfinity
  $ /usr/libexec/plymouth/plymouth-update-initrd

the "spinfinity" animation is back and running. I'm not sure whether disabling the animation on shutdown is a smart move. Facing a static background which used to show some signs of life on start-up gives you the uncomfortable feeling that something is going wrong here.
Comment 9 Joachim Frieben 2009-05-14 09:38:52 EDT
I had actually observed this issue on a "rawhide" system installed from scratch 2 weeks ago, thus the reference to F10 in the new title is not quite exact, although these systems would represent the majority of affected systems after the release of F11.
Comment 10 Ray Strode [halfline] 2009-05-14 13:57:10 EDT
okay i'm building

plymouth-0.7.0-0.2009.05.14.1

now that should make sure users who had plugins installed go their corresponding themes on upgrade.

The comps mistake is unfixable given our upgrade infrastructure, I think.  People who did fresh installs of F-10 (or early F-11 prereleases) won't get "charge" on upgrade to F-11.

Funnily, people who do F-9 fresh installs and upgrade to F-11 will however (since upgrading from rhgb to plymouth causes plymouth-system-theme to get installed)...
Comment 11 Ray Strode [halfline] 2009-05-14 15:57:32 EDT
Okay I've got a better solution building now into: plymouth-0.7.0-0.2009.05.14.2

We now make solar Requires: plymouth-system-plugin to correct the comps snafu.

This means upgrades will do the right thing by default, but people who want solar will have to install charge as well.  That seems like a lesser of two evils.

Note You need to log in before you can comment on or make changes to this bug.