Bug 499958 - Reconnecting a USB keyboard does not restore auto-repeat
Reconnecting a USB keyboard does not restore auto-repeat
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-settings-daemon (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
: Triaged
: 565395 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-09 10:21 EDT by Richard Körber
Modified: 2010-10-27 10:28 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-27 10:28:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (151.20 KB, text/plain)
2009-05-13 14:12 EDT, Richard Körber
no flags Details

  None (edit)
Description Richard Körber 2009-05-09 10:21:02 EDT
Description of problem:
After reconnecting a USB keyboard, the default auto-repeat delay and rate is used. The user's auto-repeat parameters are not restored.

When using a USB capable KVM switch, this means that the user's auto-repeat parameters are gone when switching back to the machine.

Version-Release number of selected component (if applicable):
xorg-x11-drv-evdev-2.2.1-3.fc11.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Change your auto-repeat settings. For example, increase the auto-repeat rate to something you would notice.
2. Disconnect your USB keyboard, then reconnect it. Alternatively, use a KVM switch to switch to another machine, then switch back.
3. Test the auto-repeat settings by pressing a key.

Actual results:
The keyboard is reset to the default auto-repeat parameters.

Expected results:
The user's auto-repeat parameters are actually set.

Additional info:
On F10, the user's auto-repeat parameters were restored, so this seems to be a regression in Rawhide.
Comment 1 Matěj Cepl 2009-05-12 17:52:46 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Richard Körber 2009-05-13 14:12:19 EDT
Created attachment 343837 [details]
Xorg.0.log

Xorg.0.log before disconnecting the keyboard.

There is no xorg.conf file.
Comment 3 Richard Körber 2009-05-13 14:14:20 EDT
(Note: this is the very same log file as in Bug 499961.)

After disconnecting the keyboard, these lines were appended to the logfile:

(II) config/hal: removing device Microsoft Microsoft? Digital Media Keyboard 3000
(II) Microsoft Microsoft? Digital Media Keyboard 3000: Close
(II) UnloadModule: "evdev"
(II) config/hal: removing device Microsoft Microsoft? Digital Media Keyboard 3000
(II) Microsoft Microsoft? Digital Media Keyboard 3000: Close
(II) UnloadModule: "evdev"

After reconnecting the keyboard, these lines were appended to the logfile:

(II) config/hal: Adding input device Microsoft Microsoft? Digital Media Keyboard 3000
(**) Microsoft Microsoft? Digital Media Keyboard 3000: always reports core events
(**) Microsoft Microsoft? Digital Media Keyboard 3000: Device: "/dev/input/event8"
(II) Microsoft Microsoft? Digital Media Keyboard 3000: Found 1 mouse buttons
(II) Microsoft Microsoft? Digital Media Keyboard 3000: Found scroll wheel(s)
(II) Microsoft Microsoft? Digital Media Keyboard 3000: Found x and y absolute axes
(II) Microsoft Microsoft? Digital Media Keyboard 3000: Found keys
(II) Microsoft Microsoft? Digital Media Keyboard 3000: Configuring as mouse
(II) Microsoft Microsoft? Digital Media Keyboard 3000: Configuring as keyboard
(**) Microsoft Microsoft? Digital Media Keyboard 3000: YAxisMapping: buttons 4 and 5
(**) Microsoft Microsoft? Digital Media Keyboard 3000: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
(II) XINPUT: Adding extended input device "Microsoft Microsoft? Digital Media Keyboard 3000" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "pc105"
(**) Option "xkb_layout" "de"
(**) Option "xkb_options" "terminate:ctrl_alt_bksp"
(**) Microsoft Microsoft? Digital Media Keyboard 3000: (accel) keeping acceleration scheme 1
(**) Microsoft Microsoft? Digital Media Keyboard 3000: (accel) filter chain progression: 2.00
(**) Microsoft Microsoft? Digital Media Keyboard 3000: (accel) filter stage 0: 20.00 ms
(**) Microsoft Microsoft? Digital Media Keyboard 3000: (accel) set acceleration profile 0
(II) config/hal: Adding input device Microsoft Microsoft? Digital Media Keyboard 3000
(**) Microsoft Microsoft? Digital Media Keyboard 3000: always reports core events
(**) Microsoft Microsoft? Digital Media Keyboard 3000: Device: "/dev/input/event7"
(II) Microsoft Microsoft? Digital Media Keyboard 3000: Found keys
(II) Microsoft Microsoft? Digital Media Keyboard 3000: Configuring as keyboard
(II) XINPUT: Adding extended input device "Microsoft Microsoft? Digital Media Keyboard 3000" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "pc105"
(**) Option "xkb_layout" "de"
(**) Option "xkb_options" "terminate:ctrl_alt_bksp"
Comment 4 Bug Zapper 2009-06-09 11:32:37 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Thomas Fitzsimmons 2009-10-27 13:52:36 EDT
Ping.  Is anyone working on this issue?
Comment 6 Peter Hutterer 2009-10-27 21:03:26 EDT
can I assume you changed the auto-repeat in the gnome tools?
if so, this isn't an X bug. the device disappears and comes back with the default parameters. it's the desktop environment's job to change the settings when the keyboard is plugged in again, just as it did for the keyboard before.

This is true for all settings, acceleration, keyboard repeat, etc.

FWIW, the reason why this bug appears now but not in F10 was that F10 used the keyboard driver. it wouldn't see your keyboard but the generic keyboard provided by the kernel (/dev/console). all hotplugging was handled in the kernel, X never noticed that the device disappeared.
Comment 7 Thomas Fitzsimmons 2009-10-27 21:20:33 EDT
(In reply to comment #6)
> can I assume you changed the auto-repeat in the gnome tools?

Yes.

> if so, this isn't an X bug.

OK, to which component should this bug report be assigned?
Comment 8 Richard Körber 2009-11-20 15:01:25 EST
I could still reproduce this bug with Fedora 12. Changing version to '12'.

Anyhow I found out that when toggling the Numlock state after USB reconnection, the auto-repeat settings are restored now.
Comment 9 Fedora Update System 2010-03-10 06:29:39 EST
gnome-settings-daemon-2.28.1-13.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/gnome-settings-daemon-2.28.1-13.fc12
Comment 10 Thomas Fitzsimmons 2010-03-10 12:18:06 EST
Just tested gnome-settings-daemon-2.28.1-13.fc12 on my i686 Fedora 12 machine and confirmed that the auto-repeat settings are properly applied after I reconnect my USB keyboard.  Thanks!
Comment 11 Fedora Update System 2010-03-11 02:26:01 EST
gnome-settings-daemon-2.28.1-13.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnome-settings-daemon'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/gnome-settings-daemon-2.28.1-13.fc12
Comment 12 Bastien Nocera 2010-03-11 05:27:25 EST
*** Bug 565395 has been marked as a duplicate of this bug. ***
Comment 13 Bastien Nocera 2010-10-27 10:28:37 EDT
Already been fixed in gnome-settings-daemon-2.28.2-1.fc12

Note You need to log in before you can comment on or make changes to this bug.