Bug 499966 - Anaconda KeyError: 'findrootparts' failure to upgrade F10 to Rawhide
Anaconda KeyError: 'findrootparts' failure to upgrade F10 to Rawhide
Status: CLOSED DUPLICATE of bug 499321
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-09 12:43 EDT by Andreas
Modified: 2009-05-11 10:02 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-11 10:02:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda Dump (67.99 KB, text/plain)
2009-05-09 12:43 EDT, Andreas
no flags Details
Anaconda Log (10.44 KB, application/octet-stream)
2009-05-09 12:45 EDT, Andreas
no flags Details
Storage Log (11.41 KB, application/octet-stream)
2009-05-09 12:46 EDT, Andreas
no flags Details
Syslog (42.85 KB, application/octet-stream)
2009-05-09 12:49 EDT, Andreas
no flags Details

  None (edit)
Description Andreas 2009-05-09 12:43:39 EDT
Created attachment 343219 [details]
Anaconda Dump

Description of problem:
Using 'preupgrade' on an up-to-date F10 (2009-05-09) to upgrade to Rawhide
failed.

failure looks like the bugs (bugzilla.redhat.com):
Bug 494102 -  Anaconda does not activate LVM volumes  
Bug 490198 -  F10: preupgrade: anaconda failure to upgrade F10 to Rawhide with LUKS/LVM partition  
Bug 493204 -  Anaconda Not Recognizing Existing Fedora 10 Install For Upgrade  

my laptop-hardware:
PCI bridge: Intel Corporation 82801 Mobile PCI Bridge
VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML
SATA controller: Intel Corporation 82801FBM (ICH6M)


Version-Release number of selected component (if applicable):
anaconda-11.5.0.51-1.fc11.i586.rpm
pyparted-2.0.12-1.fc11.i586.rpm

How reproducible:
every time

Steps to Reproduce:
1. Run network preupgrade, update to Rawhide
2. Reboot, select 'Update to Rawhide' in grub
3. Anaconda stops & doesn't show/activate LVM


Actual results:
Anaconda reports failure, see attached 'anacdump.txt'. Anaconda was not able to 'save to local storage' (which it provides as an option).


Expected results:
A successful mount of LVM and subsequent (automatically) update to Rawhide.


Additional info:

running f10-system:
fdisk -l
/dev/sda1   *           1          32      257008+  83  Linux
/dev/sda2              33       38913   312311632+  8e  Linux LVM

df -h
/dev/mapper/VolGroup00-LogVol00  292G  266G   11G  97% /
/dev/sda1                        244M  150M   81M  66% /boot
tmpfs                            1009M  1,2M 1007M   1% /dev/shm

ls -l /dev/dm-* /dev/mapper/*
brw-rw---- 1 root disk 253,  0  9. Mai 15:53 /dev/dm-0
brw-rw---- 1 root disk 253,  1  9. Mai 15:53 /dev/dm-1
crw-rw---- 1 root root  10, 63  9. Mai 15:53 /dev/mapper/control
brw-rw---- 1 root disk 253,  0  9. Mai 15:54 /dev/mapper/VolGroup00-LogVol00
brw-rw---- 1 root disk 253,  1  9. Mai 15:53 /dev/mapper/VolGroup00-LogVol01


13:45:47 CRITICAL: anaconda 11.5.0.51 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/gui.py", line 1377, in setScreen
    if not stepToClass[step]:
  File "/usr/lib/anaconda/gui.py", line 1535, in setup_window
    self.setScreen()
  File "/usr/lib/anaconda/gui.py", line 1545, in run
    self.setup_window(runres)
  File "/usr/lib/anaconda/gui.py", line 1292, in run
    self.icw.run (self.runres)
  File "/usr/bin/anaconda", line 966, in <module>
    anaconda.intf.run(anaconda)
KeyError: 'findrootparts'


OK, that's all I know and find out.
Comment 1 Andreas 2009-05-09 12:45:21 EDT
Created attachment 343220 [details]
Anaconda Log
Comment 2 Andreas 2009-05-09 12:46:29 EDT
Created attachment 343221 [details]
Storage Log
Comment 3 Andreas 2009-05-09 12:49:21 EDT
Created attachment 343222 [details]
Syslog
Comment 4 Maxim Evdokimov 2009-05-10 08:19:39 EDT
possible clone of Bug 499321 ?
Comment 5 Chris Lumens 2009-05-11 10:02:23 EDT

*** This bug has been marked as a duplicate of bug 499321 ***

Note You need to log in before you can comment on or make changes to this bug.