Bug 499972 - port to PolicyKit 1.0
port to PolicyKit 1.0
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-applets (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-09 13:25 EDT by Matthias Clasen
Modified: 2009-06-10 01:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-10 01:05:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch (19.49 KB, patch)
2009-05-15 00:04 EDT, Matthias Clasen
no flags Details | Diff

  None (edit)
Description Matthias Clasen 2009-05-09 13:25:13 EDT
We are going to land polkit 1.0 in F12 soon. This is going to require changes
to polkit using applications. Thankfully, mostly simplifications.

See http://fedoraproject.org/wiki/Features/PolicyKitOne  

In the case of gnome-applets, only the cpufreq applet uses PolicyKit, and there is no mechanism separation, so it is just 'fake'. We should either just drop cpufreq applet or build without PolicyKit support, I think.
Comment 1 Matthias Clasen 2009-05-15 00:04:58 EDT
Created attachment 344073 [details]
patch
Comment 2 darrell pfeifer 2009-06-01 09:38:52 EDT
Installed 2.27.2-1.fc12

Cannot start the virtual machine manager or the power manager. They both bring up the gnome crash dialog. Reverting to gnome-applets-2.27.1-1.fc12.i586 makes the problem go away.

I have selinux off.

Note also

https://bugzilla.redhat.com/show_bug.cgi?id=496493

In this case though, I am using still using

policycoreutils-2.0.62-12.2.fc11.i586

since the newer version was causing the problems in 496493. I haven't tried the newer version of policycoreutils with the gnome applets 2.27.2 to see if it is successful.
Comment 3 Matthias Clasen 2009-06-01 10:20:38 EDT
You are in the wrong bug.
Comment 4 darrell pfeifer 2009-06-01 10:35:07 EDT
Which bug should I be in? Can you point me to a better place?

If gnome-applets-2.27.2-1.fc12 is installed then choosing gnome applications from the menu that require root privs die. Reverting to 2.27.1-1.fc12 makes the problem go away.

This bug is for changes to polkit that appear in f12, which is what I installed.
Comment 5 Matthias Clasen 2009-06-01 11:05:28 EDT
The patch in this bug has not been applied yet, so it can hardly be responsible for your problems.
Comment 6 Bug Zapper 2009-06-09 11:33:24 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Matthias Clasen 2009-06-10 01:05:54 EDT
built in gnome-applets-2.27.2-2.fc12
Comment 8 Matthias Clasen 2009-06-10 01:08:24 EDT
upstream: http://bugzilla.gnome.org/show_bug.cgi?id=585309

Note You need to log in before you can comment on or make changes to this bug.