Bug 500439 - Traceback when enabling updates repo
Traceback when enabling updates repo
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 500526 (view as bug list)
Depends On:
Blocks: F11AnacondaBlocker
  Show dependency treegraph
 
Reported: 2009-05-12 13:23 EDT by Jesse Keating
Modified: 2013-01-09 22:30 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 503128 (view as bug list)
Environment:
Last Closed: 2009-05-29 19:22:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2009-05-12 13:23:42 EDT
I can't get the traceback because of another bug blocking the save dialog, but the last lines is:

IOError: [Error 2] No such file or directory: '/mnt/sysimage/var/cache/yum/updates/repomd.xml'

tty1 shows:
Could not parse metalink https://mirrors.fedoraproject.org/metalink?repo=updates-released-frawhide@arch-x86_64 error was
File /mnt/sysimage/var/cache/yum/updates/metalink.xml.tmp is not XML


So there is multiple problems.  1) the "frawhide" thing, we could probably work with that in mirrormanager.  Release is rawhide so yeah.  The second thing is we shouldn't traceback when this hits, we should fail gracefully.
Comment 1 Chris Lumens 2009-05-13 09:15:14 EDT
*** Bug 500526 has been marked as a duplicate of this bug. ***
Comment 2 Chris Lumens 2009-05-13 14:06:48 EDT
This should be fixed in the next build of anaconda, though I think Jeremy's planning on doing something in yum to prevent us from ever getting an IOError.
Comment 3 Jens Petersen 2009-05-14 20:37:07 EDT
I still see this with -52 btw.
Comment 4 Jens Petersen 2009-05-27 19:21:44 EDT
When will it say "Fedora 11 Updates" in the anaconda repo list?

Anyway anaconda is still getting confusing with "Fedora development - Updates" with anaconda -56.  No obvious backtrace but hangs.

tty1 still says:

Could not parse metalink https://mirrors.fedoraproject.org/metalink?repo=updates-released-fdevelopment&arch=i386 error was
File /mnt/sysimage/var/cache/yum/updates/metalink.xml.tmp is not XML

Anyway I also opened https://fedorahosted.org/mirrormanager/ticket/12 in the hope the MM might handle this more gracefully too.
Comment 5 Jesse Keating 2009-05-27 19:36:25 EDT
It'll say Fedora 11 Updates when it's composed as Fedora 11.
Comment 6 Matt Domsch 2009-05-28 00:03:24 EDT
the updates*-fdevelopment metalinks now point to -f11.
Comment 7 Jens Petersen 2009-05-28 03:22:59 EDT
Thanks Matt - that helps a lot.

Dunno if we should open another bug for the non-xml case?
Comment 8 Matt Domsch 2009-05-28 08:31:43 EDT
Jens, can you elaborate?  On the mirrorlist=... non-metalink, the behavior will be exactly the same from MM's perspective.  The redirect happens early, long before the output format is decided upon.
Comment 9 Jens Petersen 2009-05-28 19:28:34 EDT
(In reply to comment #8)
> Jens, can you elaborate?  On the mirrorlist=... non-metalink, the behavior will
> be exactly the same from MM's perspective.  The redirect happens early, long
> before the output format is decided upon.  

Matt, I guess the problem is that the error page was not valid XML, which confused anaconda - so I dunno if MM should output valid XML even if there is an error or anaconda should handle the text error output (non-XML) better - I suspect probably the latter?  Otherwise probably hard to separate them?
Comment 10 Matt Domsch 2009-05-28 19:36:16 EDT
MM returns an "empty" xml document and HTTP 404 in the event of a failed request.

    doc += '<?xml version="1.0" encoding="utf-8"?>\n'
    doc += '<!--\n'
    doc += '%s/%s not found or has no metalink\n' % (directory, file)
    doc += '-->\n'


That's all I could think to do in MM.
Comment 12 Matt Domsch 2009-05-29 00:04:49 EDT
that is a bug in MM then.  I opened another bug to track that separately.
Comment 13 James Laska 2009-05-29 10:20:57 EDT
(In reply to comment #7)
> Thanks Matt - that helps a lot.
> 
> Dunno if we should open another bug for the non-xml case?  

Jens, does this imply you have tested the fix mdomsch provided in comment#6.  

Can we move this issue to CLOSED RAWHIDE?
Comment 14 Jens Petersen 2009-05-29 19:22:18 EDT
Yes, install with "devel" updates seems fine now.

Note You need to log in before you can comment on or make changes to this bug.