Bug 500526 - enable updates repo backtrace
enable updates repo backtrace
Status: CLOSED DUPLICATE of bug 500439
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:c2d9629e5c56ecf0b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-13 00:56 EDT by Jens Petersen
Modified: 2009-05-13 09:15 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-13 09:15:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (147.40 KB, text/plain)
2009-05-13 00:56 EDT, Jens Petersen
no flags Details

  None (edit)
Description Jens Petersen 2009-05-13 00:56:00 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.51 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.6/site-packages/yum/repoMDObject.py", line 84, in __init__
    infile = open(srcfile, 'rt')
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 958, in _parseRepoXML
    return repoMDObject.RepoMD(self.id, local)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1158, in _commonLoadRepoXML
    self._repoXML = self._parseRepoXML(result)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1303, in _groupLoadRepoXML
    if self._commonLoadRepoXML(text):
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1319, in _loadRepoXML
    return self._groupLoadRepoXML(text, ["primary"])
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1329, in _getRepoXML
    self._loadRepoXML(text=self)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1337, in <lambda>
    repoXML = property(fget=lambda self: self._getRepoXML(),
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1174, in _check_db_version
    repoXML = self.repoXML
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 220, in _check_db_version
    return repo._check_db_version(mdtype)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 162, in populate
    if self._check_db_version(repo, mydbtype):
  File "/usr/lib/python2.6/site-packages/yum/repos.py", line 260, in populateSack
    sack.populate(repo, mdtype, callback, cacheonly)
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 488, in _getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 464, in doSackSetup
    return self._getSacks(archlist=archlist, thisrepo=thisrepo)
  File "/usr/lib/anaconda/yuminstall.py", line 1082, in <lambda>
    self.__withFuncDo(anaconda, lambda r: self.ayum.doSackSetup(thisrepo=r.id),
  File "/usr/lib/anaconda/yuminstall.py", line 1109, in __withFuncDo
    fn(repo)
  File "/usr/lib/anaconda/yuminstall.py", line 1083, in doSackSetup
    thisrepo=thisrepo, fatalerrors=fatalerrors)
  File "/usr/lib/anaconda/iw/task_gui.py", line 45, in setupRepo
    anaconda.backend.doSackSetup(anaconda, thisrepo=repo.id, fatalerrors=False)
  File "/usr/lib/anaconda/iw/task_gui.py", line 543, in _repoToggled
    if not setupRepo(self.anaconda, repo):
IOError: [Errno 2] No such file or directory: '/mnt/sysimage/var/cache/yum/updates/repomd.xml'
Comment 1 Jens Petersen 2009-05-13 00:56:06 EDT
Created attachment 343695 [details]
Attached traceback automatically from anaconda.
Comment 2 Chris Lumens 2009-05-13 09:15:14 EDT

*** This bug has been marked as a duplicate of bug 500439 ***

Note You need to log in before you can comment on or make changes to this bug.