Bug 50044 - Changing the mouse type in anaconda GUI doesn't change the mouse type during installation
Changing the mouse type in anaconda GUI doesn't change the mouse type during ...
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
: 50045 50047 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-26 06:58 EDT by Bernhard Rosenkraenzer
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-30 14:33:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernhard Rosenkraenzer 2001-07-26 06:58:44 EDT
Install beta3 on a Notebook with an internal PS/2 touchpad and a 
connected USB mouse.
When anaconda's mouse setup comes up, pick "Generic USB 3 Button mouse". 
Click OK.

You still can't use the external mouse during installation.

Mouse settings after installation are ok.
Comment 1 Glen Foster 2001-07-26 08:01:03 EDT
*** Bug 50045 has been marked as a duplicate of this bug. ***
Comment 2 Glen Foster 2001-07-26 08:02:27 EDT
*** Bug 50047 has been marked as a duplicate of this bug. ***
Comment 3 Bernhard Rosenkraenzer 2001-07-26 08:04:32 EDT
[the duplicates were caused by network flakiness - got timeouts on submission]

Comment 4 Brent Fox 2001-07-26 15:44:07 EDT
Were you trying NFS, FTP, or HTTP?
Comment 5 Bernhard Rosenkraenzer 2001-07-26 15:48:33 EDT
Umm... The problem doesn't have anything to do with the installation method. 
It's quite reproducable with all NFS, FTP, HTTP and CD-ROM installation 
methods.

The comment on network flakiness was just explaining why I submitted the bug 3 
times - "Submit Bug" gave me timeout error messages, but apparently, the bug 
got into the database nevertheless. You can safely ignore that part.
Comment 6 Brent Fox 2001-07-26 17:53:57 EDT
I don't see this with either CDROM or NFS installs on my Compaq Presario 1700T
laptop with a Logitec USB wheel mouse.
Comment 7 Brent Fox 2001-07-26 17:55:24 EDT
What kind of laptop?
Comment 8 Bernhard Rosenkraenzer 2001-07-30 10:15:11 EDT
Dell Latitude C800
Comment 9 Glen Foster 2001-07-30 14:33:53 EDT
Brent, is this behavior even "fixable"?
Comment 10 Brent Fox 2001-08-03 12:35:04 EDT
I don't think that this is something I can fix.  The mouse that you pick during
installation has no effect on the mouse at that time.  It won't take effect
until X is restarted, which in this case means rebooting the machine after
installation.  

I think it is up to the BIOS to decide which mouse it is going to use during
installation.  On my Compaq, if I plug in a USB mouse, it disables the onboard
mouse.  It seems that the Dell laptops behave differently.  There's not much we
can do about that.
Comment 11 Bernhard Rosenkraenzer 2001-08-03 12:37:46 EDT
Except for restarting X if the mouse settings have changed.
Comment 12 Bernhard Rosenkraenzer 2001-08-03 12:38:28 EDT
Or, alternatively, doing the right thing(tm) and making X mouse drivers modular so 
it can handle changes at runtime... *runs*

Note You need to log in before you can comment on or make changes to this bug.