Bug 500473 - hp-setup fails because of missing dependency to hplip-gui
Summary: hp-setup fails because of missing dependency to hplip-gui
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: hplip
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 510164 (view as bug list)
Depends On:
Blocks: 516998 553572
TreeView+ depends on / blocked
 
Reported: 2009-05-12 20:20 UTC by Mads Kiilerich
Modified: 2010-03-17 15:01 UTC (History)
2 users (show)

Fixed In Version: 3.9.8-12.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 553572 (view as bug list)
Environment:
Last Closed: 2009-08-31 23:30:36 UTC


Attachments (Terms of Use)

Description Mads Kiilerich 2009-05-12 20:20:12 UTC
Description of problem:

[root@localhost tmp]# hp-setup 

HP Linux Imaging and Printing System (ver. 3.9.2)
Printer/Fax Setup Utility ver. 8.0

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

error: Unable to load Qt4 support. Is it installed?


More specifically, it is import of ui4.setupdialog that fails.

Installing hplip-gui solves the problem.

I assume the packages are split for a valid reason, but apparently it has to be split another way.

(Note that hplip-gui has a dependency to qt3 even though hp-setup can/will use qt4. That makes this issue extra weird.)


Version-Release number of selected component (if applicable):

hplip-3.9.2-4.fc11.i586

Comment 1 Tim Waugh 2009-05-12 21:29:48 UTC
hp-setup can be run with options that don't require a graphical interface.

Comment 2 Mads Kiilerich 2009-05-12 21:51:17 UTC
Ok. 

But the default is to use a graphical interface, and when it fails to load that then it is far from obvious how to resolve that.

Please consider patching the check or the error message to say what failed and hint how it can be resolved. Reading the source to make it work should be an option, not a requirement ;-)

Comment 3 Tim Waugh 2009-07-08 09:21:29 UTC
*** Bug 510164 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2009-07-29 21:29:06 UTC
hplip-3.9.6b-3.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hplip'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6959

Comment 5 Fedora Update System 2009-08-05 00:29:24 UTC
hplip-3.9.6b-5.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hplip'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6959

Comment 6 Fedora Update System 2009-08-07 04:58:40 UTC
hplip-3.9.8-2.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hplip'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6959

Comment 7 Fedora Update System 2009-08-15 21:42:30 UTC
hplip-3.9.8-4.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hplip'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6959

Comment 8 Fedora Update System 2009-08-19 23:17:38 UTC
hplip-3.9.8-6.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hplip'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6959

Comment 9 Fedora Update System 2009-08-25 22:13:23 UTC
hplip-3.9.8-9.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hplip'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6959

Comment 10 Fedora Update System 2009-08-27 02:10:36 UTC
hplip-3.9.8-10.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hplip'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6959

Comment 11 Fedora Update System 2009-08-28 21:57:17 UTC
hplip-3.9.8-12.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hplip'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6959

Comment 12 Fedora Update System 2009-08-31 23:29:48 UTC
hplip-3.9.8-12.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Mads Kiilerich 2010-03-17 09:43:30 UTC
For the record: It seems like the problem was resolved by changing the error messages a bit:

[root@localhost ~]# yum groupinstall printing
... hplip-3.10.2-1.fc12.i686 ...
[root@localhost ~]# hp-setup 

HP Linux Imaging and Printing System (ver. 3.10.2)
Printer/Fax Setup Utility ver. 9.0

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

error: Install the hplip-gui package for graphical support.
warning: Qt/PyQt 4 initialization failed.
error: hp-setup requires GUI support (try running with --qt3). Also, try using interactive (-i) mode.

Comment 14 Tim Waugh 2010-03-17 10:09:02 UTC
Yes, as suggested in comment #2.

Comment 15 Mads Kiilerich 2010-03-17 14:46:31 UTC
Yes, that is better than before. But still not something my mother could figure out ;-)

FWIW I didn't notice the hint about installing hplip-gui, so I had to dig out this old issue to find out what the name of the missing package was and what the resolution really was.

Perhaps it could be improved to be:

warning: Qt/PyQt 4 initialization failed.
error: hp-setup GUI support is not available. Install the hplip-gui package or use interactive (-i) mode.    

(i.e.
* One single error line on the list line
* Explain what is wrong - don't tag the proposed solution as an error.
* Don't confuse the user by mentioning qt3
)

(But still I don't understand why a package without gui tries to import qt ...)

I hope it has been improved with F13. Either by installing the package by default or using PackageKit or splitting it up - or in my dreams a nice Open Source solution ...

Comment 16 Tim Waugh 2010-03-17 15:01:30 UTC
(In reply to comment #15)
> Yes, that is better than before. But still not something my mother could figure out ;-)

I don't know about your mother, but mine would not be trying to run things on the command line in the first place. ;-)

The recommended way of configuring printers is with system-config-printer via System->Administration->Printing.

> I hope it has been improved with F13. Either by installing the package by
> default or using PackageKit or splitting it up - or in my dreams a nice Open
> Source solution ...    

It already *is* split up.  You can run hp-setup without any graphical environment present, and so it is in the main package, not the gui sub-package.

It's a shame that hp-setup doesn't automatically run in "text" mode in this situation, but honestly it's more of a shame that hp-setup is needed at all.


Note You need to log in before you can comment on or make changes to this bug.