Bug 510164 - Hplip commands fail report errors about unable to load Qt4 support
Hplip commands fail report errors about unable to load Qt4 support
Status: CLOSED DUPLICATE of bug 500473
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-07 20:40 EDT by Brian G. Anderson
Modified: 2009-07-08 05:21 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-08 05:21:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian G. Anderson 2009-07-07 20:40:43 EDT
Description of problem:
When trying to run hplip commands like hp-info will stop with the following message:
   error: Unable to load Qt4 support. Is it installed?

However I have qt installed, but even if I didn't why isn't the dependency installed for me?

Version-Release number of selected component (if applicable):
hplip-3.9.2-4.fc11.x86_64
qt-x11-4.5.1-13.fc11.x86_64
qt-4.5.1-13.fc11.x86_64


How reproducible:
Everytime

Steps to Reproduce:
1. invoke hp-info
2.
3.
  
Actual results:
stops with error

Expected results:
no errors

Additional info:
Comment 1 Tim Waugh 2009-07-08 05:20:04 EDT
The package you need is PyQt4.

The reason it isn't a dependency of the 'hplip' package is that many of those tools can run in 'interactive' mode on the console.

Install the hplip-gui package to get the graphical parts.

The error messages probably need to be updated to reflect that.
Comment 2 Tim Waugh 2009-07-08 05:21:29 EDT

*** This bug has been marked as a duplicate of bug 500473 ***

Note You need to log in before you can comment on or make changes to this bug.